maven-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From slachiew...@apache.org
Subject [maven] 01/01: [MNG-6512] PoC - set minimum JDK to 11 to test compilation/test problems
Date Mon, 03 Dec 2018 00:52:19 GMT
This is an automated email from the ASF dual-hosted git repository.

slachiewicz pushed a commit to branch MNG-6512-build-11
in repository https://gitbox.apache.org/repos/asf/maven.git

commit 98332d4f9ac396be78188f94e4352a90ae07b646
Author: Sylwester Lachiewicz <slachiewicz@apache.org>
AuthorDate: Sat Nov 10 13:22:41 2018 +0100

    [MNG-6512] PoC - set minimum JDK to 11 to test compilation/test problems
    
    - enforcer update extras o 1.1 (have support for Java 11 and 12-ea)
    - skip sniffer - not important with compiler plugin release tag
    - update Plexus metadata plugin to snapshot version (Java 11 support)
---
 Jenkinsfile | 14 +++++---------
 pom.xml     | 46 +++++++++++++++++++++++++++++++++++++---------
 2 files changed, 42 insertions(+), 18 deletions(-)

diff --git a/Jenkinsfile b/Jenkinsfile
index ceb179d..231aaa1 100644
--- a/Jenkinsfile
+++ b/Jenkinsfile
@@ -20,11 +20,11 @@
 properties([buildDiscarder(logRotator(artifactNumToKeepStr: '5', numToKeepStr: env.BRANCH_NAME=='master'?'10':'5'))])
 
 def buildOs = 'linux'
-def buildJdk = '8'
-def buildMvn = '3.5.4'
+def buildJdk = '11'
+def buildMvn = '3.6.0'
 def runITsOses = ['linux', 'windows']
-def runITsJdks = ['7', '8', '11']
-def runITsMvn = '3.5.4'
+def runITsJdks = ['11']
+def runITsMvn = '3.6.0'
 def runITscommand = "mvn clean install -Prun-its,embedded -B -U -V" // -DmavenDistro=...
-Dmaven.test.failure.ignore=true
 def tests
 
@@ -93,11 +93,7 @@ for (String os in runITsOses) {
                             junitPublisher(ignoreAttachments: false)
                         ]) {
                             String cmd = "${runITscommand} -DmavenDistro=$WORK_DIR/apache-maven-dist.zip
-Dmaven.test.failure.ignore=true"
-                            if (stageId.endsWith('-jdk7')) {
-                              // Java 7u80 has TLS 1.2 disabled by default: need to explicitly
enable
-                              cmd = "${cmd} -Dhttps.protocols=TLSv1.2"
-                            }
-                            
+
                             if (isUnix()) {
                                 sh "${cmd}"
                             } else {
diff --git a/pom.xml b/pom.xml
index d504e02..b3f360b 100644
--- a/pom.xml
+++ b/pom.xml
@@ -1,4 +1,4 @@
-<?xml version="1.0" encoding="UTF-8"?>
+<?xml version="1.0" encoding="UTF-8"?>
 
 <!--
 Licensed to the Apache Software Foundation (ASF) under one
@@ -46,15 +46,16 @@ under the License.
   <inceptionYear>2001</inceptionYear>
 
   <properties>
+    <javaVersion>11</javaVersion>
     <maven.version>3.0.5</maven.version>
-    <maven.compiler.source>1.7</maven.compiler.source>
-    <maven.compiler.target>1.7</maven.compiler.target>
+    <maven.compiler.source>11</maven.compiler.source>
+    <maven.compiler.target>11</maven.compiler.target>
     <classWorldsVersion>2.5.2</classWorldsVersion>
     <commonsCliVersion>1.4</commonsCliVersion>
     <commonsLangVersion>3.8.1</commonsLangVersion>
     <junitVersion>4.12</junitVersion>
     <mockitoVersion>2.21.0</mockitoVersion>
-    <plexusVersion>1.7.1</plexusVersion>
+    <plexusVersion>1.8-SNAPSHOT</plexusVersion>
     <plexusInterpolationVersion>1.25</plexusInterpolationVersion>
     <plexusUtilsVersion>3.1.0</plexusUtilsVersion>
     <guiceVersion>4.2.1</guiceVersion>
@@ -552,15 +553,23 @@ under the License.
     </pluginManagement>
     <plugins>
       <plugin>
+        <artifactId>maven-enforcer-plugin</artifactId>
+        <version>3.0.0-M2</version>
+		<dependencies>
+			<dependency>
+              <groupId>org.codehaus.mojo</groupId>
+              <artifactId>extra-enforcer-rules</artifactId>
+              <version>1.1</version>
+			</dependency>
+		</dependencies>
+      </plugin>
+
+      <plugin>
         <groupId>org.codehaus.mojo</groupId>
         <artifactId>animal-sniffer-maven-plugin</artifactId>
         <version>1.15</version>
         <configuration>
-          <signature>
-            <groupId>org.codehaus.mojo.signature</groupId>
-            <artifactId>java17</artifactId>
-            <version>1.0</version>
-          </signature>
+          <skip>true</skip><!-- no rules for Java 11 yet -->
         </configuration>
         <executions>
           <execution>
@@ -687,5 +696,24 @@ under the License.
         </plugins>
       </build>
     </profile>
+    <profile>
+      <id>jdk11plus</id>
+      <activation>
+        <jdk>[11,)</jdk>
+      </activation>
+      <build>
+        <pluginManagement>
+          <plugins>
+            <plugin>
+              <groupId>org.apache.maven.plugins</groupId>
+              <artifactId>maven-compiler-plugin</artifactId>
+              <configuration>
+                <release>11</release>
+              </configuration>
+            </plugin>
+          </plugins>
+        </pluginManagement>
+      </build>
+    </profile>
   </profiles>
 </project>


Mime
View raw message