maven-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rfscho...@apache.org
Subject svn commit: r1647008 - /maven/plugins/trunk/maven-compiler-plugin/src/it/mcompiler-179/verify.groovy
Date Sat, 20 Dec 2014 15:51:01 GMT
Author: rfscholte
Date: Sat Dec 20 15:51:00 2014
New Revision: 1647008

URL: http://svn.apache.org/r1647008
Log:
Make verify-script JDK9 proof (hopefully they won't change the message...)

Modified:
    maven/plugins/trunk/maven-compiler-plugin/src/it/mcompiler-179/verify.groovy

Modified: maven/plugins/trunk/maven-compiler-plugin/src/it/mcompiler-179/verify.groovy
URL: http://svn.apache.org/viewvc/maven/plugins/trunk/maven-compiler-plugin/src/it/mcompiler-179/verify.groovy?rev=1647008&r1=1647007&r2=1647008&view=diff
==============================================================================
--- maven/plugins/trunk/maven-compiler-plugin/src/it/mcompiler-179/verify.groovy (original)
+++ maven/plugins/trunk/maven-compiler-plugin/src/it/mcompiler-179/verify.groovy Sat Dec 20
15:51:00 2014
@@ -21,5 +21,15 @@ def logFile = new File( basedir, 'build.
 assert logFile.exists()
 content = logFile.text
 
-assert content.contains( '1 warning' )
+// JDK (,1.9): 1 warning: 
+// [WARNING] bootstrap class path not set in conjunction with -source 1.6
+// [INFO] 1 warning
+// 
+// JDK [1.9,):
+// [WARNING] bootstrap class path not set in conjunction with -source 1.6
+// [WARNING] source value 1.6 is obsolete and will be removed in a future release
+// [WARNING] target value 1.6 is obsolete and will be removed in a future release
+// [WARNING] To suppress warnings about obsolete options, use -Xlint:-options.
+// [INFO] 4 warnings 
+assert content.contains( '[WARNING] bootstrap class path not set in conjunction with -source
1.6' )
 assert content.contains( '1 error' )



Mime
View raw message