maven-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From pg...@apache.org
Subject svn commit: r1243270 - in /maven/enforcer/trunk/enforcer-rules/src: main/java/org/apache/maven/plugins/enforcer/ site/apt/
Date Sun, 12 Feb 2012 15:53:19 GMT
Author: pgier
Date: Sun Feb 12 15:53:19 2012
New Revision: 1243270

URL: http://svn.apache.org/viewvc?rev=1243270&view=rev
Log:
[MENFORCER-128] Rename new goal IncompatibleDependencyOverwrite -> RequireUpperBoundDeps

Added:
    maven/enforcer/trunk/enforcer-rules/src/main/java/org/apache/maven/plugins/enforcer/RequireUpperBoundDeps.java
      - copied, changed from r1242799, maven/enforcer/trunk/enforcer-rules/src/main/java/org/apache/maven/plugins/enforcer/IncompatibleDependencyOverwrite.java
    maven/enforcer/trunk/enforcer-rules/src/site/apt/requireUpperBoundDeps.apt.vm
      - copied, changed from r1242799, maven/enforcer/trunk/enforcer-rules/src/site/apt/IncompatibleDependencyOverwrite.apt.vm
Removed:
    maven/enforcer/trunk/enforcer-rules/src/main/java/org/apache/maven/plugins/enforcer/IncompatibleDependencyOverwrite.java
    maven/enforcer/trunk/enforcer-rules/src/site/apt/IncompatibleDependencyOverwrite.apt.vm
Modified:
    maven/enforcer/trunk/enforcer-rules/src/site/apt/index.apt

Copied: maven/enforcer/trunk/enforcer-rules/src/main/java/org/apache/maven/plugins/enforcer/RequireUpperBoundDeps.java
(from r1242799, maven/enforcer/trunk/enforcer-rules/src/main/java/org/apache/maven/plugins/enforcer/IncompatibleDependencyOverwrite.java)
URL: http://svn.apache.org/viewvc/maven/enforcer/trunk/enforcer-rules/src/main/java/org/apache/maven/plugins/enforcer/RequireUpperBoundDeps.java?p2=maven/enforcer/trunk/enforcer-rules/src/main/java/org/apache/maven/plugins/enforcer/RequireUpperBoundDeps.java&p1=maven/enforcer/trunk/enforcer-rules/src/main/java/org/apache/maven/plugins/enforcer/IncompatibleDependencyOverwrite.java&r1=1242799&r2=1243270&rev=1243270&view=diff
==============================================================================
--- maven/enforcer/trunk/enforcer-rules/src/main/java/org/apache/maven/plugins/enforcer/IncompatibleDependencyOverwrite.java
(original)
+++ maven/enforcer/trunk/enforcer-rules/src/main/java/org/apache/maven/plugins/enforcer/RequireUpperBoundDeps.java
Sun Feb 12 15:53:19 2012
@@ -48,7 +48,7 @@ import org.codehaus.plexus.i18n.I18N;
 /**
  * @author Geoffrey De Smet
  */
-public class IncompatibleDependencyOverwrite extends AbstractNonCacheableEnforcerRule
+public class RequireUpperBoundDeps extends AbstractNonCacheableEnforcerRule
 {
 
     private static Log log;
@@ -112,14 +112,14 @@ public class IncompatibleDependencyOverw
                 i18n = (I18N) helper.getComponent( I18N.class );
             }
             DependencyNode node = getNode( helper );
-            IncompatibleOverwriteVisitor visitor
-                    = new IncompatibleOverwriteVisitor();
+            RequireUpperBoundDepsVisitor visitor
+                    = new RequireUpperBoundDepsVisitor();
             node.accept( visitor );
             List<String> errorMessages = buildErrorMessages( visitor.getConflicts()
);
             if ( errorMessages.size() > 0 )
             {
                 throw new EnforcerRuleException(
-                        "Failed while enforcing IncompatibleDependencyOverwrite. The error(s)
are "
+                        "Failed while enforcing RequireUpperBoundDeps. The error(s) are "
                         + errorMessages );
             }
         }
@@ -145,7 +145,7 @@ public class IncompatibleDependencyOverw
 
     private String buildErrorMessage(List<DependencyNode> conflict) {
         StringBuilder errorMessage = new StringBuilder();
-        errorMessage.append("\nIncompatible dependency overwrite error for "
+        errorMessage.append("\nRequire upper bound dependencies error for "
                 + getFullArtifactName(conflict.get(0).getArtifact())
                 + " paths to dependency are:\n");
         if ( conflict.size() > 0 )
@@ -187,7 +187,7 @@ public class IncompatibleDependencyOverw
         return artifact.getGroupId() + ":" + artifact.getArtifactId() + ":" + artifact.getVersion();
     }
 
-    private static class IncompatibleOverwriteVisitor implements DependencyNodeVisitor {
+    private static class RequireUpperBoundDepsVisitor implements DependencyNodeVisitor {
 
         private Map<String, List<DependencyNodeHopCountPair>> keyToPairsMap
                 = new LinkedHashMap<String, List<DependencyNodeHopCountPair>>();

Modified: maven/enforcer/trunk/enforcer-rules/src/site/apt/index.apt
URL: http://svn.apache.org/viewvc/maven/enforcer/trunk/enforcer-rules/src/site/apt/index.apt?rev=1243270&r1=1243269&r2=1243270&view=diff
==============================================================================
--- maven/enforcer/trunk/enforcer-rules/src/site/apt/index.apt (original)
+++ maven/enforcer/trunk/enforcer-rules/src/site/apt/index.apt Sun Feb 12 15:53:19 2012
@@ -37,7 +37,7 @@ Standard Rules
   
   * {{{./dependencyConvergence.html}dependencyConvergence}} - ensure all dependencies converge
to the same version.
 
-  * {{{./incompatibleDependencyOverwrite.html}IncompatibleDependencyOverwrite}} - ensures
that every (transitive) dependency is resolved to it's specified version or higher.
+  * {{{./requireUpperBoundDeps.html}requireUpperBoundDeps}} - ensures that every (transitive)
dependency is resolved to it's specified version or higher.
 
   * {{{./evaluateBeanshell.html}evaluateBeanshell}} - evaluates a beanshell script.
 

Copied: maven/enforcer/trunk/enforcer-rules/src/site/apt/requireUpperBoundDeps.apt.vm (from
r1242799, maven/enforcer/trunk/enforcer-rules/src/site/apt/IncompatibleDependencyOverwrite.apt.vm)
URL: http://svn.apache.org/viewvc/maven/enforcer/trunk/enforcer-rules/src/site/apt/requireUpperBoundDeps.apt.vm?p2=maven/enforcer/trunk/enforcer-rules/src/site/apt/requireUpperBoundDeps.apt.vm&p1=maven/enforcer/trunk/enforcer-rules/src/site/apt/IncompatibleDependencyOverwrite.apt.vm&r1=1242799&r2=1243270&rev=1243270&view=diff
==============================================================================
--- maven/enforcer/trunk/enforcer-rules/src/site/apt/IncompatibleDependencyOverwrite.apt.vm
(original)
+++ maven/enforcer/trunk/enforcer-rules/src/site/apt/requireUpperBoundDeps.apt.vm Sun Feb
12 15:53:19 2012
@@ -50,8 +50,8 @@
 
 -----------------------------------------------------------------------------------
 
-Failed while enforcing IncompatibleDependencyOverwrite. The error(s) are [
-IncompatibleDependencyOverwrite error for org.slf4j:slf4j-api:1.4.0 paths to dependency are:
+Failed while enforcing RequireUpperBoundDeps. The error(s) are [
+RequireUpperBoundDeps error for org.slf4j:slf4j-api:1.4.0 paths to dependency are:
 +-test:TestParent:1.0-SNAPSHOT
   +-org.slf4j:slf4j-api:1.4.0
 and
@@ -98,7 +98,7 @@ and
             <id>enforce</id>
             <configuration>
               <rules>
-                <IncompatibleDependencyOverwrite/>
+                <RequireUpperBoundDeps/>
               </rules>
             </configuration>
             <goals>



Mime
View raw message