maven-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From hbout...@apache.org
Subject svn commit: r1137805 - /maven/pom/trunk/maven/pom.xml
Date Mon, 20 Jun 2011 22:32:42 GMT
Author: hboutemy
Date: Mon Jun 20 22:32:42 2011
New Revision: 1137805

URL: http://svn.apache.org/viewvc?rev=1137805&view=rev
Log:
[MPOM-13] set Java 5 compiler settings in default configuration (was only in quality-checks
profile)

Modified:
    maven/pom/trunk/maven/pom.xml

Modified: maven/pom/trunk/maven/pom.xml
URL: http://svn.apache.org/viewvc/maven/pom/trunk/maven/pom.xml?rev=1137805&r1=1137804&r2=1137805&view=diff
==============================================================================
--- maven/pom/trunk/maven/pom.xml (original)
+++ maven/pom/trunk/maven/pom.xml Mon Jun 20 22:32:42 2011
@@ -607,6 +607,23 @@ under the License.
     </site>
   </distributionManagement>
 
+  <build>
+    <pluginManagement>
+      <plugins>
+        <!-- The Maven universe targets Java 1.5 -->
+        <plugin>
+          <groupId>org.apache.maven.plugins</groupId>
+          <artifactId>maven-compiler-plugin</artifactId>
+          <version>2.3.2</version>
+          <configuration>
+            <source>1.5</source>
+            <target>1.5</target>
+          </configuration>
+        </plugin>
+      </plugins>
+    </pluginManagement>
+  </build>
+
   <reporting>
     <plugins>
       <plugin>
@@ -626,21 +643,6 @@ under the License.
         </property>
       </activation>
       <build>
-        <pluginManagement>
-          <plugins>
-            <!-- The Maven universe targets Java 1.5 -->
-            <plugin>
-              <groupId>org.apache.maven.plugins</groupId>
-              <artifactId>maven-compiler-plugin</artifactId>
-              <version>2.3.2</version>
-              <configuration>
-                <source>1.5</source>
-                <target>1.5</target>
-                <encoding>${project.build.sourceEncoding}</encoding>
-              </configuration>
-            </plugin>
-          </plugins>
-        </pluginManagement>
         <plugins>
           <!--<plugin>
           Clirr needs to be more flexble before we can force this everywhere. New releases
that don't have previous artifacts to compare cause Clirr to blow up. And Clirr needs to be
smart enough to only look at the previous release artifact so we can make this work during
snapshot builds, otherwise it just blows up when you try to do a release.



Mime
View raw message