maven-announce mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Connolly <>
Subject [ANN] New release lines of Apache Maven after 30th Sep 2013 will require Java 6 or newer
Date Sat, 27 Jul 2013 21:21:05 GMT
As a result of a recent vote on the Maven Developers list the decision has
been made to discontinue support for running Maven itself using Java 5.0.

The Maven 2.0.x release line has a minimum Java requirement of 1.4
The Maven 2.1.x, 2.2.x, 3.0.x and 3.1.x release lines all have a minimum
Java requirement of 5.0

After of 30th of September 2013, any new release lines will have a minimum
Java requirement of 6.0

Existing release lines will retain their existing requirements for any new
patch releases.

Plugins will continue to default to following the Java requirements of the
base version of Maven that those plugins run on (though specific plugins
are always free to insist on a more recent version of Java than their base
version of Maven core would indicate if there is a good reason for that

No decision has been made as to when to move the minimum Java requirement

Note that this is only the minimum requirement for running Maven itself.

It is possible to configure the Apache Maven Compiler plugin to compile
using a different JDK than the JRE used to run Maven. (See

It is possible to configure Apache Maven Surefire and Failsafe plugins to
run unit/integration tests using a different JDK than the JRE used to run
Maven. (See either

Another useful resource is the Toolchains support: which can
be used to simplify using a different JDK for compiling and running unit

Thank you.

-Stephen Connolly on behalf of the Maven Developers.

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message