maven-announce mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte" <rfscho...@apache.org>
Subject [ANN] Apache Maven Enforcer Plugin 1.3 Released
Date Sun, 30 Jun 2013 19:55:53 GMT
The Apache Maven team is pleased to announce the release of the Maven  
Enforcer Plugin, version 1.3

The Enforcer plugin provides goals to control certain environmental  
constraints such as Maven version, JDK version and OS family along with  
many more standard rules and user created rules.

http://maven.apache.org/enforcer/maven-enforcer-plugin/

You should specify the version in your project's plugin configuration:

<plugin>
   <groupId>org.apache.maven.plugins</groupId>
   <artifactId>maven-enforcer-plugin</artifactId>
   <version>1.3</version>
</plugin>


Release Notes - Apache Maven 2.x Enforcer Plugin - Version 1.3

** Bug
     * [MENFORCER-42] - Maven-Enforcer-Plugin fails in multimodule project  
when artifacts not in repository
     * [MENFORCER-123] - BannedDependencies version number not taken into  
account
     * [MENFORCER-126] - requirePluginVersions misreports plugins with  
artifactIds defined through properties
     * [MENFORCER-146] - requireUpperBoundDeps inneffective when  
DependencyManagement is used
     * [MENFORCER-148] - Broken hyperlink on Enforcer plugin usage page
     * [MENFORCER-149] - Broken links to properties of "Require OS Version"  
of Maven Enforcer Plugin
     * [MENFORCER-155] - Add rule RequirePrerequisite

** Improvement
     * [MENFORCER-83] - Banned dependencies should support regular  
expressions
     * [MENFORCER-134] - Require Upper Bound Dependencies and matching  
Snapshot Dependencies

** New Feature
     * [MENFORCER-74] - The bannedDependencies rule should support  
classifier
     * [MENFORCER-75] - The bannedDependencies rule should support scope  
condition
     * [MENFORCER-147] - Add RequireSameVersions
     * [MENFORCER-152] - Add Rule: BanDuplicatePomDependencyVersion or  
RequireUniquePomDependencyVersion

** Task
     * [MENFORCER-153] - Use Mock Repository Manager for ITs
     * [MENFORCER-154] - Update maven-dependency-tree to 2.1 to make it  
work with Maven-3.1+


Enjoy,

-The Apache Maven team

Mime
View raw message