manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: Sharepoint connector help : site didn't exist or external
Date Mon, 08 Oct 2018 18:32:07 GMT
Excellent news!
Thanks for the update.

Karl


On Mon, Oct 8, 2018 at 1:54 PM Susheel Kumar <susheel2777@gmail.com> wrote:

> Thank you so much Karl. I was able to crawl the site and index them.
>
> On Wed, Oct 3, 2018 at 3:31 PM Karl Wright <daddywri@gmail.com> wrote:
>
>> Please read the user documentation for the sharepoint connector very
>> carefully.  You will need a site rule AND a path rule.
>>
>> Thanks,
>> Karl
>>
>>
>> On Wed, Oct 3, 2018 at 3:29 PM Susheel Kumar <susheel2777@gmail.com>
>> wrote:
>>
>>> Hi Karl,
>>>
>>> Please ignore my previous message.  I was just able to crawl it but for
>>> the files which i wanted to get extracted it is showing me below message. I
>>> already had Path configured to have /content included file and library type
>>> included but it is still not including them. How to correctly define path
>>> in order to get them included.
>>>
>>> DEBUG 2018-10-03T15:22:58,724 (Worker thread '40') - SharePoint:
>>> Checking whether to include document
>>> '/Content/Review_Communication_template.docx'
>>> DEBUG 2018-10-03T15:22:58,724 (Worker thread '40') - SharePoint: File
>>> path '/Content/Review_Communication_template.docx' does not match any rules
>>> - excluding
>>> DEBUG 2018-10-03T15:22:58,724 (Worker thread '40') - SharePoint:
>>> Checking whether to include document '/Content/Review_Template.pptx'
>>>
>>> On Wed, Oct 3, 2018 at 2:48 PM Susheel Kumar <susheel2777@gmail.com>
>>> wrote:
>>>
>>>> Thank you so much, Karl and taking me up to here. I am able to see
>>>> connector loggings now.
>>>>
>>>> The next I am struggling with, when I run a job to use sharepoint
>>>> repository and output to local file system, I see sometime 401 Unauthorized
>>>> for usergroup.asmx OR 404 for lists.asmx or 404 for Permission.asmx when I
>>>> am running same job again and again.  I am able to access these web service
>>>> thru POSTMAN and it works.
>>>>
>>>> Any hint what may be missing? I already had manifold Sharepoint plugin
>>>> installed.
>>>>
>>>> DEBUG 2018-10-03T13:24:24,631 (Thread-49328) - Enter:
>>>> SOAPPart::saveChanges
>>>> DEBUG 2018-10-03T13:24:24,631 (Thread-49328) - http-outgoing-90 >>
>>>> "POST /sites/mysite/_vti_bin/usergroup.asmx HTTP/1.1[\r][\n]"
>>>> DEBUG 2018-10-03T13:24:24,631 (Thread-49328) - http-outgoing-90 >>
>>>> "Content-Type: text/xml; charset=utf-8[\r][\n]"
>>>> DEBUG 2018-10-03T13:24:24,631 (Thread-49328) - http-outgoing-90 >>
>>>> "Accept: */*[\r][\n]"
>>>> DEBUG 2018-10-03T13:24:24,631 (Thread-49328) - http-outgoing-90 >>
>>>> "SOAPAction: "
>>>> http://schemas.microsoft.com/sharepoint/soap/directory/GetUserCollectionFromGroup
>>>> "[\r][\n]"
>>>> DEBUG 2018-10-03T13:24:24,631 (Thread-49328) - http-outgoing-90 >>
>>>> "User-Agent: Axis/1.4[\r][\n]"
>>>> DEBUG 2018-10-03T13:24:24,631 (Thread-49328) - http-outgoing-90 >>
>>>> "Content-Length: 427[\r][\n]"
>>>> DEBUG 2018-10-03T13:24:24,631 (Thread-49328) - http-outgoing-90 >>
>>>> "Host: dit.apps.com[\r][\n]"
>>>> DEBUG 2018-10-03T13:24:24,631 (Thread-49328) - http-outgoing-90 >>
>>>> "Connection: Keep-Alive[\r][\n]"
>>>> DEBUG 2018-10-03T13:24:24,631 (Thread-49328) - http-outgoing-90 >>
>>>> "Accept-Encoding: gzip,deflate[\r][\n]"
>>>> DEBUG 2018-10-03T13:24:24,631 (Thread-49328) - http-outgoing-90 >>
>>>> "Authorization: NTLM
>>>> TlRMTVNTUAADAAAAGAAYAEgAAADOAM4AYAAAAAQABAAuAQAADgAOADIBAAAeAB4AQAEAAAAAAABeAQAABYKIogUBKAoAAAAPMhvCQLxXxh1vp0BTXWvSa7dE6WMG25EYSBDigKSFQ4YXcg/4Gs4bOgEBAAAAAAAAYHUY7j1b1AFjszvpmEMnhAAAAAACAAQARQBTAAEAFgBDAEQATABEAEUAVgBFAFMAUgAwADIABAAaAEUAUwAuAEEARAAuAEEARABQAC4AYwBvAG0AAwAyAEMARABMAEQARQBWAEUAUwBSADAAMgAuAEUAUwAuAEEARAAuAEEARABQAC4AYwBvAG0ABQAUAEEARAAuAEEARABQAC4AYwBvAG0ABwAIAMWOHe89W9QBAAAAAAAAAABFAFMAawB1AG0AYQByAHMANQBSAE8AUwBFAEwAQwBEAFYAMAAwADAAMQBMAEoAQwA=[\r][\n]"
>>>> DEBUG 2018-10-03T13:24:24,631 (Thread-49328) - http-outgoing-90 >>
>>>> "[\r][\n]"
>>>> DEBUG 2018-10-03T13:24:24,631 (Thread-49328) - http-outgoing-90 >>
>>>> "<?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope xmlns:soapenv="
>>>> http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="
>>>> http://www.w3.org/2001/XMLSchema" xmlns:xsi="
>>>> http://www.w3.org/2001/XMLSchema-instance"><soapenv:Body><GetUserCollectionFromGroup
>>>> xmlns="http://schemas.microsoft.com/sharepoint/soap/directory/"><groupName>Excel
>>>> Services
>>>> Viewers</groupName></GetUserCollectionFromGroup></soapenv:Body></soapenv:Envelope>"
>>>> DEBUG 2018-10-03T13:24:24,806 (Thread-49328) - http-outgoing-90 <<
>>>> "HTTP/1.1 401 Unauthorized[\r][\n]"
>>>>
>>>> OR
>>>>
>>>> DEBUG 2018-10-03T13:27:17,603 (Thread-50830) - http-outgoing-102 >>
>>>> "POST /sites/mysite/_vti_bin/lists.asmx HTTP/1.1[\r][\n]"
>>>> DEBUG 2018-10-03T13:27:17,603 (Thread-50830) - http-outgoing-102 >>
>>>> "Content-Type: text/xml; charset=utf-8[\r][\n]"
>>>> DEBUG 2018-10-03T13:27:17,603 (Thread-50830) - http-outgoing-102 >>
>>>> "Accept: */*[\r][\n]"
>>>> DEBUG 2018-10-03T13:27:17,603 (Thread-50830) - http-outgoing-102 >>
>>>> "SOAPAction: "
>>>> http://schemas.microsoft.com/sharepoint/soap/GetListCollection
>>>> "[\r][\n]"
>>>> DEBUG 2018-10-03T13:27:17,603 (Thread-50830) - http-outgoing-102 >>
>>>> "User-Agent: Axis/1.4[\r][\n]"
>>>> DEBUG 2018-10-03T13:27:17,603 (Thread-50830) - http-outgoing-102 >>
>>>> "Content-Length: 335[\r][\n]"
>>>> DEBUG 2018-10-03T13:27:17,603 (Thread-50830) - http-outgoing-102 >>
>>>> "Host: dit.apps.com[\r][\n]"
>>>> DEBUG 2018-10-03T13:27:17,603 (Thread-50830) - http-outgoing-102 >>
>>>> "Connection: Keep-Alive[\r][\n]"
>>>> DEBUG 2018-10-03T13:27:17,603 (Thread-50830) - http-outgoing-102 >>
>>>> "Accept-Encoding: gzip,deflate[\r][\n]"
>>>> DEBUG 2018-10-03T13:27:17,603 (Thread-50830) - http-outgoing-102 >>
>>>> "[\r][\n]"
>>>> DEBUG 2018-10-03T13:27:17,603 (Thread-50830) - http-outgoing-102 >>
>>>> "<?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope xmlns:soapenv="
>>>> http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="
>>>> http://www.w3.org/2001/XMLSchema" xmlns:xsi="
>>>> http://www.w3.org/2001/XMLSchema-instance"><soapenv:Body><GetListCollection
>>>> xmlns="http://schemas.microsoft.com/sharepoint/soap/
>>>> "/></soapenv:Body></soapenv:Envelope>"
>>>> DEBUG 2018-10-03T13:27:17,670 (Thread-50830) - http-outgoing-102 <<
>>>> "HTTP/1.1 404 Not Found[\r][\n]"
>>>> DEBUG 2018-10-03T13:27:17,670 (Thread-50830) -
>>>>
>>>> On Mon, Oct 1, 2018 at 3:10 PM Karl Wright <daddywri@gmail.com> wrote:
>>>>
>>>>> You're putting this in the wrong place.
>>>>>
>>>>> Leave logging.xml alone.  Instead, add this into your properties.xml
>>>>> file:
>>>>>
>>>>> <property name="org.apache.manifoldcf.connectors" value="DEBUG"/>
>>>>>
>>>>> Karl
>>>>>
>>>>>
>>>>> On Mon, Oct 1, 2018 at 2:31 PM Susheel Kumar <susheel2777@gmail.com>
>>>>> wrote:
>>>>>
>>>>>> Hi Karl,
>>>>>>
>>>>>> Trying the first put the logging in place. Below I have in
>>>>>> logging.xml (manifold 2.10) which is outputting the wire debugging messages
>>>>>> but I am not able to see connector debug messages.  I tried to add below
>>>>>> Logger under Loggers but it's not writing any connectors debug messages.
>>>>>> What am i missing here?
>>>>>>
>>>>>> Logging.xml
>>>>>> ---
>>>>>> <Configuration status="DEBUG" name="ManifoldCF" packages="">
>>>>>>   <Appenders>
>>>>>>     <File name="MyFile" fileName="logs/manifoldcf.log">
>>>>>>       <PatternLayout>
>>>>>>         <Pattern>%5p %d{ISO8601} (%t) - %m%n</Pattern>
>>>>>>       </PatternLayout>
>>>>>>     </File>
>>>>>>   </Appenders>
>>>>>>   <Loggers>
>>>>>>     <Root level="DEBUG">
>>>>>>       <AppenderRef ref="MyFile"/>
>>>>>>     </Root>
>>>>>>   </Loggers>
>>>>>> </Configuration>
>>>>>>
>>>>>> Logger to enable connector debug messages
>>>>>> ===
>>>>>> <Logger name="log4j.logger. <http://log4j.logger.org/>
>>>>>> org.apache.manifoldcf.connectors" level="DEBUG" additivity="false">
>>>>>> <Appender-ref ref="MyFile" level="DEBUG" />
>>>>>> </Logger>
>>>>>>
>>>>>> On Fri, Sep 28, 2018 at 8:56 AM Karl Wright <daddywri@gmail.com>
>>>>>> wrote:
>>>>>>
>>>>>>> Please review the documentation on how to set up your paths for
>>>>>>> indexing; your specification is likely incorrect.  The paths use matching
>>>>>>> rules to determine what to traverse.
>>>>>>>
>>>>>>> By the way, you've turned on wire debugging for
>>>>>>> httpcomponents/httpclient, but you probably meant to turn on connector
>>>>>>> debugging, since that logs all the decisions that the connector makes.  You
>>>>>>> do that in properties.xml; the property is org.apache.manifoldcf.connectors
>>>>>>> and the value you want is DEBUG.
>>>>>>>
>>>>>>> Karl
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> On Fri, Sep 28, 2018 at 8:49 AM Susheel Kumar <susheel2777@gmail.com>
>>>>>>> wrote:
>>>>>>>
>>>>>>>> Hello Karl,
>>>>>>>>
>>>>>>>> Hoping you can help me out moving further to index documents into
>>>>>>>> Solr from Sharepoint.
>>>>>>>>
>>>>>>>> I am able to have Sharepoint repository connection working and then
>>>>>>>> created Solr output connection which is working as well.
>>>>>>>>
>>>>>>>> Now when I am running the job, i see it run for 10-30 seconds shows
>>>>>>>> Documents 1 and Active 1 then they again reset to 0 and nothing I see in
>>>>>>>> Solr being indexed.
>>>>>>>>
>>>>>>>> The Solr cloud is 6.6.2. Below manifold logs entry.
>>>>>>>>
>>>>>>>> DEBUG 2018-09-28T08:37:06,239 (Thread-153948) - CookieSpec
>>>>>>>> selected: default
>>>>>>>> DEBUG 2018-09-28T08:37:06,240 (Thread-153948) - Auth cache not set
>>>>>>>> in the context
>>>>>>>> DEBUG 2018-09-28T08:37:06,240 (Thread-153948) - Connection request:
>>>>>>>> [route: {}->http://server1:8080][state: class
>>>>>>>> org.apache.solr.client.solrj.impl.HttpSolrClient][total kept alive: 0;
>>>>>>>> route allocated: 0 of 10000; total allocated: 0 of 10000]
>>>>>>>> DEBUG 2018-09-28T08:37:06,240 (Thread-153948) - Connection leased:
>>>>>>>> [id: 29][route: {}->http://server1:8080][total kept alive: 0;
>>>>>>>> route allocated: 1 of 10000; total allocated: 1 of 10000]
>>>>>>>> DEBUG 2018-09-28T08:37:06,241 (Thread-153948) - Opening connection
>>>>>>>> {}->http://server1:8080
>>>>>>>> DEBUG 2018-09-28T08:37:06,277 (Thread-153948) - Connecting to
>>>>>>>> server1/11.16.75.152:8080
>>>>>>>> DEBUG 2018-09-28T08:37:06,346 (Thread-153948) - Connection
>>>>>>>> established 29.0.200.110:59251<->11.16.75.152:8080
>>>>>>>> DEBUG 2018-09-28T08:37:06,346 (Thread-153948) - http-outgoing-29:
>>>>>>>> set socket timeout to 600000
>>>>>>>> DEBUG 2018-09-28T08:37:06,346 (Thread-153948) - Executing request
>>>>>>>> POST /solr/TEST/update/extract?commit=true HTTP/1.1
>>>>>>>> DEBUG 2018-09-28T08:37:06,346 (Thread-153948) - Target auth state:
>>>>>>>> UNCHALLENGED
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - Proxy auth state:
>>>>>>>> UNCHALLENGED
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> POST /solr/TEST/update/extract?commit=true HTTP/1.1
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> User-Agent: Solr[org.apache.solr.client.solrj.impl.HttpSolrClient] 1.0
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> Content-Length: 389
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> Content-Type: multipart/form-data;
>>>>>>>> boundary=tpyLnqpL02aTW2ED66alDREcjqYMQBvaJDUr2IFc; charset=UTF-8
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> Host: server1:8080
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> Connection: Keep-Alive
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "POST /solr/TEST/update/extract?commit=true HTTP/1.1[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "User-Agent: Solr[org.apache.solr.client.solrj.impl.HttpSolrClient]
>>>>>>>> 1.0[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "Content-Length: 389[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "Content-Type: multipart/form-data;
>>>>>>>> boundary=tpyLnqpL02aTW2ED66alDREcjqYMQBvaJDUr2IFc; charset=UTF-8[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "Host: server1:8080[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "Connection: Keep-Alive[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "--tpyLnqpL02aTW2ED66alDREcjqYMQBvaJDUr2IFc[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "Content-Disposition: form-data; name="wt"[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,347 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "Content-Type: text/plain; charset=UTF-8[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,348 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "Content-Transfer-Encoding: 8bit[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,348 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,348 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "javabin"
>>>>>>>> DEBUG 2018-09-28T08:37:06,348 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,348 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "--tpyLnqpL02aTW2ED66alDREcjqYMQBvaJDUr2IFc[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,348 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "Content-Disposition: form-data; name="version"[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,348 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "Content-Type: text/plain; charset=UTF-8[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,348 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "Content-Transfer-Encoding: 8bit[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,348 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,348 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "2"
>>>>>>>> DEBUG 2018-09-28T08:37:06,348 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,348 (Thread-153948) - http-outgoing-29 >>
>>>>>>>> "--tpyLnqpL02aTW2ED66alDREcjqYMQBvaJDUr2IFc--[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,435 (Thread-153948) - http-outgoing-29 <<
>>>>>>>> "HTTP/1.1 200 OK[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,435 (Thread-153948) - http-outgoing-29 <<
>>>>>>>> "Content-Type: application/octet-stream[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,435 (Thread-153948) - http-outgoing-29 <<
>>>>>>>> "Content-Length: 41[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,435 (Thread-153948) - http-outgoing-29 <<
>>>>>>>> "[\r][\n]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,435 (Thread-153948) - http-outgoing-29 <<
>>>>>>>> "[0x2][0xa1][0xe0].responseHeader[0xa2][0xe0]&status[0x6][0x0][0x0][0x0][0x0][0xe0]%QTimeY[0x1]"
>>>>>>>> DEBUG 2018-09-28T08:37:06,435 (Thread-153948) - http-outgoing-29 <<
>>>>>>>> HTTP/1.1 200 OK
>>>>>>>> DEBUG 2018-09-28T08:37:06,435 (Thread-153948) - http-outgoing-29 <<
>>>>>>>> Content-Type: application/octet-stream
>>>>>>>> DEBUG 2018-09-28T08:37:06,435 (Thread-153948) - http-outgoing-29 <<
>>>>>>>> Content-Length: 41
>>>>>>>> DEBUG 2018-09-28T08:37:06,435 (Thread-153948) - Connection can be
>>>>>>>> kept alive indefinitely
>>>>>>>> DEBUG 2018-09-28T08:37:06,435 (Thread-153948) - Connection [id:
>>>>>>>> 29][route: {}->http://server1:8080][state: class
>>>>>>>> org.apache.solr.client.solrj.impl.HttpSolrClient] can be kept alive
>>>>>>>> indefinitely
>>>>>>>> DEBUG 2018-09-28T08:37:06,435 (Thread-153948) - Connection
>>>>>>>> released: [id: 29][route: {}->http://server1:8080][state: class
>>>>>>>> org.apache.solr.client.solrj.impl.HttpSolrClient][total kept alive: 1;
>>>>>>>> route allocated: 1 of 10000; total allocated: 1 of 10000]
>>>>>>>> DEBUG 2018-09-28T08:37:10,778 (Crawler idle cleanup thread) -
>>>>>>>> Closing connections idle longer than 60000 MILLISECONDS
>>>>>>>> DEBUG 2018-09-28T08:37:10,778 (Crawler idle cleanup thread) -
>>>>>>>> http-outgoing-28: Close connection
>>>>>>>> DEBUG 2018-09-28T08:37:10,836 (Idle cleanup thread) - Closing
>>>>>>>> connections idle longer than 60000 MILLISECONDS
>>>>>>>> DEBUG 2018-09-28T08:37:10,872 (Idle cleanup thread) - Closing
>>>>>>>> connections idle longer than 60000 MILLISECONDS
>>>>>>>>
>>>>>>>> On Wed, Sep 19, 2018 at 2:06 PM Susheel Kumar <
>>>>>>>> susheel2777@gmail.com> wrote:
>>>>>>>>
>>>>>>>>> No, Karl. I even didn't realize we would need it on the Sharepoint
>>>>>>>>> server. Thanks so much again for helping me moving forward. I have asked
>>>>>>>>> Site admin to get that installed and will update here with the progress.
>>>>>>>>>
>>>>>>>>> On Wed, Sep 19, 2018 at 12:44 PM Karl Wright <daddywri@gmail.com>
>>>>>>>>> wrote:
>>>>>>>>>
>>>>>>>>>> Have you installed the ManifoldCF Sharepoint 2013 plugin on the
>>>>>>>>>> Sharepoint server?
>>>>>>>>>>
>>>>>>>>>> Karl
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> On Wed, Sep 19, 2018 at 12:32 PM Susheel Kumar <
>>>>>>>>>> susheel2777@gmail.com> wrote:
>>>>>>>>>>
>>>>>>>>>>> Thank you so much, Karl. It fixed that but the error message in
>>>>>>>>>>> manifold UI remain same and from the logs I can see it got authenticated
>>>>>>>>>>> when accessing lists.asmx but later when accessing MCPermission.asmx and
>>>>>>>>>>> calling GetPermissionCollection it is having 404 not found
>>>>>>>>>>> error.
>>>>>>>>>>>
>>>>>>>>>>> Any suggestion?
>>>>>>>>>>>
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,721 (Thread-10672) - http-outgoing-16 >> Authorization: NTLM TlRMTVNTUAADAAAAGAAYAEgAAADWANYAYAAAAAQABAA2AQAADgAOADoBAAAeAB4ASAEAAAAAAABmAQAABYKIogUBKAoAAAAPi29mDuWNNMMk94I7QDt2QOcOIEMSunezE/kMXJfCgXDtpBsjM34qLgEBAAAAAAAAgMcWhS1Q1AFfqWKUz0ldwQAAAAACAAQARQBTAAEAGgBEAEMAMQBQAFIAUwBQAFMAVgBNAFcARgAyAAQAGgBFAFMALgBBAEQALgBBAEQAUAAuAGMAbwBtAAMANgBEAEMAMQBQAFIAUwBQAFMAVgBNAFcARgAyAC4ARQBTAC4AQQBEAC4AQQBEAFAALgBjAG8AbQAFABQAQQBEAC4AQQBEAFAALgBjAG8AbQAHAAgAVj0dgS1Q1AEAAAAAAAAAAEUAUwBrAHUAbQBhAHIAcwA1AFIATwBTAEUATABDAEQAVgAwADAAMAAxAEwASgBDAA==
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,721 (Thread-10672) - Enter: SOAPPart::saveChanges
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,721 (Thread-10672) - http-outgoing-16 >> "POST /sites/ES/_vti_bin/MCPermissions.asmx HTTP/1.1[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,721 (Thread-10672) - http-outgoing-16 >> "Content-Type: text/xml; charset=utf-8[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,721 (Thread-10672) - http-outgoing-16 >> "Accept: */*[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,721 (Thread-10672) - http-outgoing-16 >> "SOAPAction: "http://microsoft.com/sharepoint/webpartpages/GetPermissionCollection"[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,721 (Thread-10672) - http-outgoing-16 >> "User-Agent: Axis/1.4[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,721 (Thread-10672) - http-outgoing-16 >> "Content-Length: 420[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,721 (Thread-10672) - http-outgoing-16 >> "Host: teamsites.corp.com[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,721 (Thread-10672) - http-outgoing-16 >> "Connection: Keep-Alive[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,721 (Thread-10672) - http-outgoing-16 >> "Accept-Encoding: gzip,deflate[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,721 (Thread-10672) - http-outgoing-16 >> "Authorization: NTLM TlRMTVNTUAADAAAAGAAYAEgAAADWANYAYAAAAAQABAA2AQAADgAOADoBAAAeAB4ASAEAAAAAAABmAQAABYKIogUBKAoAAAAPi29mDuWNNMMk94I7QDt2QOcOIEMSunezE/kMXJfCgXDtpBsjM34qLgEBAAAAAAAAgMcWhS1Q1AFfqWKUz0ldwQAAAAACAAQARQBTAAEAGgBEAEMAMQBQAFIAUwBQAFMAVgBNAFcARgAyAAQAGgBFAFMALgBBAEQALgBBAEQAUAAuAGMAbwBtAAMANgBEAEMAMQBQAFIAUwBQAFMAVgBNAFcARgAyAC4ARQBTAC4AQQBEAC4AQQBEAFAALgBjAG8AbQAFABQAQQBEAC4AQQBEAFAALgBjAG8AbQAHAAgAVj0dgS1Q1AEAAAAAAAAAAEUAUwBrAHUAbQBhAHIAcwA1AFIATwBTAEUATABDAEQAVgAwADAAMAAxAEwASgBDAA==[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,721 (Thread-10672) - http-outgoing-16 >> "[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,721 (Thread-10672) - http-outgoing-16 >> "<?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><soapenv:Body><GetPermissionCollection xmlns="http://microsoft.com/sharepoint/webpartpages/"><objectName>/</objectName><objectType>Web</objectType></GetPermissionCollection></soapenv:Body></soapenv:Envelope>"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,840 (Thread-10672) - http-outgoing-16 << "HTTP/1.1 404 Not Found[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << "Server: Microsoft-IIS/7.5[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << "X-SharePointHealthScore: 0[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << "SPRequestGuid: fd49909e-ab60-0085-9239-12625468d677[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << "request-id: fd49909e-ab60-0085-9239-12625468d677[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << "X-FRAME-OPTIONS: SAMEORIGIN[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << "SPRequestDuration: 90[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << "SPIisLatency: 0[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << "Persistent-Auth: true[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << "X-Powered-By: ASP.NET[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << "MicrosoftSharePointTeamServices: 15.0.0.4893[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << "X-Content-Type-Options: nosniff[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << "X-MS-InvokeApp: 1; RequireReadOnly[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << "Date: Wed, 19 Sep 2018 15:29:06 GMT[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << "Content-Length: 0[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << "[\r][\n]"
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << HTTP/1.1 404 Not Found
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << Server: Microsoft-IIS/7.5
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << X-SharePointHealthScore: 0
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << SPRequestGuid: fd49909e-ab60-0085-9239-12625468d677
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << request-id: fd49909e-ab60-0085-9239-12625468d677
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << X-FRAME-OPTIONS: SAMEORIGIN
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << SPRequestDuration: 90
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,841 (Thread-10672) - http-outgoing-16 << SPIisLatency: 0
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,842 (Thread-10672) - http-outgoing-16 << Persistent-Auth: true
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,842 (Thread-10672) - http-outgoing-16 << X-Powered-By: ASP.NET
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,842 (Thread-10672) - http-outgoing-16 << MicrosoftSharePointTeamServices: 15.0.0.4893
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,842 (Thread-10672) - http-outgoing-16 << X-Content-Type-Options: nosniff
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,842 (Thread-10672) - http-outgoing-16 << X-MS-InvokeApp: 1; RequireReadOnly
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,842 (Thread-10672) - http-outgoing-16 << Date: Wed, 19 Sep 2018 15:29:06 GMT
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,842 (Thread-10672) - http-outgoing-16 << Content-Length: 0
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,842 (Thread-10672) - Connection can be kept alive indefinitely
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,842 (Thread-10672) - Authentication succeeded
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,842 (Thread-10672) - Connection [id: 16][route: {}->http://teamsites.corp.com:80][state: ES\myuserID] can be kept alive indefinitely
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,842 (Thread-10672) - Connection released: [id: 16][route: {}->http://teamsites.corp.com:80][state: ES\myuserID][total kept alive: 1; route allocated: 1 of 1; total allocated: 1 of 20]
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,842 (Thread-10672) - Cancelling request execution
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,847 (qtp1165791284-402) - org.apache.axis.i18n.resource::handleGetObject(return01)
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,847 (qtp1165791284-402) - (404)HTTP/1.1 404 Not Found
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,847 (qtp1165791284-402) - Enter: SOAPPart ctor(FORM_FAULT)
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,847 (qtp1165791284-402) - org.apache.axis.i18n.resource::handleGetObject(setMsgForm)
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,847 (qtp1165791284-402) - Setting current message form to: FORM_FAULT (currentMessage is now org.apache.axis.AxisFault)
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,847 (qtp1165791284-402) - Exit: SOAPPart ctor()
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,847 (qtp1165791284-402) - org.apache.axis.i18n.resource::handleGetObject(toAxisFault00)
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,847 (qtp1165791284-402) - Mapping Exception to AxisFault
>>>>>>>>>>> org.apache.axis.AxisFault: (404)HTTP/1.1 404 Not Found
>>>>>>>>>>>    at org.apache.manifoldcf.connectorcommon.common.CommonsHTTPSender.invoke(CommonsHTTPSender.java:201) ~[mcf-connector-common.jar:?]
>>>>>>>>>>>    at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32) ~[axis-1.4.jar:?]
>>>>>>>>>>>    at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118) ~[axis-1.4.jar:?]
>>>>>>>>>>>    at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83) ~[axis-1.4.jar:?]
>>>>>>>>>>>    at org.apache.axis.client.AxisClient.invoke(AxisClient.java:165) ~[axis-1.4.jar:?]
>>>>>>>>>>>    at org.apache.axis.client.Call.invokeEngine(Call.java:2784) ~[axis-1.4.jar:?]
>>>>>>>>>>>    at org.apache.axis.client.Call.invoke(Call.java:2767) ~[axis-1.4.jar:?]
>>>>>>>>>>>    at org.apache.axis.client.Call.invoke(Call.java:2443) [axis-1.4.jar:?]
>>>>>>>>>>>    at org.apache.axis.client.Call.invoke(Call.java:2366) [axis-1.4.jar:?]
>>>>>>>>>>>    at org.apache.axis.client.Call.invoke(Call.java:1812) [axis-1.4.jar:?]
>>>>>>>>>>>    at com.microsoft.sharepoint.webpartpages.PermissionsSoapStub.getPermissionCollection(PermissionsSoapStub.java:200) [mcf-sharepoint-connector.jar:?]
>>>>>>>>>>>    at org.apache.manifoldcf.crawler.connectors.sharepoint.SPSProxyHelper.checkConnection(SPSProxyHelper.java:1612) [mcf-sharepoint-connector.jar:?]
>>>>>>>>>>>    at org.apache.manifoldcf.crawler.connectors.sharepoint.SharePointRepository.check(SharePointRepository.java:457) [mcf-sharepoint-connector.jar:?]
>>>>>>>>>>>    at org.apache.jsp.viewconnection_jsp._jspService(viewconnection_jsp.java:249) [jsp/:?]
>>>>>>>>>>>    at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70) [jasper-6.0.35.jar:6.0.35]
>>>>>>>>>>>    at javax.servlet.http.HttpServlet.service(HttpServlet.java:790) [javax.servlet-api-3.1.0.jar:3.1.0]
>>>>>>>>>>>    at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:388) [jasper-6.0.35.jar:6.0.35]
>>>>>>>>>>>    at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313) [jasper-6.0.35.jar:6.0.35]
>>>>>>>>>>>    at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:260) [jasper-6.0.35.jar:6.0.35]
>>>>>>>>>>>    at javax.servlet.http.HttpServlet.service(HttpServlet.java:790) [javax.servlet-api-3.1.0.jar:3.1.0]
>>>>>>>>>>>    at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:769) [jetty-servlet-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:585) [jetty-servlet-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:595) [jetty-security-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:223) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1125) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:515) [jetty-servlet-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1059) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.Dispatcher.forward(Dispatcher.java:191) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.Dispatcher.forward(Dispatcher.java:72) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.apache.jasper.runtime.PageContextImpl.doForward(PageContextImpl.java:709) [jasper-6.0.35.jar:6.0.35]
>>>>>>>>>>>    at org.apache.jasper.runtime.PageContextImpl.forward(PageContextImpl.java:680) [jasper-6.0.35.jar:6.0.35]
>>>>>>>>>>>    at org.apache.jsp.execute_jsp._jspService(execute_jsp.java:368) [jsp/:?]
>>>>>>>>>>>    at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70) [jasper-6.0.35.jar:6.0.35]
>>>>>>>>>>>    at javax.servlet.http.HttpServlet.service(HttpServlet.java:790) [javax.servlet-api-3.1.0.jar:3.1.0]
>>>>>>>>>>>    at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:388) [jasper-6.0.35.jar:6.0.35]
>>>>>>>>>>>    at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313) [jasper-6.0.35.jar:6.0.35]
>>>>>>>>>>>    at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:260) [jasper-6.0.35.jar:6.0.35]
>>>>>>>>>>>    at javax.servlet.http.HttpServlet.service(HttpServlet.java:790) [javax.servlet-api-3.1.0.jar:3.1.0]
>>>>>>>>>>>    at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:769) [jetty-servlet-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:585) [jetty-servlet-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:577) [jetty-security-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:223) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1125) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:515) [jetty-servlet-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1059) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:215) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.handler.HandlerList.handle(HandlerList.java:52) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.Server.handle(Server.java:497) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:311) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:248) [jetty-server-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:540) [jetty-io-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.util.thread.QueuedThreool.runJob(QueuedThreadPool.java:610) [jetty-util-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:539) [jetty-util-9.2.3.v20140905.jar:9.2.3.v20140905]
>>>>>>>>>>>    at java.lang.Thread.run(Thread.java:745) [?:1.8.0_60]
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,850 (qtp1165791284-402) - Log4JLogChute using logger 'velocity'
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,850 (qtp1165791284-402) - Initializing Velocity, Calling init()...
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,850 (qtp1165791284-402) - Starting Apache Velocity v1.7 (compiled: 2010-11-19 12:14:37)
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,850 (qtp1165791284-402) - Default Properties File: org/apache/velocity/runtime/defaults/velocity.properties
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,850 (qtp1165791284-402) - Trying to use logger class org.apache.velocity.runtime.log.Log4JLogChute
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,850 (qtp1165791284-402) - Using logger class org.apache.velocity.runtime.log.Log4JLogChute
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,851 (qtp1165791284-402) - ResourceCache: initialized (class org.apache.velocity.runtime.resource.ResourceCacheImpl) with class java.util.Collections$SynchronizedMap cache map.
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,851 (qtp1165791284-402) - Loaded System Directive: org.apache.velocity.runtime.directive.Stop
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,851 (qtp1165791284-402) - Loaded System Directive: org.apache.velocity.runtime.directive.Define
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,851 (qtp1165791284-402) - Loaded System Directive: org.apache.velocity.runtime.directive.Break
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,851 (qtp1165791284-402) - Loaded System Directive: org.apache.velocity.runtime.directive.Evaluate
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,851 (qtp1165791284-402) - Loaded System Directive: org.apache.velocity.runtime.directive.Literal
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,851 (qtp1165791284-402) - Loaded System Directive: org.apache.velocity.runtime.directive.Macro
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,851 (qtp1165791284-402) - Loaded System Directive: org.apache.velocity.runtime.directive.Parse
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,851 (qtp1165791284-402) - Loaded System Directive: org.apache.velocity.runtime.directive.Include
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,851 (qtp1165791284-402) - Loaded System Directive: org.apache.velocity.runtime.directive.Foreach
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,852 (qtp1165791284-402) - Created '20' parsers.
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,852 (qtp1165791284-402) - Velocimacro : "velocimacro.library" is not set.  Trying default library: VM_global_library.vm
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,852 (qtp1165791284-402) - Could not load resource 'VM_global_library.vm' from ResourceLoader org.apache.manifoldcf.core.i18n.MCFVelocityResourceLoader: Resource 'VM_global_library.vm' not found.
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,852 (qtp1165791284-402) - Velocimacro : Default library not found.
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,852 (qtp1165791284-402) - Velocimacro : allowInline = true : VMs can be defined inline in templates
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,852 (qtp1165791284-402) - Velocimacro : allowInlineToOverride = false : VMs defined inline may NOT replace previous VM definitions
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,852 (qtp1165791284-402) - Velocimacro : allowInlineLocal = false : VMs defined inline will be global in scope if allowed.
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,852 (qtp1165791284-402) - Velocimacro : autoload off : VM system will not automatically reload global library macros
>>>>>>>>>>> DEBUG 2018-09-19T11:29:13,853 (qtp1165791284-402) - ResourceManager : found viewConfiguration.html with loader org.apache.velocity.runtime.resource.ResourceCacheImpl
>>>>>>>>>>> DEBUG 2018-09-19T11:29:14,566 (Idle cleanup thread) - Closing connections idle longer than 60000 MILLISECONDS
>>>>>>>>>>> DEBUG 2018-09-19T11:29:14,740 (Crawler idle cleanup thread) - Closing connections idle longer than 60000 MILLISECONDS
>>>>>>>>>>> ^C
>>>>>>>>>>>
>>>>>>>>>>>
>>>>>>>>>>> On Wed, Sep 19, 2018 at 11:52 AM Karl Wright <daddywri@gmail.com>
>>>>>>>>>>> wrote:
>>>>>>>>>>>
>>>>>>>>>>>> Hi Susheel,
>>>>>>>>>>>>
>>>>>>>>>>>> The problem is likely your site path.  The actual path looks
>>>>>>>>>>>> like it should be just "/ES", not "/ES/_layouts/15".
>>>>>>>>>>>>
>>>>>>>>>>>> Karl
>>>>>>>>>>>>
>>>>>>>>>>>>
>>>>>>>>>>>> On Wed, Sep 19, 2018 at 9:18 AM Susheel Kumar <
>>>>>>>>>>>> susheel2777@gmail.com> wrote:
>>>>>>>>>>>>
>>>>>>>>>>>>> Hello,
>>>>>>>>>>>>>
>>>>>>>>>>>>> I am new this mailing list and just started using manifold to
>>>>>>>>>>>>> able to index data from our Sharepoint 2013 and index into Solr.
>>>>>>>>>>>>>
>>>>>>>>>>>>> I have a site which i am able to access throw browser
>>>>>>>>>>>>> http://teamsites.corp.com/sites/ES/_layouts/15/viewlsts.aspx
>>>>>>>>>>>>> and when I setup Repository connection using below, it is showing me below
>>>>>>>>>>>>> connection status.
>>>>>>>>>>>>>
>>>>>>>>>>>>> I am clueless how to proceed further.  Please suggest
>>>>>>>>>>>>>
>>>>>>>>>>>>> *"The site at http://teamsites.corp.com/ES/_layouts/15
>>>>>>>>>>>>> <http://teamsites.corp.com/ES/_layouts/15> did not exist or was external;
>>>>>>>>>>>>> skipping"*
>>>>>>>>>>>>>
>>>>>>>>>>>>> Server SharePoint version: SharePoint Services 5.0 (2013)
>>>>>>>>>>>>> Server protocol: http
>>>>>>>>>>>>> Server name: teamsites.corp.com
>>>>>>>>>>>>> Server port:
>>>>>>>>>>>>> Site path: /ES/_layouts/15
>>>>>>>>>>>>> User name: domain\myUserID
>>>>>>>>>>>>> Password: ********
>>>>>>>>>>>>> Proxy host:
>>>>>>>>>>>>> Proxy port:
>>>>>>>>>>>>> Proxy user name:
>>>>>>>>>>>>> Proxy password: ********
>>>>>>>>>>>>> Proxy domain:
>>>>>>>>>>>>> SSL certificate list:
>>>>>>>>>>>>> No certificates present
>>>>>>>>>>>>> Authority type: Active Directory
>>>>>>>>>>>>>
>>>>>>>>>>>>

Mime
View raw message