manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From aurelien.mazo...@francelabs.com
Subject Re: Alfresco webscript connection problem
Date Tue, 02 Jan 2018 18:10:01 GMT
Hi, 

I tested the Alfresco webscript connector on a new test environment.
Here are the steps I followed: 

 	* Downloaded the last version of Alfresco community and installed it
with the script: alfresco-community-installer-201707-linux-x64.bin
 	* Downloaded the alfresco-indexer from github and run a mvn install
-Dmaven.test.skip=true on it
 	* Installed the generated amp with the following command:

java -jar alfresco-mmt.jar install
pathtoalfrescoindexer/alfrescro-indexer-webscripts/target/alfresco-indexer-webscripts.amp
pathtoalfrescoinstalldir/tomcat/webapps/alfresco.war -force and started
alfresco 

 	* Downloaded and started the last version of manifoldcf 
(apache-manifoldcf-2.9-bin.zip) in single process mode (start.sh)
 	* Created an alfresco webscript connector with the following
connection params:

 	* Protocol : http
 	* Host name : localhost
 	* Port : 8080
 	* Context : /alfresco/service
 	* Store protocol : workspace
 	* Store ID : SpacesStore
 	* User name : admin
 	* Password : admin

And got the error : "Alfresco connection check failed". You can find the
log file in attachment. Did I miss something? 

Thank you for your help, 

Regards, 

Aurélien MAZOYER 

On 27.10.2017 16:01, Luis Cabaceira wrote:

> Also check the possible configurations that you can add to your alfresco-global.properties

> 
> CONFIGURATION
> 
> Alfresco Indexer Webscripts can be configured to tweak the indexing process; in alfresco-global.properties
you can override the following default parameters. 
> 
> [1]URL PREFIXES
> 
> indexer.properties.url.prefix = http://localhost:8080/alfresco/service/node/details
> indexer.document.url.prefix = http://localhost:8080/alfresco/service/slingshot/node
> indexer.content.url.prefix = http://localhost:8080/alfresco/service
> indexer.share.url.prefix = http://localhost:8888/share
> indexer.preview.url.prefix = http://localhost:8080/alfresco/service
> indexer.thumbnail.url.prefix = http://localhost:8080/alfresco/service
> 
> [2]NODE CHANGES PAGING PARAMETERS
> 
> indexer.changes.nodesperacl=10
> indexer.changes.nodespertxn=10
> 
> [3]NODE CHANGES ALLOWED NODE TYPES (WHITELIST)
> 
> indexer.changes.allowedTypes={http://www.alfresco.org/model/content/1.0}content,{http://www.alfresco.org/model/content/1.0}folder
> 
> Other examples of allowed types:
> 
> {http://www.alfresco.org/model/forum/1.0}topic
> {http://www.alfresco.org/model/forum/1.0}post
> {http://www.alfresco.org/model/content/1.0}person
> {http://www.alfresco.org/model/content/1.0}link
> {http://www.alfresco.org/model/calendar}calendar
> {http://www.alfresco.org/model/calendar}calendarEvent
> {http://www.alfresco.org/model/datalist/1.0}dataList
> {http://www.alfresco.org/model/datalist/1.0}dataListItem (includes all sub-types, such
as dl:task, dl:event and dl:issue)
> {http://www.alfresco.org/model/blogintegration/1.0}blogDetails
> {http://www.alfresco.org/model/blogintegration/1.0}blogPost
> 
> On 27 October 2017 at 15:00, Luis Cabaceira <cabaceira@gmail.com> wrote:
> 
> Ok, i've just tested this again in 2.8.1 and i didn't need to compile alfresco-indexer.
Using the Alfresco webscripts connector you only need to have the amps installed in Alfresco
and you don't need to touch the alfresco-indexer jar file that comes with the Manifold release.

> 
> The Alfresco Indexer Webscripts (A server-side component (an AMP that needs to be installed
in Alfresco)) expose a set of Webscripts (RESTFull urls) on Alfresco Repository that are then
used by Manifold to communicate with Alfresco.  
> 
> This is my connection properties, connection type is Alfresco Webscript. 
> 
> After saving with your values you should have 
> 
> Hope this helps, 
> Luis 
> 
> On 24 October 2017 at 15:44, Aurélien MAZOYER <aurelien.mazoyer@francelabs.com>
wrote:
> 
> Hi, 
> 
> Sure,here are the different steps: 
> 
> * Compiled alfresco-indexer (with alfresco-version 5.2.f in pom) with skipTest option
> * Deployed amp to Alfresco (Is there any way to validate that the service is up and running?)
> * Started last version of MCF in single process mode and created a webscript repository
connection with the following configuration:
> 
> PROTOCOL: 
> 
> http 
> 
> HOST NAME: 
> 
> host 
> 
> PORT: 
> 
> 8080 
> 
> CONTEXT: 
> 
> /alfresco/service 
> 
> STORE PROTOCOL: 
> 
> workspace 
> 
> STORE ID: 
> 
> SpacesStore 
> 
> USER NAME: 
> 
> user 
> 
> PASSWORD: 
> 
> ******** 
> 
> * Saved the config and got the exception... Is there any way to be sure that my configuration
is correct?
> 
> Thank you, 
> 
> Aurélien 
> 
> DE : Luis Cabaceira [mailto:cabaceira@gmail.com] 
> ENVOYÉ : mardi 24 octobre 2017 15:18
> 
> À : user@manifoldcf.apache.org
> OBJET : Re: Alfresco webscript connection problem 
> 
> Please enumerate the steps you are doing to test this so I can repeat them here and let
you know.
> 
> Luis Cabaceira
> 
> Alfresco  
> 
> On 24 Oct 2017, at 12:52, Aurélien MAZOYER <aurelien.mazoyer@francelabs.com> wrote:

> 
> Hi, 
> 
> I downloaded MCF 2.8.1 and tested it but I am still struggling with the following exception:

> 
> ERROR 2017-10-24T13:37:16,835 (qtp765242091-443) - Json response is missing username.

> 
> com.github.maoo.indexer.client.AlfrescoParseException: Json response is missing username.

> 
> at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.getUsername(WebScriptsAlfrescoClient.java:305)
~[alfresco-indexer-client-0.8.1.jar:?] 
> 
> at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.getUser(WebScriptsAlfrescoClient.java:298)
~[alfresco-indexer-client-0.8.1.jar:?] 
> 
> at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.userFromHttpEntity(WebScriptsAlfrescoClient.java:289)
~[alfresco-indexer-client-0.8.1.jar:?] 
> 
> at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.fetchUserAuthorities(WebScriptsAlfrescoClient.java:352)
~[alfresco-indexer-client-0.8.1.jar:?] 
> 
> at org.apache.manifoldcf.crawler.connectors.alfrescowebscript.AlfrescoConnector.check(AlfrescoConnector.java:133)
[mcf-alfresco-webscript-connector.jar:?] 
> 
> I cannot understand the error message as I provided a username in the alfresco webscript
repo connection configuration. 
> 
> Any idea of what I can investigate ? 
> 
> Thank you, 
> 
> Aurélien 
> 
> DE : Luis Cabaceira [mailto:cabaceira@gmail.com] 
> ENVOYÉ : vendredi 20 octobre 2017 12:25
> À : user@manifoldcf.apache.org
> OBJET : Re: Alfresco webscript connection problem 
> 
> Hi, i've used 2.8.1 OOTB with the Amps installed in Alfresco as per the documentation.
 
> 
> On 20 October 2017 at 10:56, Aurélien MAZOYER <aurelien.mazoyer@francelabs.com>
wrote: 
> 
> Hi, 
> 
> @Luis : Can you tell me if you used Manifold 2.8.1 out of the box for your test or if
you used a custom alfresco-indexer lib for your test? 
> 
> Thank you, 
> 
> Aurélien 
> 
> DE : Aurélien MAZOYER [mailto:aurelien.mazoyer@francelabs.com] 
> ENVOYÉ : vendredi 6 octobre 2017 14:03
> À : user@manifoldcf.apache.org
> 
> OBJET : RE: Alfresco webscript connection problem 
> 
> Yes, here is the configuration I used : 
> 
> PROTOCOL: 
> 
> http 
> 
> HOST NAME: 
> 
> host 
> 
> PORT: 
> 
> 8080 
> 
> CONTEXT: 
> 
> /alfresco/service 
> 
> STORE PROTOCOL: 
> 
> workspace 
> 
> STORE ID: 
> 
> SpacesStore 
> 
> USER NAME: 
> 
> user 
> 
> PASSWORD: 
> 
> ******** 
> 
> Did you use Manifold 2.8.1 out of the box for your test or did you use a custom alfresco-indexer
lib? 
> 
> Regards, 
> 
> Aurélien 
> 
> DE : Luis Cabaceira [mailto:cabaceira@gmail.com] 
> ENVOYÉ : vendredi 6 octobre 2017 13:49
> À : user@manifoldcf.apache.org
> OBJET : Re: Alfresco webscript connection problem 
> 
> Have you filled in the username and password for Alfresco ? From the stacktrace you are
showing its apparently missing the username. I've just tested this with Alfresco 5.2 and Manifold
2.8.1 and it works ok for me. 
> 
> On 6 October 2017 at 09:00, Aurélien MAZOYER <aurelien.mazoyer@francelabs.com>
wrote: 
> 
> Hi, 
> 
> Thank you for your advice. I am now able to compile the project with the following command:

> 
> mvn clean install -Dmaven.test.skip=true  
> 
> and the following pom.xml 
> 
> <properties> 
> 
> <alfresco.version>5.2.f</alfresco.version> 
> 
> <!--<alfresco.enterprise.version>5.0.2</alfresco.enterprise.version>-->

> 
> <h2-support.version>5.0</h2-support.version> 
> 
> </properties> 
> 
> I copied the fresh compiled alfresco-indexer-client.jar to the connector-lib folder of
manifoldcf (version 2.7.1) and deployed the amp on Alfresco. 
> 
> I tried to configure a repository connection in mcf with the following configuration:

> 
> PROTOCOL: 
> 
> http 
> 
> HOST NAME: 
> 
> host 
> 
> PORT: 
> 
> 8080 
> 
> CONTEXT: 
> 
> /alfresco/service 
> 
> STORE PROTOCOL: 
> 
> workspace 
> 
> STORE ID: 
> 
> SpacesStore 
> 
> USER NAME: 
> 
> user 
> 
> PASSWORD: 
> 
> ******** 
> 
> and I get the exception: 
> 
> ERROR 2017-10-05 18:06:11,518 (qtp1297502382-371) - Json response is missing username.

> 
> com.github.maoo.indexer.client.AlfrescoParseException: Json response is missing username.

> 
> at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.getUsername(WebScriptsAlfrescoClient.java:315)

> 
> at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.getUser(WebScriptsAlfrescoClient.java:308)

> 
> at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.userFromHttpEntity(WebScriptsAlfrescoClient.java:299)

> 
> at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.fetchUserAuthorities(WebScriptsAlfrescoClient.java:362)

> 
> at org.apache.manifoldcf.crawler.connectors.alfrescowebscript.AlfrescoConnector.check(AlfrescoConnector.java:133)

> 
> at org.apache.jsp.viewconnection_jsp._jspService(viewconnection_jsp.java:249) 
> 
> at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70) 
> 
> at javax.servlet.http.HttpServlet.service(HttpServlet.java:790) 
> 
> at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:388) 
> 
> at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313) 
> 
> at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:260) 
> 
> at javax.servlet.http.HttpServlet.service(HttpServlet.java:790) 
> 
> at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:769) 
> 
> at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:585) 
> 
> at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143) 
> 
> at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:595) 
> 
> at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:223)

> 
> at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1125)

> 
> at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:515) 
> 
> Any idea what is going on? 
> 
> Regards, 
> 
> Aurélien 
> 
> DE : Luis Cabaceira [mailto:cabaceira@gmail.com] 
> ENVOYÉ : mercredi 4 octobre 2017 12:23
> À : user@manifoldcf.apache.org
> 
> OBJET : Re: Alfresco webscript connection problem 
> 
> Hi, enterprise artifacts from Alfresco (assuming you have an account on Alfresco nexus)
normally do not end in letters. 
> 
> So for example, for enterprise 5.2.1.1 <alfresco.enterprise.version>5.2.1.1</alfresco.enterprise.version>

> 
> The best way to check is to login to nexus.alfresco.com [4] and search for the version
you want. 
> 
> <dependency> 
> 
> <groupId>org.alfresco</groupId> 
> 
> <artifactId>alfresco-enterprise</artifactId> 
> 
> <version>5.2.1.1</version> 
> 
> <type>war</type> 
> 
> </dependency> 
> 
> On 4 October 2017 at 10:34, Aurélien MAZOYER <aurelien.mazoyer@francelabs.com>
wrote: 
> 
> Hi All, 
> 
> I am not sure that my last email has been correctly delivered to the ML. 
> 
> Can you please tell me if my modification to the pom.xml is correct? 
> 
> Thank you 
> 
> Regards, 
> 
> Aurélien 
> 
> DE : Aurélien MAZOYER [mailto:aurelien.mazoyer@francelabs.com] 
> ENVOYÉ : mardi 12 septembre 2017 15:23
> À : 'user@manifoldcf.apache.org' <user@manifoldcf.apache.org>
> CC : 'Luis Cabaceira' <luis.cabaceira@alfresco.com>; 'Rafa Haro' <rharo@apache.org>
> OBJET : RE: Alfresco webscript connection problem 
> 
> Hi all, 
> 
> Thank you for your answer and sorry for my late reply. 
> 
> @Maurizio : When I first tested it, I forgot to modify the pom.xml. 
> 
> Then, I wanted to compile it again with the correct version and set the following properties:

> 
> <properties> 
> 
> <!--<alfresco.version>5.2.f</alfresco.version>--> 
> 
> <alfresco.enterprise.version>5.2.f</alfresco.enterprise.version> 
> 
> <h2-support.version>5.0</h2-support.version> 
> 
> </properties> 
> 
> before running a "mvn clean install". However, I can see that the alfresco-core 5.0.d
jar is still used during the compilation phrase. 
> 
> Did I do something wrong? 
> 
> Thank you. 
> 
> Aurélien 
> 
> DE : Luis Cabaceira [mailto:cabaceira@gmail.com] 
> ENVOYÉ : mardi 22 août 2017 13:21
> À : user@manifoldcf.apache.org
> CC : Luis Cabaceira <luis.cabaceira@alfresco.com>; Rafa Haro <rharo@apache.org>
> OBJET : Re: Alfresco webscript connection problem
> 
> Hi, i'm currently onsite with customer but i can take a look and try to reproduce the
issue next week.
> 
> Luis 
> 
> On 22 August 2017 at 12:12, Maurizio Pillitu <maoo@apache.org> wrote: 
> 
> Hi Aurélien,
> 
> also adding Luis Cabaceira (from Alfresco Consultancy team) that can probably help and
try to reproduce the issue. 
> 
> I haven't tested the connector yet against 5.2.0 Community, I'll give it a try and see
if I can reproduce the issue. 
> 
> In the meantime, can you please confirm that you followed the steps described in https://github.com/Alfresco/alfresco-indexer/blob/master/MANIFOLD.md
[5] ? Note that instructions are based on Manifold 2.2 , Solr 4.9.1 and Alfresco 5.1.x, you'd
need to tweak those values to use the versions of choice. 
> 
> Thanks,
> 
> mao 
> 
> On Tue, Aug 22, 2017 at 12:43 PM Karl Wright <daddywri@gmail.com> wrote: 
> 
> Hi Maurizio and Rafa, do you have any response? 
> 
> Karl 
> 
> On Wed, Aug 9, 2017 at 1:24 PM, Karl Wright <daddywri@gmail.com> wrote: 
> 
> It might be the case.  I'm cc'ing the resident Alfresco experts about this now.
> 
> Karl 
> 
> On Wed, Aug 9, 2017 at 1:17 PM, Aurélien MAZOYER <aurelien.mazoyer@francelabs.com>
wrote: 
> 
> Hi community, 
> 
> I want to crawl data from an Alfresco Community v.5.2.0 with the Alfresco Webscript connector
of ManifoldCF 2.7.1. 
> 
> I installed the AMP as explained in https://github.com/Alfresco/alfresco-indexer [6]

> 
> When I try to set up a repository connection to my Alfresco server, I get the exception:

> 
> ERROR 2017-08-09 19:01:27,071 (qtp790722099-425) - Json response is missing username.

> 
> com.github.maoo.indexer.client.AlfrescoParseException: Json response is missing username.

> 
> at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.getUsername(WebScriptsAlfrescoClient.java:305)

> 
> at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.getUser(WebScriptsAlfrescoClient.java:298)

> 
> at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.userFromHttpEntity(WebScriptsAlfrescoClient.java:289)

> 
> at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.fetchUserAuthorities(WebScriptsAlfrescoClient.java:352)

> 
> I read in the MCF documentation that the connector was tested with Alfresco 5.0.d. 
> 
> Do you think the connector is not compliant with Alfresco 5.2 and that is why I encounter
this exception? 
> 
> Thank you, 
> 
> Aurélien

-- 

Maurizio Pillitu 

maoo @ keybase [7]/github [8]/twitter [9]/apache/linkedIn [10] 

-- 

Luis Cabaceira 

-- 

Luis Cabaceira 

-- 

Luis Cabaceira 

-- 

Luis Cabaceira 

  -- 

Luis Cabaceira 

  -- 
Luis Cabaceira 

 

Links:
------
[1] https://github.com/cabaceira/alfresco-indexer#url-prefixes
[2]
https://github.com/cabaceira/alfresco-indexer#node-changes-paging-parameters
[3]
https://github.com/cabaceira/alfresco-indexer#node-changes-allowed-node-types-whitelist
[4] http://nexus.alfresco.com
[5] https://github.com/Alfresco/alfresco-indexer/blob/master/MANIFOLD.md
[6] https://github.com/Alfresco/alfresco-indexer
[7] https://keybase.io/maoo
[8] https://github.com/maoo
[9] https://twitter.com/maoo
[10] https://www.linkedin.com/in/mpillitu
Mime
View raw message