manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: SharePoint Server connection issue
Date Thu, 12 Oct 2017 11:46:12 GMT
Sorry, forgot to include the doc link:

https://cwiki.apache.org/confluence/display/CONNECTORS/Debugging+Connections

Karl


On Thu, Oct 12, 2017 at 6:55 AM, Karl Wright <daddywri@gmail.com> wrote:

> I will need you to debug your connection by turning on httpclient wire
> debugging.  This document is, unfortunately, out of date, since our log4j
> dependency is now log4j2 (with an xml configuration file).  But this is
> what you need to do to get information back in the log that you'd use to
> diagnose why your connection is not working.  The problem could be anything
> from:
> (a) no redirection is taking place still, to
> (b) login credentials are incorrect in some way, to
> (c) a whole slew of other possibilities.
>
> Thanks,
> Karl
>
>
> On Thu, Oct 12, 2017 at 5:58 AM, Kalam, Venkata Krishna Chaitanya <
> vkalam@informatica.com> wrote:
>
>> HI Karl
>>
>> Thanks for the patch. But after applying the patch also it still shows
>> the same message for the connection. Can you please let me know if any
>> additional changes required.
>>
>> Thanks
>>
>> Chaitanya
>>
>>
>>
>>
>>
>> *From:* Karl Wright [mailto:daddywri@gmail.com]
>> *Sent:* Wednesday, October 11, 2017 10:46 PM
>> *To:* user@manifoldcf.apache.org
>> *Subject:* Re: SharePoint Server connection issue
>>
>>
>>
>> Hi Venkata,
>>
>>
>>
>> Please see https://issues.apache.org/jira/browse/CONNECTORS-1465 .
>> There is an attached patch which I think should solve your problem.  Please
>> let me know.
>>
>>
>>
>> Karl
>>
>>
>>
>>
>>
>> On Wed, Oct 11, 2017 at 12:53 PM, Karl Wright <daddywri@gmail.com> wrote:
>>
>> The SharePoint connector uses HttpClient's DefaultRedirectStrategy, as
>> described here:
>>
>> https://hc.apache.org/httpcomponents-client-ga/httpclient/
>> apidocs/org/apache/http/impl/client/DefaultRedirectStrategy.html
>>
>>
>>
>> It looks like httpclient no longer automatically redirects POST requests
>> using this strategy; it should be LaxRedirectStrategy instead for that to
>> happen.  I'll open a ticket and provide a patch.
>>
>>
>>
>> Karl
>>
>>
>>
>>
>>
>> On Wed, Oct 11, 2017 at 12:45 PM, Kalam, Venkata Krishna Chaitanya <
>> vkalam@informatica.com> wrote:
>>
>> Hi
>>
>> When I am trying to connect to a sharepoint server using manifoldcf 2.8.1
>> I am getting following error.
>>
>>
>>
>> The site at http://inv28webapps11/sites/portal did not exist or was
>> external; skipping.
>>
>> From my troubleshooting, going through some blogs and GitHub code, I
>> found out the server is generating redirect response (http code 302).So
>> it’s printing this message.
>>
>> Can you please suggest any workaround in order to connect to a SharePoint
>> server that’s generating redirect response.?
>>
>>
>>
>> References for me to come to the conclusion.
>>
>> ==================================
>>
>> https://cwiki.apache.org/confluence/display/CONNECTORS/Debug
>> ging+Connections
>>
>> https://mail-archives.apache.org/mod_mbox/manifoldcf-commits
>> /201602.mbox/%3C20160222125008.0F7A33A0249@svn01-us-west.apache.org%3E
>>
>>
>>
>> and through chrome developer tools I found out server is indeed giving a
>> 302 response.
>>
>>
>>
>>
>>
>> sharepoint connection  details:
>>
>> *Server SharePoint version:*
>>
>> SharePoint Services 5.0 (2013)
>>
>> *Server protocol:*
>>
>> http
>>
>> *Server name:*
>>
>> inv28webapps11
>>
>> *Server port:*
>>
>> 80
>>
>> *Site path:*
>>
>> /sites/portal
>>
>>
>>
>>
>>
>>
>>
>
>

Mime
View raw message