manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: SharePoint Server connection issue
Date Wed, 11 Oct 2017 16:53:23 GMT
The SharePoint connector uses HttpClient's DefaultRedirectStrategy, as
described here:

https://hc.apache.org/httpcomponents-client-ga/httpclient/apidocs/org/apache/http/impl/client/DefaultRedirectStrategy.html

It looks like httpclient no longer automatically redirects POST requests
using this strategy; it should be LaxRedirectStrategy instead for that to
happen.  I'll open a ticket and provide a patch.

Karl


On Wed, Oct 11, 2017 at 12:45 PM, Kalam, Venkata Krishna Chaitanya <
vkalam@informatica.com> wrote:

> Hi
>
> When I am trying to connect to a sharepoint server using manifoldcf 2.8.1
> I am getting following error.
>
>
>
> The site at http://inv28webapps11/sites/portal did not exist or was
> external; skipping.
>
> From my troubleshooting, going through some blogs and GitHub code, I found
> out the server is generating redirect response (http code 302).So it’s
> printing this message.
>
> Can you please suggest any workaround in order to connect to a SharePoint
> server that’s generating redirect response.?
>
>
>
> References for me to come to the conclusion.
>
> ==================================
>
> https://cwiki.apache.org/confluence/display/CONNECTORS/
> Debugging+Connections
>
> https://mail-archives.apache.org/mod_mbox/manifoldcf-commits/201602.mbox/%
> 3C20160222125008.0F7A33A0249@svn01-us-west.apache.org%3E
>
>
>
> and through chrome developer tools I found out server is indeed giving a
> 302 response.
>
>
>
>
>
> sharepoint connection  details:
>
> *Server SharePoint version:*
>
> SharePoint Services 5.0 (2013)
>
> *Server protocol:*
>
> http
>
> *Server name:*
>
> inv28webapps11
>
> *Server port:*
>
> 80
>
> *Site path:*
>
> /sites/portal
>
>
>

Mime
View raw message