manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luis Cabaceira <cabace...@gmail.com>
Subject Re: Alfresco webscript connection problem
Date Wed, 04 Oct 2017 10:23:12 GMT
Hi, enterprise artifacts from Alfresco (assuming you have an account on
Alfresco nexus) normally do not end in letters.

So for example, for enterprise 5.2.1.1 <alfresco.enterprise.version>
5.2.1.1</alfresco.enterprise.version>

The best way to check is to login to nexus.alfresco.com and search for the
version you want.

<dependency>
  <groupId>org.alfresco</groupId>
  <artifactId>alfresco-enterprise</artifactId>
  <version>5.2.1.1</version>
  <type>war</type>
</dependency>



On 4 October 2017 at 10:34, Aurélien MAZOYER <
aurelien.mazoyer@francelabs.com> wrote:

> Hi All,
>
>
>
> I am not sure that my last email has been correctly delivered to the ML.
>
> Can you please tell me if my modification to the pom.xml is correct?
>
>
> Thank you
>
>
>
> Regards,
>
>
>
> Aurélien
>
>
>
> *De :* Aurélien MAZOYER [mailto:aurelien.mazoyer@francelabs.com]
> *Envoyé :* mardi 12 septembre 2017 15:23
> *À :* 'user@manifoldcf.apache.org' <user@manifoldcf.apache.org>
> *Cc :* 'Luis Cabaceira' <luis.cabaceira@alfresco.com>; 'Rafa Haro' <
> rharo@apache.org>
> *Objet :* RE: Alfresco webscript connection problem
>
>
>
> Hi all,
>
>
>
> Thank you for your answer and sorry for my late reply.
>
>
>
> @Maurizio : When I first tested it, I forgot to modify the pom.xml.
>
> Then, I wanted to compile it again with the correct version and set the
> following properties:
>
>     <properties>
>
>         <!--<alfresco.version>5.2.f</alfresco.version>-->
>
>         <alfresco.enterprise.version>5.2.f</alfresco.enterprise.version>
>
>         <h2-support.version>5.0</h2-support.version>
>
>     </properties>
>
> before running a “mvn clean install”. However, I can see that the
> alfresco-core 5.0.d jar is still used during the compilation phrase.
>
>
>
> Did I do something wrong?
>
>
> Thank you.
>
>
>
> Aurélien
>
>
>
> *De :* Luis Cabaceira [mailto:cabaceira@gmail.com <cabaceira@gmail.com>]
> *Envoyé :* mardi 22 août 2017 13:21
> *À :* user@manifoldcf.apache.org
> *Cc :* Luis Cabaceira <luis.cabaceira@alfresco.com>; Rafa Haro <
> rharo@apache.org>
> *Objet :* Re: Alfresco webscript connection problem
>
>
>
> Hi, i'm currently onsite with customer but i can take a look and try to
> reproduce the issue next week.
>
>
>
> Luis
>
>
>
> On 22 August 2017 at 12:12, Maurizio Pillitu <maoo@apache.org> wrote:
>
> Hi Aurélien,
>
>
>
> also adding Luis Cabaceira (from Alfresco Consultancy team) that can
> probably help and try to reproduce the issue.
>
>
>
> I haven't tested the connector yet against 5.2.0 Community, I'll give it a
> try and see if I can reproduce the issue.
>
>
>
> In the meantime, can you please confirm that you followed the steps
> described in https://github.com/Alfresco/alfresco-indexer/
> blob/master/MANIFOLD.md ? Note that instructions are based on Manifold
> 2.2 , Solr 4.9.1 and Alfresco 5.1.x, you'd need to tweak those values to
> use the versions of choice.
>
>
>
> Thanks,
>
>   mao
>
>
>
> On Tue, Aug 22, 2017 at 12:43 PM Karl Wright <daddywri@gmail.com> wrote:
>
> Hi Maurizio and Rafa, do you have any response?
>
>
>
> Karl
>
>
>
>
>
> On Wed, Aug 9, 2017 at 1:24 PM, Karl Wright <daddywri@gmail.com> wrote:
>
> It might be the case.  I'm cc'ing the resident Alfresco experts about this
> now.
>
>
>
> Karl
>
>
>
>
>
> On Wed, Aug 9, 2017 at 1:17 PM, Aurélien MAZOYER <
> aurelien.mazoyer@francelabs.com> wrote:
>
> Hi community,
>
>
>
> I want to crawl data from an Alfresco Community v.5.2.0 with the Alfresco
> Webscript connector of ManifoldCF 2.7.1.
>
> I installed the AMP as explained in https://github.com/Alfresco/
> alfresco-indexer
>
> When I try to set up a repository connection to my Alfresco server, I get
> the exception:
>
>
>
> ERROR 2017-08-09 19:01:27,071 (qtp790722099-425) - Json response is
> missing username.
>
> com.github.maoo.indexer.client.AlfrescoParseException: Json response is
> missing username.
>
>                at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.
> getUsername(WebScriptsAlfrescoClient.java:305)
>
>                at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.
> getUser(WebScriptsAlfrescoClient.java:298)
>
>                at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.
> userFromHttpEntity(WebScriptsAlfrescoClient.java:289)
>
>                at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.
> fetchUserAuthorities(WebScriptsAlfrescoClient.java:352)
>
>
>
> I read in the MCF documentation that the connector was tested with Alfresco
> 5.0.d.
>
> Do you think the connector is not compliant with Alfresco 5.2 and that is
> why I encounter this exception?
>
>
>
> Thank you,
>
>
>
> Aurélien
>
>
>
>
>
> --
>
> Maurizio Pillitu
>
> maoo @ keybase <https://keybase.io/maoo>/github <https://github.com/maoo>/
> twitter <https://twitter.com/maoo>/apache <maoo@apache.org>/linkedIn
> <https://www.linkedin.com/in/mpillitu>
>
>
>
>
>
> --
>
> Luis Cabaceira
>



-- 
Luis Cabaceira

Mime
View raw message