manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luis Cabaceira <cabace...@gmail.com>
Subject Re: Alfresco webscript connection problem
Date Tue, 24 Oct 2017 13:18:29 GMT
Please enumerate the steps you are doing to test this so I can repeat them here and let you
know.

Luis Cabaceira
Alfresco 

> On 24 Oct 2017, at 12:52, Aurélien MAZOYER <aurelien.mazoyer@francelabs.com> wrote:
> 
> Hi,
> 
> I downloaded MCF 2.8.1 and tested it but I am still struggling with the following exception:
> ERROR 2017-10-24T13:37:16,835 (qtp765242091-443) - Json response is missing username.
> com.github.maoo.indexer.client.AlfrescoParseException: Json response is missing username.
>         at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.getUsername(WebScriptsAlfrescoClient.java:305)
~[alfresco-indexer-client-0.8.1.jar:?]
>         at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.getUser(WebScriptsAlfrescoClient.java:298)
~[alfresco-indexer-client-0.8.1.jar:?]
>         at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.userFromHttpEntity(WebScriptsAlfrescoClient.java:289)
~[alfresco-indexer-client-0.8.1.jar:?]
>         at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.fetchUserAuthorities(WebScriptsAlfrescoClient.java:352)
~[alfresco-indexer-client-0.8.1.jar:?]
>         at org.apache.manifoldcf.crawler.connectors.alfrescowebscript.AlfrescoConnector.check(AlfrescoConnector.java:133)
[mcf-alfresco-webscript-connector.jar:?]
>  
> I cannot understand the error message as I provided a username in the alfresco webscript
repo connection configuration.
> Any idea of what I can investigate ?
>  
> Thank you,
>  
> Aurélien
>  
> De : Luis Cabaceira [mailto:cabaceira@gmail.com] 
> Envoyé : vendredi 20 octobre 2017 12:25
> À : user@manifoldcf.apache.org
> Objet : Re: Alfresco webscript connection problem
>  
> Hi, i've used 2.8.1 OOTB with the Amps installed in Alfresco as per the documentation.

>  
> On 20 October 2017 at 10:56, Aurélien MAZOYER <aurelien.mazoyer@francelabs.com>
wrote:
> Hi,
>  
> @Luis : Can you tell me if you used Manifold 2.8.1 out of the box for your test or if
you used a custom alfresco-indexer lib for your test?
>  
> Thank you,
> 
> Aurélien
>  
> De : Aurélien MAZOYER [mailto:aurelien.mazoyer@francelabs.com] 
> Envoyé : vendredi 6 octobre 2017 14:03
> À : user@manifoldcf.apache.org
> 
> Objet : RE: Alfresco webscript connection problem
>  
> Yes, here is the configuration I used :
>  
> Protocol:
> http
> Host name:
> host
> Port:
> 8080
> Context:
> /alfresco/service
> Store protocol:
> workspace
> Store ID:
> SpacesStore
> User name:
> user
> Password:
> ********
> Did you use Manifold 2.8.1 out of the box for your test or did you use a custom alfresco-indexer
lib?
> Regards,
> Aurélien
>  
>  
>  
> De : Luis Cabaceira [mailto:cabaceira@gmail.com] 
> Envoyé : vendredi 6 octobre 2017 13:49
> À : user@manifoldcf.apache.org
> Objet : Re: Alfresco webscript connection problem
>  
> Have you filled in the username and password for Alfresco ? From the stacktrace you are
showing its apparently missing the username. I've just tested this with Alfresco 5.2 and Manifold
2.8.1 and it works ok for me.
>  
> On 6 October 2017 at 09:00, Aurélien MAZOYER <aurelien.mazoyer@francelabs.com>
wrote:
> Hi,
>  
> Thank you for your advice. I am now able to compile the project with the following command:
> mvn clean install -Dmaven.test.skip=true 
> and the following pom.xml
>     <properties>
>         <alfresco.version>5.2.f</alfresco.version>
>         <!--<alfresco.enterprise.version>5.0.2</alfresco.enterprise.version>-->
>         <h2-support.version>5.0</h2-support.version>
>     </properties>
> I copied the fresh compiled alfresco-indexer-client.jar to the connector-lib folder of
manifoldcf (version 2.7.1) and deployed the amp on Alfresco.
>  
> I tried to configure a repository connection in mcf with the following configuration:
>  
> Protocol:
> http
> Host name:
> host
> Port:
> 8080
> Context:
> /alfresco/service
> Store protocol:
> workspace
> Store ID:
> SpacesStore
> User name:
> user
> Password:
> ********
>  
>  
> and I get the exception:
>  
> ERROR 2017-10-05 18:06:11,518 (qtp1297502382-371) - Json response is missing username.
> com.github.maoo.indexer.client.AlfrescoParseException: Json response is missing username.
>         at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.getUsername(WebScriptsAlfrescoClient.java:315)
>         at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.getUser(WebScriptsAlfrescoClient.java:308)
>         at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.userFromHttpEntity(WebScriptsAlfrescoClient.java:299)
>         at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.fetchUserAuthorities(WebScriptsAlfrescoClient.java:362)
>         at org.apache.manifoldcf.crawler.connectors.alfrescowebscript.AlfrescoConnector.check(AlfrescoConnector.java:133)
>         at org.apache.jsp.viewconnection_jsp._jspService(viewconnection_jsp.java:249)
>         at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
>         at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
>         at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:388)
>         at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313)
>         at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:260)
>         at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
>         at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:769)
>         at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:585)
>         at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
>         at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:595)
>         at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:223)
>         at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1125)
>         at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:515)
>  
> Any idea what is going on?
>  
> Regards,
>  
> Aurélien
>  
>  
> De : Luis Cabaceira [mailto:cabaceira@gmail.com] 
> Envoyé : mercredi 4 octobre 2017 12:23
> À : user@manifoldcf.apache.org
> 
> Objet : Re: Alfresco webscript connection problem
>  
> Hi, enterprise artifacts from Alfresco (assuming you have an account on Alfresco nexus)
normally do not end in letters. 
>  
> So for example, for enterprise 5.2.1.1 <alfresco.enterprise.version>5.2.1.1</alfresco.enterprise.version>
>  
> The best way to check is to login to nexus.alfresco.com and search for the version you
want.
>  
> <dependency>
>   <groupId>org.alfresco</groupId>
>   <artifactId>alfresco-enterprise</artifactId>
>   <version>5.2.1.1</version>
>   <type>war</type>
> </dependency>
>  
>  
>  
> On 4 October 2017 at 10:34, Aurélien MAZOYER <aurelien.mazoyer@francelabs.com>
wrote:
> Hi All,
>  
> I am not sure that my last email has been correctly delivered to the ML.
> Can you please tell me if my modification to the pom.xml is correct?
> 
> Thank you
>  
> Regards,
>  
> Aurélien
>  
> De : Aurélien MAZOYER [mailto:aurelien.mazoyer@francelabs.com] 
> Envoyé : mardi 12 septembre 2017 15:23
> À : 'user@manifoldcf.apache.org' <user@manifoldcf.apache.org>
> Cc : 'Luis Cabaceira' <luis.cabaceira@alfresco.com>; 'Rafa Haro' <rharo@apache.org>
> Objet : RE: Alfresco webscript connection problem
>  
> Hi all,
>  
> Thank you for your answer and sorry for my late reply.
>  
> @Maurizio : When I first tested it, I forgot to modify the pom.xml.
> Then, I wanted to compile it again with the correct version and set the following properties:
>     <properties>
>         <!--<alfresco.version>5.2.f</alfresco.version>-->
>         <alfresco.enterprise.version>5.2.f</alfresco.enterprise.version>
>         <h2-support.version>5.0</h2-support.version>
>     </properties>
> before running a “mvn clean install”. However, I can see that the alfresco-core 5.0.d
jar is still used during the compilation phrase.
>  
> Did I do something wrong?
> 
> Thank you.
>  
> Aurélien
>  
> De : Luis Cabaceira [mailto:cabaceira@gmail.com] 
> Envoyé : mardi 22 août 2017 13:21
> À : user@manifoldcf.apache.org
> Cc : Luis Cabaceira <luis.cabaceira@alfresco.com>; Rafa Haro <rharo@apache.org>
> Objet : Re: Alfresco webscript connection problem
>  
> Hi, i'm currently onsite with customer but i can take a look and try to reproduce the
issue next week.
>  
> Luis
>  
> On 22 August 2017 at 12:12, Maurizio Pillitu <maoo@apache.org> wrote:
> Hi Aurélien,
>  
> also adding Luis Cabaceira (from Alfresco Consultancy team) that can probably help and
try to reproduce the issue.
>  
> I haven't tested the connector yet against 5.2.0 Community, I'll give it a try and see
if I can reproduce the issue.
>  
> In the meantime, can you please confirm that you followed the steps described in https://github.com/Alfresco/alfresco-indexer/blob/master/MANIFOLD.md
? Note that instructions are based on Manifold 2.2 , Solr 4.9.1 and Alfresco 5.1.x, you'd
need to tweak those values to use the versions of choice.
>  
> Thanks,
>   mao
>  
> On Tue, Aug 22, 2017 at 12:43 PM Karl Wright <daddywri@gmail.com> wrote:
> Hi Maurizio and Rafa, do you have any response?
>  
> Karl
>  
>  
> On Wed, Aug 9, 2017 at 1:24 PM, Karl Wright <daddywri@gmail.com> wrote:
> It might be the case.  I'm cc'ing the resident Alfresco experts about this now.
>  
> Karl
>  
>  
> On Wed, Aug 9, 2017 at 1:17 PM, Aurélien MAZOYER <aurelien.mazoyer@francelabs.com>
wrote:
> Hi community,
>  
> I want to crawl data from an Alfresco Community v.5.2.0 with the Alfresco Webscript connector
of ManifoldCF 2.7.1.
> I installed the AMP as explained in https://github.com/Alfresco/alfresco-indexer
> When I try to set up a repository connection to my Alfresco server, I get the exception:
>  
> ERROR 2017-08-09 19:01:27,071 (qtp790722099-425) - Json response is missing username.
> com.github.maoo.indexer.client.AlfrescoParseException: Json response is missing username.
>                at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.getUsername(WebScriptsAlfrescoClient.java:305)
>                at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.getUser(WebScriptsAlfrescoClient.java:298)
>                at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.userFromHttpEntity(WebScriptsAlfrescoClient.java:289)
>                at com.github.maoo.indexer.client.WebScriptsAlfrescoClient.fetchUserAuthorities(WebScriptsAlfrescoClient.java:352)
>  
> I read in the MCF documentation that the connector was tested with Alfresco 5.0.d.
> Do you think the connector is not compliant with Alfresco 5.2 and that is why I encounter
this exception?
>  
> Thank you,
>  
> Aurélien
>  
>  
> --
> Maurizio Pillitu
> maoo @ keybase/github/twitter/apache/linkedIn
> 
> 
>  
> --
> Luis Cabaceira
> 
> 
>  
> --
> Luis Cabaceira
> 
> 
>  
> --
> Luis Cabaceira
> 
> 
>  
> --
> Luis Cabaceira

Mime
View raw message