manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Potts <jeffpott...@gmail.com>
Subject Re: SharePoint Connector: "Root site is unreachable"
Date Fri, 04 Nov 2016 00:01:10 GMT
In my example those are all virtual sites, but for some reason they are not accessible via
/site. Is that an indication that something is misconfigured on the Sharepoint side?

Why would the connector report a working connection but the job be unable to navigate the
path structure?

Jeff

> On Nov 3, 2016, at 6:17 PM, Karl Wright <daddywri@gmail.com> wrote:
> 
> Hi Jeff,
> 
> SharePoint's site model is as follows:
> 
> -- there is a root site, usually with the URL http://somedomain.com
> -- there are "virtual" sites, which are also full-fledge sites, usually with the URL
http://somedomain.com/site/site_name
> -- there are subsites of the root site, usually with URLs like http://somedomain.com/subsiteX
> -- there are subsites of virtual sites, usually with URLs like http://somedomain.com/site/site_name/subsiteY
> 
> Your MCF sharepoint connections should not point to subsites; they should only point
to the root site or a single virtual site.  There is no way to deal with crawling multiple
virtual sites with the same connection, which is what the documentation is trying to say.
> 
> I hope this helps.
> 
> Karl
> 
> 
>> On Thu, Nov 3, 2016 at 6:58 PM, Jeff Potts <jeffpotts01@gmail.com> wrote:
>> I am using apache-manifoldcf-2.5. I am trying to get the SharePoint Connector to
work against SharePoint 2003.
>> 
>> My SharePoint site URLs are like:
>> http://somedomain.com/SomeSite/_layouts/viewlsts.aspx
>> http://somedomain.com/SomeOtherSite/_layouts/viewlsts.aspx
>> http://somedomain.com/YetAnotherSite/_layouts/viewlsts.aspx
>> 
>> I have set up a Connector with:
>> 
>> Server protocol: http
>> Server name: somedomain.com
>> Server port: 80
>> Site path: /SomeSite
>> 
>> The connection status says, "Connection working".
>> 
>> However, when I go to set up a job, and I click the "Paths" tab, I see the message,
"Root site is unreachable, or user has no permissions".
>> 
>> I know I have permissions to that site because I can read/write to its document library
through the web interface. So I feel like I may be missing something regarding the correct
value for site path.
>> 
>> The docs say, "...type in the portion of the root site URL that includes everything
after the server and port, except for the final "aspx" file," which is why I am using "/SomeSite"
as the site path.
>> 
>> But another snippet from the docs says this:
>> 
>> "The SharePoint connection type is designed so that one SharePoint repository connection
can access all SharePoint sites from a specific root site though its explicit subsites. It
is the case that it is desirable in some very large SharePoint installations to access all
SharePoint sites using a single connection. But the ManifoldCF SharePoint connection type
does not support that model as of yet."
>> 
>> That confused me because it isn't clear if I should be specifying some sort of root
site (which I have no idea how to determine the path for) or if creating one connection for
each site should work.
>> 
>> Jeff
>> 
>> 
> 

Mime
View raw message