manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Najman, Radko" <radko.naj...@merck.com>
Subject Re: Getting Sharepoint ACL into Elasticsearch
Date Fri, 24 Jun 2016 13:07:40 GMT
Hi Karl,

thanks. To your comments:
(1) Originally I wasn’t using a user mapping. I tried it as an experiment when I couldn’t
make it work and I didn’t know what else to try because I read that somebody else used it
whe solving similar problem with Solr (https://mail-archives.apache.org/mod_mbox/manifoldcf-user/201406.mbox/%3CCANWCqG7L+EDTOjLoUgUda0YsaF6d1iYbE6Tdcqqhi7R1C42O3w@mail.gmail.com%3E)
(2) I still see “site did not exist” in the connection status for repository connection.
If I go to that address the site exists. What confuses me is that the authority connection
is working with the same server settings.

I will check the rest of your suggestions.

Thanks,
Radko

From: Karl Wright <daddywri@gmail.com<mailto:daddywri@gmail.com>>
Reply-To: "user@manifoldcf.apache.org<mailto:user@manifoldcf.apache.org>" <user@manifoldcf.apache.org<mailto:user@manifoldcf.apache.org>>
Date: Friday 24 June 2016 at 02:53
To: "user@manifoldcf.apache.org<mailto:user@manifoldcf.apache.org>" <user@manifoldcf.apache.org<mailto:user@manifoldcf.apache.org>>
Subject: Re: Getting Sharepoint ACL into Elasticsearch

Two comments:
(1) Why are you using a user mapping?  This typically would not be used for SharePoint authorities.
(2) Your repository connection is complaining that it can't connect.  Have you resolved that?

Have you installed the appropriate MCF SharePoint plugin on the server side?  Did you install
it when logged in as a user with full administrative privileges?  Are you crawling with a
user that has sufficient privileges to fetch ACL information?  If not, all documents will
be skipped because the connector won't be able to fetch ACLs from SharePoint.  You can figure
this out by enabling connector debugging (in properties.xml; see the how-to-build-and-deploy
page) and examining the logs to see why documents are being skipped.

Thanks,
Karl


On Thu, Jun 23, 2016 at 6:31 PM, Najman, Radko wrote:
Hello,

I’m trying to crawl Sharepoint documents into Elasticsearch. I configured MCF 2.1 (attached
are my configuration screenshots):

 1.  created Authority group
 2.  created User mapping (mapping.png)
 3.  created Authority connection with SharePoint/Native authority type (auth_conn.png)
 4.  created Repository connection with SharePoint authority type (rep_conn.png)
 5.  created job with enabled security (job.png)

When I ran the job I could see the documents were processed but no document was crawled into
the Eleasticsearch index.

I was able to crawl the documents with disabled security or when I specified the access token.
Then the documents were crawled and I could see "allow_token_document": “sharepoint_grp:my_token”
in the index.

What I want to do is to get the document ACLs and store them in the index but I cannot make
it. I tried different configurations and authority types but without any success.

Do I miss something?

Thank you,
Radko
Notice:  This e-mail message, together with any attachments, contains
information of Merck & Co., Inc. (2000 Galloping Hill Road, Kenilworth,
New Jersey, USA 07033), and/or its affiliates Direct contact information
for affiliates is available at 
http://www.merck.com/contact/contacts.html) that may be confidential,
proprietary copyrighted and/or legally privileged. It is intended solely
for the use of the individual or entity named on this message. If you are
not the intended recipient, and have received this message in error,
please notify us immediately by reply e-mail and then delete it from 
your system.

Mime
View raw message