manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adrian Conlon <Adrian.Con...@arup.com>
Subject RE: Continuous stream of errors from agents (using ManifoldCF 2.4)
Date Fri, 06 May 2016 15:23:58 GMT
Thanks again Konrad: you were spot on.  The problem was in my customised startup scripts.

Once I'd fixed those, ManifoldCF 2.4 worked perfectly.

Adrian

From: Adrian Conlon [mailto:Adrian.Conlon@arup.com]
Sent: 06 May 2016 15:43
To: user@manifoldcf.apache.org
Subject: RE: Continuous stream of errors from agents (using ManifoldCF 2.4)

Thanks Konrad,

Good catch!  I think it's my startup scripts that need to be looked at.

I'll double check, and let the list know if it works.

Adrian

From: Konrad Holl [mailto:KHoll@searchtechnologies.com]
Sent: 06 May 2016 15:33
To: user@manifoldcf.apache.org<mailto:user@manifoldcf.apache.org>
Subject: RE: Continuous stream of errors from agents (using ManifoldCF 2.4)

Hi Adrian,

it looks like a class it not found. Can you check your JARs for current http components (available
from https://hc.apache.org/downloads.cgi). httpcore-4.4.4.jar does contain the missing class.

You may also want to check the order of the JARs in the classpath when starting ManifoldCF.

Hope that helps

Konrad.

From: Adrian Conlon [mailto:Adrian.Conlon@arup.com]
Sent: Freitag, 6. Mai 2016 16:16
To: user@manifoldcf.apache.org<mailto:user@manifoldcf.apache.org>
Subject: Continuous stream of errors from agents (using ManifoldCF 2.4)

Hi List,

I've just started experimenting with using ManifoldCF 2.4 in our deployments and I'm coming
across a problem.

None of the jobs are progressing at all, past deciding that they have a single document to
process, and my logs are being flooded with the following:

FATAL 2016-05-06 15:09:38,350 (Worker thread '0') - Error tossed: org/apache/http/util/Args
java.lang.NoClassDefFoundError: org/apache/http/util/Args
        at org.apache.http.conn.ssl.SSLConnectionSocketFactory.<init>(SSLConnectionSocketFactory.java:294)
        at org.apache.http.conn.ssl.SSLConnectionSocketFactory.<init>(SSLConnectionSocketFactory.java:283)
       at org.apache.manifoldcf.agents.output.solr.HttpPoster.<init>(HttpPoster.java:231)
        at org.apache.manifoldcf.agents.output.solr.SolrConnector.getSession(SolrConnector.java:360)
        at org.apache.manifoldcf.agents.output.solr.SolrConnector.getPipelineDescription(SolrConnector.java:512)
        at org.apache.manifoldcf.agents.incrementalingest.IncrementalIngester.getOutputDescription(IncrementalIngester.java:479)
        at org.apache.manifoldcf.crawler.system.PipelineSpecification.<init>(PipelineSpecification.java:43)
        at org.apache.manifoldcf.crawler.system.WorkerThread.run(WorkerThread.java:308)

Any ideas where to look?  The scripts I'm using for deployment are exactly the same as I'm
using with v2.3.  I'm assuming I'm missing a step somewhere...

Thanks for any help received!

Adrian

____________________________________________________________
Electronic mail messages entering and leaving Arup  business
systems are scanned for acceptability of content and viruses

Mime
View raw message