manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: Importing a Manifoldcf config
Date Tue, 18 Nov 2014 21:08:34 GMT
I've attached a patch.  The ticket was already resolved in the dev_1x
branch.

Thanks,
Karl


On Tue, Nov 18, 2014 at 4:03 PM, Karl Wright <daddywri@gmail.com> wrote:

> Hi Michael,
>
> You are correct.  See CONNECTORS-1107.  I will be attaching a patch
> shortly.
>
> Karl
>
>
> On Tue, Nov 18, 2014 at 3:52 PM, Michael Wilken <wilkenm@gmail.com> wrote:
>
>> I'm running into an issue when trying to migrate a config from one
>> Manifoldcf instance to another.  The config was exported using:
>>
>> > executecommand.sh org.apache.manifoldcf.crawler.ImportConfiguration
>> ~/qa-manifoldcf.conf
>>
>>
>> I copy the export file to another server, and try to import it into a
>> different Manifoldcf instance:
>>
>> > executecommand.sh org.apache.manifoldcf.crawler.ImportConfiguration
>> ~/qa-manifoldcf.conf
>>
>> Configuration file successfully read
>> org.apache.manifoldcf.core.interfaces.ManifoldCFException: Error reading
>> configuration file: Unknown authority configuration version: 3
>> at
>> org.apache.manifoldcf.crawler.system.ManifoldCF.importConfiguration(ManifoldCF.java:816)
>> at
>> org.apache.manifoldcf.crawler.ImportConfiguration.doExecute(ImportConfiguration.java:42)
>> at
>> org.apache.manifoldcf.crawler.BaseCrawlerInitializationCommand.execute(BaseCrawlerInitializationCommand.java:37)
>> at
>> org.apache.manifoldcf.crawler.ImportConfiguration.main(ImportConfiguration.java:60)
>> Caused by: java.io.IOException: Unknown authority configuration version: 3
>> at
>> org.apache.manifoldcf.authorities.authority.AuthorityConnectionManager.importConfiguration(AuthorityConnectionManager.java:259)
>> at
>> org.apache.manifoldcf.crawler.system.ManifoldCF.importConfiguration(ManifoldCF.java:771)
>> ... 3 more
>>
>> At first, the 2 Manifold's were different versions, the source was 1.6.1,
>> and the destination was 1.7.2.   To rule out version issues, I installed a
>> new 1.6.1 instance, and got the same error.  There is a difference in
>> databases, the source is using Hypersonic, and the destination is Postgres,
>> but after a cursory look at the code, I don't think that should be a
>> problem.
>>
>> Any guidance is greatly appreciated!
>>
>> -mike
>>
>
>

Mime
View raw message