manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: Manifoldcf sharepoint connecyor
Date Tue, 20 May 2014 11:29:01 GMT
Hi Babita,

If what you are doing is simply setting up ManifoldCF for the first time,
what I'd do is this:

(1) Pick a deployment model.  All models work with Postgresql, so that is
not a reason to pick one over the other.  Simpler is usually better (easier
to manage etc), so if you can get away with the single-process model, that
would be the easiest.

This is the roughly the order of complexity, less complexity to more
complexity:
(a) Single process
(b) Combined war
(c) Multiprocess setup with zookeeper synchronization (agents process,
mcf-authority-service war, mcf-crawler-ui war, mcf-api-service war)
(d) Multiprocess setup with filesystem synchronization

(2) Configure MCF based strongly on the examples.  There is an example for
EVERY model above.  If you are using Tomcat rather than jetty, you still do
the same things.  But there are some differences:

- make sure the -D switch is set to point to the appropriate properties.xml
- make sure your tomcat and your agents process share the same working
directory, or resolving relative paths in properties.xml will not work
properly
- deploy the jars using the tomcat administrative web application; don't
mess with tomcat configuration information

Karl


On Tue, May 20, 2014 at 6:37 AM, Babita Bansal <babita.bansal@gmail.com>wrote:

> Hi Karl
>
> Please see my response below:
>
> (1) What version of MCF are you trying to debug?  Which MCF version did
> that screen shot come from? I refreshed my browser and clear the cache now
> seeing new UI.
>
> I am using manifold CF version 1.5.1 as mentioned downloaded code from
> apache-manifoldcf-1.5.1-src.zip<http://archive.apache.org/dist/manifoldcf/apache-manifoldcf-1.5.1-src.zip>
>  from
> http://manifoldcf.apache.org/en_US/download.html#Apache+ManifoldCF+1.5.1%2C+2014+Feb+20
>
> (2) How is MCF deployed on tomcat?  Is it the combined war you deployed,
> or individual service wars?
>
> I have configured xml configuration of all war files in tomcat conf
> location ../tomcat/conf/Catalina/localhost/, sample like
>
> <?xml version="1.0" encoding="utf-8"?>
>
> <Context docBase="C:\IW\MCF\manifoldcf\dist\web\war\mcf-api-service.war"
> debug="0" crossContext="true"> </Context>
>
>
> Did it for all 4 war simmilar way changing name of war and filename as per
> war. Which is successfully deploying and extracting on tomcat webapps
> folder.
>
> (3) What kind of synchronization have you configured in properties.xml?
>
> In properties file i have done following configuration to connect to
> postgres DB attached in mail.  And startup of tomcat use
> -Dorg.apache.manifoldcf.configfile=C:\IW\MCF\manifoldcf\dist\multiprocess-example\properties.xml
> to read the configuration of property file.
>
> My tomcat version in 7 and postgres version is 9.1 and running on windows
> 2008.
>
>
> Please let me know if i missed anything.
>
>
>
> Thanks
> Babita Bansal
>
>
> On Tue, May 20, 2014 at 11:16 AM, Karl Wright <daddywri@gmail.com> wrote:
>
>> Hi Babita,
>>
>> We have proven only that the SharePoint connector for 1.5.1 works
>> properly against the SharePoint you are trying to crawl, so there is no
>> SharePoint connector bug.  What I had intended to do from this point was to
>> change one thing at a time between the 1.5.1 single-process example running
>> on Derby and whatever MCF version and configuration you are trying to
>> debug.  But since I don't know what version that is, and don't know how it
>> is configured, I cannot make this plan work without further information.
>>
>> Before we go further, can you tell me:
>>
>> (1) What version of MCF are you trying to debug?  Which MCF version did
>> that screen shot come from?
>> (2) How is MCF deployed on tomcat?  Is it the combined war you deployed,
>> or individual service wars?
>> (3) What kind of synchronization have you configured in properties.xml?
>>
>> Thanks,
>> Karl
>>
>>
>>
>> On Tue, May 20, 2014 at 5:52 AM, Babita Bansal <babita.bansal@gmail.com>wrote:
>>
>>> Hi Karl
>>>
>>> I have downloaded source code zip  apache-manifoldcf-1.5.1-src.zip<http://archive.apache.org/dist/manifoldcf/apache-manifoldcf-1.5.1-src.zip>
>>>  from
>>> http://manifoldcf.apache.org/en_US/download.html#Apache+ManifoldCF+1.5.1%2C+2014+Feb+20
and built using ant build.
>>>
>>> What i mean here if i start manifold using start.jar, i could see the
>>> latest UI and share point connector is also working, will share you the
>>> screen shot. Can you point me the exact source code which needs to be use.
>>>
>>> Thanks
>>> Babita Bansal
>>>
>>>
>>>
>>> thanks
>>> Babita Banal
>>>
>>>
>>>
>>> On Tue, May 20, 2014 at 10:17 AM, Karl Wright <daddywri@gmail.com>wrote:
>>>
>>>> Also, your screen shot cannot be from mcf 1.5.1.  The style sheet is
>>>> completely different now.  What version of mcf are you really using?
>>>>
>>>> Karl
>>>>
>>>> Sent from my Windows Phone
>>>> ------------------------------
>>>> From: Karl Wright
>>>> Sent: 5/20/2014 5:13 AM
>>>> To: Babita Bansal; user@manifoldcf.apache.org
>>>> Subject: RE: Manifoldcf sharepoint connecyor
>>>>
>>>> Hi Babita,
>>>>
>>>> Lets take one step at a time.
>>>>
>>>> If single process example works, then try modifying single process
>>>> properties.xml to point to your postgres database.  The
>>>> how-to-build-and-deploy page describes the parameters you need to do that.
>>>>
>>>> Initialize.bat is not needed for single process, so just try this one
>>>> change and tell me how it goes.
>>>>
>>>> Thanks,
>>>> Karl
>>>>
>>>> Sent from my Windows Phone
>>>> ------------------------------
>>>> From: Babita Bansal
>>>> Sent: 5/20/2014 4:23 AM
>>>> To: user@manifoldcf.apache.org
>>>> Subject: Re: Manifoldcf sharepoint connecyor
>>>>
>>>> Hi
>>>>
>>>> I have tried with default database and application, it working fine
>>>> there. I need to use postgres DB. What i did, downloaded the source and
>>>> built using ant. And in properties.xml file provided the postgres db
>>>> settings, and run the command initialize.bat to create the postgres db. I
>>>> can connect to windows share and alfresco easily. But when i tried to
>>>> configure share point it just blank page no error on log file. Could you
>>>> please let me know how to set debugging, as i don't see anything in log
>>>> file. Attached screen shot for configuration :
>>>>
>>>>
>>>> Any ref guide or configuration details really appreciated. Just to
>>>> inform you guys i have not done any configuration on share point side for
>>>> share point connector.
>>>>
>>>>
>>>> If possible i can have screen share session with you.
>>>>
>>>> Thanks
>>>> Babita Bansal
>>>>
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> On Tue, May 20, 2014 at 12:33 AM, Karl Wright <daddywri@gmail.com>wrote:
>>>>
>>>>> Hi Babita,
>>>>>
>>>>> To rule out any database or app server misconfiguration, can you try
>>>>> running the single-process example, and setting up your SharePoint
>>>>> connection there?
>>>>>
>>>>> cd example
>>>>> <java> -jar start.jar
>>>>>
>>>>> <set up your connection in the UI>
>>>>>
>>>>> Thanks!
>>>>> Karl
>>>>>
>>>>>
>>>>>
>>>>> On Mon, May 19, 2014 at 6:58 PM, Babita Bansal <
>>>>> babita.bansal@gmail.com> wrote:
>>>>>
>>>>>> Hi
>>>>>>
>>>>>> I am trying to connect sharepoint 2010 with manifoldcf
>>>>>> . but after clicking on save i just get blank page . when i refresh
>>>>>> page o get illegal parameter value. I am using postgres db with tomcat
7.
>>>>>> Version of manifold is 1.5.1 . alfresco n windows share connectors
are
>>>>>> workimg fine
>>>>>>
>>>>>> Pls help to resolve any issue.
>>>>>>
>>>>>> Thanks
>>>>>>
>>>>>
>>>>>
>>>>
>>>
>>
>

Mime
View raw message