manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Warning!! Solr 3.x, Solr 4.x, and ElasticSearch plugin upgrades
Date Mon, 24 Feb 2014 08:24:40 GMT
Hi all,

As part of supporting parent security in Windows, we're reworking the way
ManifoldCF organizes security tokens.  New kinds of security tokens can be
added at any time in the future, and it is the responsibility of the output
connector to prevent documents whose security requirements are unsupported
from being indexed.

This means that there is now a very strong relationship between the version
of an output connector that supports security, and the plugin that enforces
it on the search engine side.  Upgrading one may well require upgrading the
other.

We have not yet figured out how to enforce that an upgrade take place.
There will likely be multiple versions of the plugins available (for one
thing), and there will also likely be a compatibility matrix available in
the documentation.  But, for now, please be aware that MCF trunk requires a
trunk version of the Solr 3.x, Solr 4.x, and ES plugins to fully secure
documents.

Thanks,
Karl

Mime
View raw message