manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: Share Point connection definition
Date Thu, 27 Feb 2014 13:03:39 GMT
Hi Yuvaraj,

Which version of the SharePoint 2010 plugin are you deploying?  It matters
because we changed the logging in the last SharePoint 2010 plugin release
to adhere more closely to SharePoint 2010 conventions.  The logging code
used with the most recent plugin release is:

>>>>>>
                SPDiagnosticsService.Local.WriteTrace(0, new
SPDiagnosticsCategory("MCPermissions.asmx", TraceSeverity.Unexpected,
EventSeverity.Error), TraceSeverity.Unexpected, "Error: "+ex.Message,
ex.StackTrace);
<<<<<<

You'll have to chase down where that goes on your installation. ;-)

Karl




On Thu, Feb 27, 2014 at 7:59 AM, yuvaraj ponnuswamy
<yuvaraj_p7@yahoo.co.in>wrote:

> Hi Karl,
>
> Thanks for the information, i will check whether the MCF is installed
> properly with admin user with full rights.
>
>
> Also, can i know usually where(which location)  the MCPermission plugin
> will write the log files.So that i can check it there.
>
>
> Thanks
> P.Yuvaraj kumar
>   *From:* Karl Wright <daddywri@gmail.com>
>
> *To:* "user@manifoldcf.apache.org" <user@manifoldcf.apache.org>; yuvaraj
> ponnuswamy <yuvaraj_p7@yahoo.co.in>
> *Sent:* Thursday, 27 February 2014, 17:41
>
> *Subject:* Re: Share Point connection definition
>
>   Hi Yuvaraj,
>
> The error reported is from the server side.  I believe that it is
> reporting that something went wrong but when the MCPermissions plugin tried
> to write to the server log, it did not have permissions to do so.  So there
> are TWO errors here.
>
> The MCPermissions plugin MUST be installed by an administrative user with
> full rights.  If it is not, it basically has insufficient permissions to do
> anything useful.  Can you check that this was done properly?
>
> Thanks,
> Karl
>
>
>
> On Thu, Feb 27, 2014 at 6:37 AM, yuvaraj ponnuswamy <
> yuvaraj_p7@yahoo.co.in> wrote:
>
>  Hi Karl/Ahmet,
>
> it is working now and able to index the document.
>
> I have another issue now, i have tried the connection with test share
> point URL and it was working fine.
>
> But when we chnaged the share point url in the Repository connector to
> another url in development environment where all our documents are
> present.I am getting the below error instead of connection working. Where
> as if we give the sharepoint url directly in the browser it is working.
>
> We have installed the MCPermissionService in the development environment.
> Can you please let me know what could cause this error.
>
> Error:
> Unknown SharePoint server error accessing site - axis fault = Server,
> detail = Server was unable to process request. ---> The source was not
> found, but some or all event logs could not be searched. Inaccessible logs:
> Security.
>
>
> I have also attaced the screen shot of the connection definition.
>
> Please let us know your comments.
>
>
>
> Thanks
> P.Yuvaraj Kumar
>
>   *From:* Ahmet Arslan <iorixxx@yahoo.com>
> *To:* "user@manifoldcf.apache.org" <user@manifoldcf.apache.org>; yuvaraj
> ponnuswamy <yuvaraj_p7@yahoo.co.in>
> *Sent:* Thursday, 20 February 2014, 3:22
> *Subject:* Re: Share Point connection definition
>
> Hi Yuvaraj,
>
>
> It seems that you get 'connection working' for share-point repository
> connection. Did you able to index your data from share point? If not can
> you give us your Job definition parameters?
>
> Ahmet
>
>
>
> On Wednesday, February 5, 2014 6:35 PM, yuvaraj ponnuswamy <
> yuvaraj_p7@yahoo.co.in> wrote:
>
> Hi Karl,
>
> i have given the site path as default which is empty.
>
> After giving that when i run the job it is keep on running(Running for 3
> hrs continously usually)
> I am not sure it is indexing the documents from the share point. if
> required i can send the screen shot of my configurations.
>
>
> Thanks
> P.Yuvaraj kumar
> From: Karl Wright <daddywri@gmail.com>
> To: yuvaraj ponnuswamy <yuvaraj_p7@yahoo.co.in>
> Cc: "user@manifoldcf.apache.org" <user@manifoldcf.apache.org>
> Sent: Wednesday, 5 February 2014, 21:49
> Subject: Re: Share Point connection definition
>
>
>
> Hi Yuvaraj,
>
> This is the part you did wrong:
>
> "2) then pasted the path as :/TestDocLib/Forms"
>
> That *explicitly* disagrees with the instructions in the user manual.
>
> The site root path for your machine seems to be:
>
> host name: 10.232.25.114
> port: 80
> protocol: http
> site path: the default
>
> Please try that and let me know what you see when you view the connection.
>
> Thanks,
> Karl
>
>
>
>
>
> On Wed, Feb 5, 2014 at 11:15 AM, yuvaraj ponnuswamy <
> yuvaraj_p7@yahoo.co.in> wrote:
>
> Hi Karl,
> >
> >
> >Thanks for your response.
> >
> >I have logged into the share point url:
> >
> >1)
> >http://10.232.25.114/
> >
> >
> >2) then pasted the path as :/TestDocLib/Forms
> >
> >3) Resolving the url as below:
> >
> http://10.232.25.114/TestDocLib/Forms/AllItems.aspx?RootFolder=%2fTestDocLib%2fForms&FolderCTID=0x012001
> >
> >this has no documents under this path.
> >
> >
> >This is what you are mentioning or else, can you please little eloborate
> on your suggestion.
> >
> >
> >Thanks
> >P.Yuvaraj Kumar
> >
> >
> >From: Karl Wright <daddywri@gmail.com>
> >To: "user@manifoldcf.apache.org" <user@manifoldcf.apache.org>; yuvaraj
> ponnuswamy <yuvaraj_p7@yahoo.co.in>
> >Sent: Wednesday, 5 February 2014, 21:35
> >Subject: Re: Share Point connection definition
> >
> >
> >
> >Hi Yavaraj,
> >
> >This URL cannot be the site root URL; it's in fact the URL for some bit
> of SharePoint data.  Can you please log into your SharePoint UI at the root
> site level, and without navigating anywhere else, post the URL displayed in
> the browser here?  You may redact the actual site name part of the path.
> >
> >Karl
> >
> >
> >
> >
> >
> >On Wed, Feb 5, 2014 at 10:55 AM, yuvaraj ponnuswamy <
> yuvaraj_p7@yahoo.co.in> wrote:
> >
> >HI Karl,
> >>
> >>I am trying to configire the ManifoldCF with Share Point as Repository
> connector and Solr as the output connector.
> >>
> >>I have attched the share point configuration details.i have given the
> site path field as everything after the server and port , except the final
> aspx file as mentioned in the MCF end User documentation.
> >>If i remove the site path value as empty then it is running without
> error.
> >>
> >>Site path: /TestDocLib/Forms
> >>
> >>But while running the Job i am getting the exception as
> >>Error: Library view url without site is not in the expected form:
> 'ms/AllItems.aspx'
> >>
> >>Please let me know site path is necessary. I have attched the screen
> shot for your reference.
> >>
> >>
> >>Thanks
> >>P.Yuvaraj Kumar
> >
> >
> >
>
>
>
>
>
>

Mime
View raw message