manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: ManifoldCF configuration with Sharepoint and Solr
Date Wed, 22 Jan 2014 12:48:39 GMT
Hi Yavaraj,

This warning:
"WARN 2014-01-22 18:01:46,682 (Worker thread '25') - Service interruption
reported for job 1390290609168 connection 'MySharePointTCG': Remote
procedure exception: The Web application at http://10.232.25.114/ could not
be found. Verify that you have typed the URL correctly. If the URL should
be serving existing content, the system administrator may need to add a new
request URL mapping to the intended application. "

... usually means that your IIS is not set up correctly.  The setup issue I
am thinking of means that the web services ManifoldCF relies on do not work
properly because they see the wrong URL paths for their context.  The error
message is informative; you need to add a new request URL mapping in IIS
for this aspect of SharePoint to work correctly.  There are a number of
message threads in this list which explain in greater or lesser detail what
exactly needs to be done.  You can look for those here:
http://mail-archives.apache.org/mod_mbox/manifoldcf-user/ ... or here:
http://mail-archives.apache.org/mod_mbox/manifoldcf-dev/ .

Karl


On Wed, Jan 22, 2014 at 7:41 AM, yuvaraj ponnuswamy
<yuvaraj_p7@yahoo.co.in>wrote:

> Hi Karl,
>
> I have created the Library - TestDocLib and added two files -error.docx
> and Sametime1.docx and one folder called Folder1 in the SharePoint.
>
> I also configured the Path rule as /TestDocLib/* and Metadata as
> /TestDocLib/.
>
> But while running the JOb it is keep on running and displaying the details
> as below, but i have only two documents in the Share Point Library
> -TestDocLib
>
> Document - 2
> Active - 1
> Processed - 2
>
> I am not sure why it is not updating the status of the Job correctly and
> it is keep on going in running status.
>
> Also when i checked the logs, i am seeing the below exception.
>
> Please let me know if i am missing any thing.In the Solr side i am using
> the default collection1 core.I have attched the updated Screen shots.
>
>
> Please let me know you suggestions that would be of great help.
>
> Logs: manifoldcf.log
> ----------------------
>  WARN 2014-01-22 17:50:30,208 (Thread-64717) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>  WARN 2014-01-22 17:50:30,239 (Worker thread '16') - Service interruption
> reported for job 1390290609168 connection 'MySharePointTCG': Remote
> procedure exception: The Web application at http://10.232.25.114/ could
> not be found. Verify that you have typed the URL correctly. If the URL
> should be serving existing content, the system administrator may need to
> add a new request URL mapping to the intended application.
>  WARN 2014-01-22 17:55:50,143 (Thread-67282) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>  WARN 2014-01-22 17:56:08,534 (Thread-67427) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>  WARN 2014-01-22 17:56:08,565 (Worker thread '23') - Service interruption
> reported for job 1390290609168 connection 'MySharePointTCG': Remote
> procedure exception: The Web application at http://10.232.25.114/ could
> not be found. Verify that you have typed the URL correctly. If the URL
> should be serving existing content, the system administrator may need to
> add a new request URL mapping to the intended application.
>  WARN 2014-01-22 17:56:29,893 (Thread-67588) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>  WARN 2014-01-22 17:56:47,939 (Thread-67735) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>  WARN 2014-01-22 17:57:06,002 (Thread-67881) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>  WARN 2014-01-22 17:58:16,297 (Thread-68450) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>  WARN 2014-01-22 17:58:34,343 (Thread-68583) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>  WARN 2014-01-22 17:58:52,421 (Thread-68731) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>  WARN 2014-01-22 18:01:28,557 (Thread-69988) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>  WARN 2014-01-22 18:01:46,635 (Thread-70136) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>  WARN 2014-01-22 18:01:46,682 (Worker thread '25') - Service interruption
> reported for job 1390290609168 connection 'MySharePointTCG': Remote
> procedure exception: The Web application at http://10.232.25.114/ could
> not be found. Verify that you have typed the URL correctly. If the URL
> should be serving existing content, the system administrator may need to
> add a new request URL mapping to the intended application.
>
> Thanks
> P.Yuvaraj Kumar
>   *From:* yuvaraj ponnuswamy <yuvaraj_p7@yahoo.co.in>
> *To:* Karl Wright <daddywri@gmail.com>; "user@manifoldcf.apache.org" <
> user@manifoldcf.apache.org>
> *Sent:* Tuesday, 21 January 2014, 19:51
> *Subject:* Re: ManifoldCF configuration with Sharepoint and Solr
>
>   Hi Karl,
>
> OK, I will add the rules that you have menitoned and re run the job.
> Thanks for your inputs.
>
>
> Regards
> P.Yuvaraj Kumar
>
>
>   *From:* Karl Wright <daddywri@gmail.com>
> *To:* "user@manifoldcf.apache.org" <user@manifoldcf.apache.org>; yuvaraj
> ponnuswamy <yuvaraj_p7@yahoo.co.in>
> *Sent:* Tuesday, 21 January 2014, 19:45
> *Subject:* Re: ManifoldCF configuration with Sharepoint and Solr
>
>   Hi Yuvaraj,
>
> You have a site rule, but you need library, list, and file rules in order
> to be able to match documents.  You may want to reread the end user
> documentation to understand how the rules work.
>
> Thanks,
> Karl
>
>
>
> On Tue, Jan 21, 2014 at 9:07 AM, yuvaraj ponnuswamy <
> yuvaraj_p7@yahoo.co.in> wrote:
>
>  Hi Karl,
>
> Thanks for your reply,
>
> I have attached the Job View and  Share Point View in the same document
>  at the end for your information.
>
> Please let me know if you need any other details.
>
>
> Thanks
> P.Yuvaraj Kumar
>
>   *From:* Karl Wright <daddywri@gmail.com>
> *To:* "user@manifoldcf.apache.org" <user@manifoldcf.apache.org>; yuvaraj
> ponnuswamy <yuvaraj_p7@yahoo.co.in>
> *Sent:* Tuesday, 21 January 2014, 19:06
> *Subject:* Re: ManifoldCF configuration with Sharepoint and Solr
>
>   Hi Yuvaraj,
>
> The kerberos warnings in the log are harmless.  I think it is likely that
> your SharePoint rules are simply not matching any sites/libraries/documents
> etc.  Can you view your job and include a screen shot of that?
>
> Karl
>
>
>
> On Tue, Jan 21, 2014 at 8:32 AM, yuvaraj ponnuswamy <
> yuvaraj_p7@yahoo.co.in> wrote:
>
>  Hi Karl,
>
> Iam using the Share Point as the repository connector and Solr as the
> output connector.
> when I configure the Job for the above connections and ran the Job
> *MySharePointTCG* it is running fine and displaying the Documents count
> as 1 and Processed count as 1.
> But when i checked the solr i am not able to see any documents gets
> indexed.
>
> Also when i checked the logs it is displaying the error message as below.
> I have attached the MCF configuration details.
>
> Please let me know how to get the document indexed in Solr.
>
> manifolfCF Logs:
> WARN 2014-01-21 17:19:54,172 (Thread-15101) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>  WARN 2014-01-21 17:20:12,221 (Thread-15127) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>  WARN 2014-01-21 17:20:30,316 (Thread-15144) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>  WARN 2014-01-21 17:22:04,340 (Thread-15366) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>  WARN 2014-01-21 17:22:22,388 (Thread-15603) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>  WARN 2014-01-21 17:22:40,453 (Thread-15802) - NEGOTIATE authentication
> error: No valid credentials provided (Mechanism level: No valid credentials
> provided (Mechanism level: Failed to find any Kerberos tgt))
>
> Please let me know your suggestions.
>
>
> Thanks
> P.Yuvaraj Kumar
>
>
>
>
>
>
>
>
>
>

Mime
View raw message