manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Libucha <mlibu...@gmail.com>
Subject Re: Crawling SharePoint Lists
Date Tue, 15 Oct 2013 22:23:47 GMT
Hi Karl,

Thanks for the quick attention. It's better, but not fixed?

I am now getting metadata for the one list row we were choking on before,
but it doesn't see the other two rows at all. I think the relevant part of
the log is this:

SharePoint: Document identifier is a list: '/DiscussStuff'

SharePoint: getListItems xml response: '<GetListItems xmlns="
http://schemas.microsoft.com/sharepoint/soap/directory/"><GetListItemsResponse
xmlns=""><GetListItemsResult
FileRef="Lists/DiscussStuff/Giants/3_.000"/></GetListItemsResponse></GetListItems>'

There should be a 1_.000 and a 2._000 as well.

Maybe the problem is in the webapp on the SharePoint server?

Thanks again for all the help.

Mark



On Tue, Oct 15, 2013 at 2:31 PM, Karl Wright <daddywri@gmail.com> wrote:

> Just resolved this ticket, on trunk.
>
> Please synch up and try again.
>
> Karl
>
>
>
> On Tue, Oct 15, 2013 at 4:59 PM, Karl Wright <daddywri@gmail.com> wrote:
>
>> CONNECTORS-786.
>>
>> I've prioritized this as very high because this is functionality that
>> used to work but is now broken because I added attachment support.  With
>> luck I will be able to look at it later tonight.
>>
>> Karl
>>
>>
>>
>> On Tue, Oct 15, 2013 at 4:36 PM, Karl Wright <daddywri@gmail.com> wrote:
>>
>>> This is the problem:
>>>
>>>
>>> SharePoint: Can't get version of '/DiscussStuff///Giants/3_.
>>> 000' because modified date or attachment url not found
>>>
>>> It looks like it decided that the list item was in fact an attachment,
>>> which makes sense because it was a compound list id.
>>>
>>> I'll open a ticket for this.
>>>
>>> Thanks!
>>> Karl
>>>
>>>
>>>
>>>
>>> On Tue, Oct 15, 2013 at 3:40 PM, Mark Libucha <mlibucha@gmail.com>wrote:
>>>
>>>>
>>>> On Tue, Oct 15, 2013 at 11:50 AM, Karl Wright <daddywri@gmail.com>wrote:
>>>>
>>>>> Do you see any of these in the log?
>>>>
>>>>
>>>>
>>>> There are 3 rows in my discussion group -- two topics, one post in
>>>> each, one with a reply. In the logs I'm only seeing one of them (the
>>>> chronologically last to be put into SharePoint).
>>>>
>>>> The log looks like this -- maybe that last message means it's choking
>>>> on this list and giving up on processing it further?
>>>>
>>>> Thanks...
>>>>
>>>>
>>>> SharePoint: Document identifier is a list: '/DiscussStuff'
>>>>
>>>> SharePoint: getListItems xml response: '<GetListItems xmlns="
>>>> http://schemas.microsoft.com/sharepoint/soap/directory/"><GetListItemsResponse
>>>> xmlns=""><GetListItemsResult
>>>> FileRef="Lists/DiscussStuff/Giants/3_.000"/></GetListItemsResponse></GetListItems>'
>>>>
>>>> SharePoint: Checking whether to include list item
>>>> '/DiscussStuff/Giants/3_.000'
>>>>
>>>> SharePoint: Getting version of '/DiscussStuff///Giants/3_.000'
>>>>
>>>> SharePoint: Checking whether to include list item attachment
>>>> '/DiscussStuff/Giants/3_.000'
>>>>
>>>> SharePoint: Can't get version of '/DiscussStuff///Giants/3_.000'
>>>> because modified date or attachment url not found
>>>>
>>>>
>>>
>>
>

Mime
View raw message