manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From altaf a <altaf...@gmail.com>
Subject Re: Sharepoint 2010 connector getting started--facing problem in displaying fields.
Date Fri, 05 Apr 2013 13:38:30 GMT
HI Karl,

Not sure why its not displaying but please find the same attached image .

Regards,
Altaf

On Fri, Apr 5, 2013 at 7:02 PM, Karl Wright <daddywri@gmail.com> wrote:

>  Hi Altaf,
>
> The images are not displaying, I'm afraid. At least google mail isn't
> doing the trick.
>
> Karl
>
>
>
> On Fri, Apr 5, 2013 at 9:27 AM, altaf a <altaff4u@gmail.com> wrote:
>
>>  Hi Karl,
>>
>> Below is the screen shot of Job and the sharepoint data is in pages
>> library where Xyz,test are the internal names of the fields in sharepoint
>> pages.
>>
>> *Solr standard output during indexing and see what arguments it is
>> receiving, and whether they match your expectations.*
>>
>> The above underlined means i need to check in the manifoldcf logs?? I
>> checked there but nothing helped as such. I am pretty new to solr so not
>> sure where to check the standard output of solr
>>
>> Can you please let me know if i am missing anything in the below
>> cofiguration.
>>
>> [image: Inline image 1]
>>
>>
>>
>> On Thu, Apr 4, 2013 at 7:15 PM, Karl Wright <daddywri@gmail.com> wrote:
>>
>>>  Hi Altaf,
>>>
>>> The only List attributes that MCF will consider indexing are the ones
>>> that you specify on the job's "Metadata" tab.  The tab allows you to build
>>> rules about what metadata to include in what context.  See the
>>> "end-user-documentation" page for more details on how to do this and how it
>>> works.
>>>
>>> If you have done this, and you are still having trouble, it is often
>>> helpful to look at the Solr standard output during indexing and see what
>>> arguments it is receiving, and whether they match your expectations.  And
>>> if you are STILL stuck after that, you should post back to this list, but
>>> this time include:
>>>
>>> - a screenshot (or two if necessary) of the "view" page for your job, so
>>> we can see how it is set up, and
>>> - a screenshot, or cut-and-paste, of an example List record being
>>> indexed from the Solr standard output
>>>
>>> Thanks!
>>> Karl
>>>
>>>
>>>
>>> On Thu, Apr 4, 2013 at 9:13 AM, altaf a <altaff4u@gmail.com> wrote:
>>>
>>>> Hi,
>>>>
>>>> I am very new to SOLR as well as the manifold connector for sharepoint
>>>> 2010,
>>>> I have followed the *
>>>> http://manifoldcf.apache.org/release/release-1.1.1/en_US/how-to-build-and-deploy.html
>>>> * to configure the connection.
>>>>
>>>> I have configured and declared two fields of sharepoint where xyz and
>>>> test2 are internal names of columns in SharePoint page library and mapped
>>>> same thing in List all jobs-->solr field mapping with xyz-->xyz and
>>>> test2-->test2 where xyz and test2 are column names in pages library.
>>>>
>>>> Schema.xml:
>>>>  <field name="xyz" type="string" indexed="true" stored="true" />
>>>>    <field name="test2" type="string" indexed="true" stored="true" />
>>>>
>>>>  <field name="allow_token_document" type="string" indexed="true"
>>>> stored="false" multiValued="true" required="false"
>>>> default="__nosecurity__"/>
>>>>    <field name="allow_token_share" type="string" indexed="true"
>>>> stored="false" multiValued="true" required="false"
>>>> default="__nosecurity__"/>
>>>>    <field name="deny_token_document" type="string" indexed="true"
>>>> stored="false" multiValued="true" required="false"
>>>> default="__nosecurity__"/>
>>>>    <field name="deny_token_share" type="string" indexed="true"
>>>> stored="false" multiValued="true" required="false"
>>>> default="__nosecurity__"/>
>>>>
>>>> I have not removed any other default configurations of this file.
>>>>
>>>>
>>>> In solrconfig
>>>>
>>>> i have added this in in select request handler
>>>>
>>>>  <lst name="appends">
>>>>       <str name="fq">{!manifoldCFSecurity}</str>
>>>>     </lst>
>>>>
>>>> Now the problem is after successfull crawling , when i am sending a
>>>> request to solr as http://localhost:8983/solr/select?q=*:* but the two
>>>> fields are not appearing in any of the results where as some fields like
>>>> title and content are displaying the values.
>>>>
>>>> Can you please let me know whether i am missing any configuration?? As
>>>> i am new i not well aware of specific logging to check .I tried to go
>>>> thought the mail archive but didnt find any similar issue . Can anyone
>>>> please guide me..
>>>>
>>>> Regards,
>>>> Altaf
>>>>
>>>
>>>
>>
>

Mime
View raw message