manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: Sharepoint
Date Thu, 21 Feb 2013 23:13:12 GMT
Ok, just confirmed here that SharePoint 2010 selected with the
following parameters gives you something back in less than 1 min:

Parameters: 	serverLocation=
serverPort=
serverVersion=4.0
userName=domain\foo
serverProtocol=http
serverName=localhost
password=********
Connection status:	The site at http://localhost did not exist

Obviously I didn't try connecting to an Amazon instance with a missing
MCPermissions.asmx, but that shouldn't be much different.

If the empty response persists, we can assume it's throwing some weird
Error and try to catch it in the JSP.  If you are interested in doing
that let me know and I'll give you precise instructions.

Thanks
Karl


On Thu, Feb 21, 2013 at 6:02 PM, Mark Lugert <mlugert@yahoo.com> wrote:
> I see no exceptions.  Going to install the service tonight or tomorrow and retest.
>
> Never does return which is weird.  I'll keep digging.
>
> Sent from my iPhone
>
> On Feb 21, 2013, at 6:00 PM, Karl Wright <daddywri@gmail.com> wrote:
>
>> For SharePoint 2010 and up, MCPermissions.asmx is required, because
>> many of the services that worked previously in SharePoint 2003 and
>> 2008 no longer work properly on SharePoint 2010.  As far as I know,
>> Amazon does not provide anything other than SharePoint 2010 instances,
>> so that is probably going to be an issue for you.
>>
>> But you *should* get back a connection failure message on the view
>> page.  The reason not may be timeout (may take a minute or two), or it
>> could be something more serious.  Do you see any exceptions printed in
>> either the logs or out to standard out?
>>
>> Karl
>>
>> On Thu, Feb 21, 2013 at 5:03 PM, Mark Lugert <mlugert@yahoo.com> wrote:
>>> Another note.  I did not install MCPermissions.asmx as I do not need
>>> permission information from Sharepoint at this time.  All the docs are
>>> basically public.  It's more about what docs are ready for publish.
>>>
>>> Would this cause the problem I'm seeing below?  The docs make it sound like
>>> MCPermissions.asmx is only if you want authority info from the docs.
>>>
>>> thanks,
>>> mark
>>>
>>>
>>> From: Mark Lugert <mlugert@yahoo.com>
>>> To: "user@manifoldcf.apache.org" <user@manifoldcf.apache.org>
>>> Sent: Thursday, February 21, 2013 5:00 PM
>>> Subject: Sharepoint
>>>
>>> I'm trying to connect to my sharepoint server, which is on amazon.
>>>
>>> There are no sites, just a document library.  I can connect via a browser
>>> just fine, but when I set up the manifold repos connector and click save I
>>> just get a blank screen.  Nothing in the logs and the screen stays blank.
>>>
>>> It's sharepoint 2010
>>> http
>>> my amazon ec2-50-16......amzaonaws.com
>>> server port: 80
>>> Site Path: <blank> since I don't have any sites
>>> user name: <host_name>\Administrator  - this is what it shows me logged
in
>>> as via the browser
>>> Password.
>>> No cert.
>>>
>>> Any idea why there is nothing in the log and why the screen goes blank?  I
>>> turned on wire level debugging and got nothing.
>>>
>>> thanks,
>>> mark
>>>
>>>

Mime
View raw message