manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Lugert <>
Subject Re: Sharepoint
Date Fri, 22 Feb 2013 00:44:23 GMT
Debuggin this, it's hung up on this call:
connectionStatus = c.check();
This essentially does a:
getSession();URL urlServer = proxy.checkConnection( 
There is pretty much no logging in this entire connector.  I'll go in and add some to see
which method, and where, it's having issues.
Looking at the code I'd guess the proxy.checkConnection.  However, if I use the URL it "should"
be using via a browser it works fine.
Wondering if Amazon is doing something that is causing issues?  Has anyone tried using a
Sharepoint in Amazon before?
mark"/", supportsItemSecurity );newURL( serverUrl );

From: Karl Wright <>
To: Mark Lugert <> 
Cc: "" <> 
Sent: Thursday, February 21, 2013 6:13 PM
Subject: Re: Sharepoint

Ok, just confirmed here that SharePoint 2010 selected with the
following parameters gives you something back in less than 1 min:

Parameters:     serverLocation=
Connection status:    The site at http://localhost did not exist

Obviously I didn't try connecting to an Amazon instance with a missing
MCPermissions.asmx, but that shouldn't be much different.

If the empty response persists, we can assume it's throwing some weird
Error and try to catch it in the JSP.  If you are interested in doing
that let me know and I'll give you precise instructions.


On Thu, Feb 21, 2013 at 6:02 PM, Mark Lugert <> wrote:
> I see no exceptions.  Going to install the service tonight or tomorrow and retest.
> Never does return which is weird.  I'll keep digging.
> Sent from my iPhone
> On Feb 21, 2013, at 6:00 PM, Karl Wright <> wrote:
>> For SharePoint 2010 and up, MCPermissions.asmx is required, because
>> many of the services that worked previously in SharePoint 2003 and
>> 2008 no longer work properly on SharePoint 2010.  As far as I know,
>> Amazon does not provide anything other than SharePoint 2010 instances,
>> so that is probably going to be an issue for you.
>> But you *should* get back a connection failure message on the view
>> page.  The reason not may be timeout (may take a minute or two), or it
>> could be something more serious.  Do you see any exceptions printed in
>> either the logs or out to standard out?
>> Karl
>> On Thu, Feb 21, 2013 at 5:03 PM, Mark Lugert <> wrote:
>>> Another note.  I did not install MCPermissions.asmx as I do not need
>>> permission information from Sharepoint at this time.  All the docs are
>>> basically public.  It's more about what docs are ready for publish.
>>> Would this cause the problem I'm seeing below?  The docs make it sound like
>>> MCPermissions.asmx is only if you want authority info from the docs.
>>> thanks,
>>> mark
>>> From: Mark Lugert <>
>>> To: "" <>
>>> Sent: Thursday, February 21, 2013 5:00 PM
>>> Subject: Sharepoint
>>> I'm trying to connect to my sharepoint server, which is on amazon.
>>> There are no sites, just a document library.  I can connect via a browser
>>> just fine, but when I set up the manifold repos connector and click save I
>>> just get a blank screen.  Nothing in the logs and the screen stays blank.
>>> It's sharepoint 2010
>>> http
>>> my amazon
>>> server port: 80
>>> Site Path: <blank> since I don't have any sites
>>> user name: <host_name>\Administrator  - this is what it shows me logged
>>> as via the browser
>>> Password.
>>> No cert.
>>> Any idea why there is nothing in the log and why the screen goes blank?  I
>>> turned on wire level debugging and got nothing.
>>> thanks,
>>> mark
View raw message