manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: Problems with Sharepoint Connector and spanish locale
Date Wed, 03 Oct 2012 12:18:35 GMT
Maybe Ahmet has some advice?  I agree that SharePoint is difficult,
but if there is going to be any help it will be in the server-side
event logs.  Ahmet may be able to help interpret them?

Karl

On Wed, Oct 3, 2012 at 8:09 AM, Shinichiro Abe
<shinichiro.abe.1@gmail.com> wrote:
> Thank you for the reply.
> It seems difficult to figure out the cause,
> so anyway I'll check the server-side event logs.
>
> Thank you,
> Shinichiro Abe
>
>
> On 2012/10/03, at 19:37, Karl Wright wrote:
>
>> Hi Abe-san,
>>
>> The message "Remote procedure exception: Cannot open the requested
>> Sharepoint Site." seems to be a generic message that is returned by
>> the web service when something goes wrong.  Unfortunately there are
>> many possible causes.  The only way to really tell which cause it is
>> is by looking at the server-side event logs.
>>
>> I once had a client who had a system that returned this error whenever
>> we accessed the Lists web service.  Event logs weren't helpful either.
>> The only thing that we knew was that the permissions had been altered
>> for the system from their original values.  Restoring the permissions
>> to the original values was impossible, so the client wound up
>> reinstalling SharePoint.  That fixed the problem.
>>
>> SharePoint is sometimes a very difficult system to work with.
>>
>> Karl
>>
>> On Wed, Oct 3, 2012 at 6:07 AM, Shinichiro Abe
>> <shinichiro.abe.1@gmail.com> wrote:
>>> Hi,
>>>
>>> Does this solve the issue?
>>> I've faced the same problem.
>>>
>>> message is:
>>> "Remote procedure exception: Cannot open the requested
>>> Sharepoint Site."
>>>
>>> The log showed that it cannot open the sharepoint site.
>>> (But the crawl user can access the site by browser.
>>> I'm looking into the server-side event logs.)
>>>
>>> In fact the crawl user has a full-control permission on the site.
>>>
>>> Is this message because the crawl user needs the ability to obtain
>>> access permissions? Are there any other causes?
>>> Is there a possibility that a full-control user can't open the site
>>> and a site owner user can open the site?
>>>
>>> Regards,
>>> Shinichiro Abe
>>>
>>> On 2012/04/23, at 22:59, Karl Wright wrote:
>>>
>>>> Hi Jose,
>>>>
>>>> The fact that it says "Connection working" is a good sign; it means that
you are able to talk to the SharePoint server properly.
>>>>
>>>> The key message is: "Remote procedure exception: Cannot open the requested
Sharepoint Site. "  That's a server-side exception.  What it basically means is that your
SharePoint instance is not permitting an operation that the SharePoint connector requires,
usually because the permissions of the crawl user are insufficient in some way.  Typically
this is because the crawl user needs the ability to obtain access permissions (sids) for the
documents it crawls.
>>>>
>>>> If you are in a position to have your SharePoint admin look into this, the
server-side event logs are often helpful in figuring out what permissions are missing.
>>>>
>>>> Thanks,
>>>> Karl
>>>>
>>>> On Mon, Apr 23, 2012 at 9:32 AM, Jose Luis Calleja Laborda <jcalleja@bankinter.es>
wrote:
>>>>
>>>> You were right, I have changed the localization in my Browser to en_US, and
that message is not shown anymore.
>>>>
>>>> I get the  "Connection Working" message when I setup the repository connection
to Sharepoint. Besides this,  I can select the site and the library in the "Path" tab  when
I create the job.
>>>>
>>>> Digging in the log, when I start the job, the following message is shown
in the log:
>>>> WARN 2012-04-23 16:27:13,397 (Worker thread '15') - Service interruption
reported for job 1334926342487 connection 'Sharepoint': Remote procedure exception: Cannot
open the requested Sharepoint Site.
>>>>
>>>> The job remains "Running"  and never ends, until the "abort" link is pushed.
>>>>
>>>> Thanks.
>>>> Jose.
>>>>
>>>>
>>>> Karl Wright <daddywri@gmail.com>
>>>>
>>>> 20/04/2012 17:23
>>>> Por favor, responda a
>>>> connectors-user@incubator.apache.org
>>>>
>>>> Para
>>>> connectors-user@incubator.apache.org
>>>> cc
>>>> Asunto
>>>> Re: Problems with Sharepoint Connector and spanish locale
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> The exception you posted comes from the UI and is expected to be
>>>> logged since there is no Spanish localization of MCF.  It does not in
>>>> any way interfere with the crawl.
>>>>
>>>> Are there any other log messages?  Do you get "Connection working"
>>>> displayed in the UI when you view the SharePoint connection you have
>>>> set up?
>>>>
>>>> Karl
>>>>
>>>> On Fri, Apr 20, 2012 at 9:46 AM, Jose Luis Calleja Laborda
>>>> <jcalleja@bankinter.es> wrote:
>>>>>
>>>>> Hi,
>>>>> I am new in this, and I'm evaluating ManifoldCf for crawl and index our
>>>>> intranet. Everything is working fine except when I try to index a sharepoint
>>>>> site through the Sharepoint connector. MS Sharepoint is installed in
>>>>> spanish, and when the job start to crawl  the following exception is
shown
>>>>> in the log, and nothing is sent to SOLR:
>>>>>
>>>>> ERROR 2012-04-20 13:54:32,095 (1026952339@qtp-110510384-0) - Missing
>>>>> resource bundle 'org.apache.manifoldcf.crawler.connectors.sharepoint.common'
>>>>> for locale 'es_ES': Can't find bundle for base name
>>>>> org.apache.manifoldcf.crawler.connectors.sharepoint.common, locale es_ES;
>>>>> trying es
>>>>> java.util.MissingResourceException: Can't find bundle for base name
>>>>> org.apache.manifoldcf.crawler.connectors.sharepoint.common, locale es_ES
>>>>>        at
>>>>> java.util.ResourceBundle.throwMissingResourceException(ResourceBundle.java:1539)
>>>>>        at java.util.ResourceBundle.getBundleImpl(ResourceBundle.java:1278)
>>>>>        at java.util.ResourceBundle.getBundle(ResourceBundle.java:980)
>>>>>        at
>>>>> org.apache.manifoldcf.core.i18n.Messages.getResourceBundle(Messages.java:127)
>>>>>        at
>>>>> org.apache.manifoldcf.core.i18n.Messages.getMessage(Messages.java:173)
>>>>>        at
>>>>> org.apache.manifoldcf.core.i18n.Messages.getString(Messages.java:195)
>>>>>        at
>>>>> org.apache.manifoldcf.crawler.connectors.sharepoint.Messages.getString(Messages.java:91)
>>>>>        at
>>>>> org.apache.manifoldcf.crawler.connectors.sharepoint.Messages.getString(Messages.java:39)
>>>>>        at
>>>>> org.apache.manifoldcf.crawler.connectors.sharepoint.SharePointRepository.outputConfigurationHeader(SharePointRepository.java:1371)
>>>>>        at
>>>>> org.apache.manifoldcf.crawler.interfaces.RepositoryConnectorFactory.outputConfigurationHeader(RepositoryConnectorFactory.java:117)
>>>>>        at
>>>>> org.apache.jsp.editconnection_jsp._jspService(editconnection_jsp.java:484)
>>>>>        at
>>>>> org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
>>>>>        at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
>>>>>        at
>>>>> org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:388)
>>>>>
>>>>> Any kind of help with this issue is welcomed.
>>>>>
>>>>> Many thanks in advance.
>>>>> Jose Luis
>>>>
>>>>
>>>
>

Mime
View raw message