manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: Trouble getting plugin installed on sharepoint 2010
Date Fri, 12 Oct 2012 21:18:23 GMT
The IIS setup on the ec2 instance has to be correct.  I've not tried
SharePoint on ec2, so I don't know what the setup looks like, but it
needs to be as follows:

- SharePoint pages protected with NTLM security, or nothing (not basic
auth or Kerberos)
- You have to enable the ability to execute asmx plugins (there's a
setting for execution if I recall correctly)

You can learn a little more about the above perhaps by browsing to the
site using IE from a different unrelated domain, and noting the login
you have to go through.  Or, you can do packet captures with a tool
like Wireshark to figure out what authentication IE is using.  If you
install SharePoint from the SharePoint disk, it would all be properly
set up automatically, but who knows how Amazon has it by default, so
it is worth a check.

The 401 error, however, could also be due to a more likely problem,
which is that the machine name Amazon gives you may not be enough; you
may need to use a fully qualified name.  Or, even worse, there may
actually be an active directory domain that the machine is joined to,
in which case you'd want to use that.  You should also try a
fully-qualified version of the domain, if there is one.

If this seems challenging to you, welcome to the world of Windows
authentication.  But I should reassure you that so far everyone has
figured it out eventually.

Karl

On Fri, Oct 12, 2012 at 5:05 PM, Mathias Kolehmainen
<mathias@voyagergis.com> wrote:
> Still not sure why the install failed on the site.
>
> However I have installed a fresh sharepoint in ec2, but am having
> authentication problems.
>
> I can connect just fine over HTTP (and I am prompted for a username &
> password using what appears to be standard HTTP authentcation), but I cannot
> get the manifold repository to connect.
>
> I have no domain, so I've tried different username settings in manifold:
>     .\Administrator
>     MACHINE_NAME\Administrator
>
> Neither work.
>
> This is the error I get:
>
> Got an unknown remote exception accessing site - axis fault = Client, detail
> = The request failed with HTTP status 401: Unauthorized.
>
>
> This is likely a sharepoint configuration issue.  Is there something more
> that needs to be enabled on sharepoint side?
>
>

Mime
View raw message