manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject RE: Problem with reading files from Sharepoint 2010 to manifldcf
Date Tue, 30 Oct 2012 12:55:40 GMT
 1.0.1
MIME-Version: 1.0
Content-Type: multipart/mixed;
	boundary="_004_1E611569B274304DB0C7D90B3735637C01CADE0FG1W3645americas_"

--_004_1E611569B274304DB0C7D90B3735637C01CADE0FG1W3645americas_
Content-Type: multipart/alternative;
	boundary="_000_1E611569B274304DB0C7D90B3735637C01CADE0FG1W3645americas_"

--_000_1E611569B274304DB0C7D90B3735637C01CADE0FG1W3645americas_
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: 7bit

Hi Oren,

It looks like manifold is able to reach the mcpermissions service, but
the mcpermissions service is having trouble reaching the SharePoint
permissions service, which it needs. Can you access that service, or
has it been disabled?

Thanks,
Karl

Sent from my Windows Phone
From: Fridler, Oren
Sent: 10/30/2012 8:41 AM
To: user@manifoldcf.apache.org
Subject: Problem with reading files from Sharepoint 2010 to manifldcf
1.0.1
Hi
I'm using apache-manifoldcf-1.0.1-bin
I installed apache-manifoldcf-sharepoint-2010-plugin-0.1  on top of
Sharepoint 2010

On mcf I managed to create a Sharepoint repository connection and saw
the status is "Connection Working"
Also when I create the "Sharepoint to Solr" Job I can see some of the
wiki libraries that I created on SP are available for selection so I
assume MCF is getting this data from SP.
But when I start the job it is getting stuck in status "running"
forever, the mcf UI shows documents are discovered, some are processed
and some are active, but on Solr side no document is received.
On mcf logs I see the error at the end of this email.
On my browser I can open http://16.59.60.113 - getting to SP site, and
also http://16.59.60.113/_vti_bin/MCPermissions.asmx  - getting to a
page that lists these 2 services - GetListItems and
GetPermissionCollection
Attached are the mcf logs with DEBUG level.
Any help or idea what can I do would be highly appreciated.
Thanks
Oren.


AxisFault
faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Client
faultSubcode:
 faultString: The Web application at http://16.59.60.113 could not be
found. Verify that you have typed the URL correctly. If the URL should
be serving existing content, the system administrator may need to add
a new request URL mapping to the intended application.
faultActor: http://16.59.60.113/_vti_bin/MCPermissions.asmx
faultNode:
 faultDetail:
               {}Error:<ErrorNumber>1010</ErrorNumber><ErrorMessage>The
Web application at http://16.59.60.113 could not be found. Verify that
you have typed the URL correctly. If the URL should be serving
existing content, the system administrator may need to add a new
request URL mapping to the intended
application.</ErrorMessage><ErrorSource>Microsoft.SharePoint</ErrorSource>






--_000_1E611569B274304DB0C7D90B3735637C01CADE0FG1W3645americas_
Content-Type: text/html; charset="utf-8"
Content-Transfer-Encoding: quoted-printable

<html><head><meta content=3D"text/html; charset=3Dutf-8" http-equiv=3D"Cont=
ent-Type"></head><body><div><div style=3D"font-family: Calibri,sans-serif;
=
font-size: 11pt;">Hi Oren,<br><br>It looks like manifold is able to reach t=
he mcpermissions service, but the mcpermissions service is having trouble r=
eaching the SharePoint permissions service, which it needs.&nbsp; Can you a=
ccess that service, or has it been disabled?<br><br>Thanks,<br>Karl<br><br>=
Sent from my Windows Phone<br></div></div><hr><span style=3D"font-family:
T=
ahoma,sans-serif; font-size: 10pt; font-weight: bold;">From: </span><span s=
tyle=3D"font-family: Tahoma,sans-serif; font-size: 10pt;">Fridler, Oren</sp=
an><br><span style=3D"font-family: Tahoma,sans-serif; font-size: 10pt; font=
-weight: bold;">Sent: </span><span style=3D"font-family: Tahoma,sans-serif;=
 font-size: 10pt;">10/30/2012 8:41 AM</span><br><span style=3D"font-family:=
 Tahoma,sans-serif; font-size: 10pt; font-weight: bold;">To: </span><span s=
tyle=3D"font-family: Tahoma,sans-serif; font-size: 10pt;">user@manifoldcf.a=
pache.org</span><br><span style=3D"font-family: Tahoma,sans-serif; font-siz=
e: 10pt; font-weight: bold;">Subject: </span><span style=3D"font-family: Ta=
homa,sans-serif; font-size: 10pt;">Problem with reading files from Sharepoi=
nt 2010 to manifldcf 1.0.1</span><br><br></body></html><html
xmlns:v=3D"urn=
:schemas-microsoft-com:vml" xmlns:o=3D"urn:schemas-microsoft-com:office:off=
ice" xmlns:w=3D"urn:schemas-microsoft-com:office:word" xmlns:m=3D"http://sc=
hemas.microsoft.com/office/2004/12/omml" xmlns=3D"http://www.w3.org/TR/REC-=
html40">
<head>
<meta http-equiv=3D"Content-Type" content=3D"text/html; charset=3Dus-ascii"=
>
<meta name=3D"Generator" content=3D"Microsoft Word 14 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
=09{font-family:Calibri;
=09panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
=09{margin:0cm;
=09margin-bottom:.0001pt;
=09font-size:11.0pt;
=09font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
=09{mso-style-priority:99;
=09color:blue;
=09text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
=09{mso-style-priority:99;
=09color:purple;
=09text-decoration:underline;}
span.EmailStyle17
=09{mso-style-type:personal-compose;
=09font-family:"Calibri","sans-serif";
=09color:windowtext;}
.MsoChpDefault
=09{mso-style-type:export-only;
=09font-family:"Calibri","sans-serif";}
@page WordSection1
=09{size:612.0pt 792.0pt;
=09margin:72.0pt 72.0pt 72.0pt 72.0pt;}
div.WordSection1
=09{page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext=3D"edit" spidmax=3D"1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext=3D"edit">
<o:idmap v:ext=3D"edit" data=3D"1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang=3D"EN-US" link=3D"blue" vlink=3D"purple">
<div class=3D"WordSection1">
<p class=3D"MsoNormal">Hi<o:p></o:p></p>
<p class=3D"MsoNormal">I&#8217;m using apache-manifoldcf-1.0.1-bin <o:p></o=
:p></p>
<p class=3D"MsoNormal">I installed apache-manifoldcf-sharepoint-2010-plugin=
-0.1&nbsp; on top of Sharepoint 2010<o:p></o:p></p>
<p class=3D"MsoNormal"><o:p>&nbsp;</o:p></p>
<p class=3D"MsoNormal">On mcf I managed to create a Sharepoint repository c=
onnection and saw the status is &#8220;Connection Working&#8221;<o:p></o:p>=
</p>
<p class=3D"MsoNormal">Also when I create the &#8220;Sharepoint to Solr&#82=
21; Job I can see some of the wiki libraries that I created on SP are avail=
able for selection so I assume MCF is getting this data from SP.<o:p></o:p>=
</p>
<p class=3D"MsoNormal">But when I start the job it is getting stuck in stat=
us &#8220;running&#8221; forever, the mcf UI shows documents are discovered=
, some are processed and some are active, but on Solr side no document is r=
eceived.<o:p></o:p></p>
<p class=3D"MsoNormal">On mcf logs I see the error at the end of this email=
.<o:p></o:p></p>
<p class=3D"MsoNormal">On my browser I can open <a href=3D"http://16.59.60.=
113">http://16.59.60.113</a> - getting to SP site, and also
<a href=3D"http://16.59.60.113/_vti_bin/MCPermissions.asmx">http://16.59.60=
.113/_vti_bin/MCPermissions.asmx</a>&nbsp; - getting to a page that lists t=
hese 2 services - GetListItems and GetPermissionCollection<o:p></o:p></p>
<p class=3D"MsoNormal">Attached are the mcf logs with DEBUG level.<o:p></o:=
p></p>
<p class=3D"MsoNormal">Any help or idea what can I do would be highly appre=
ciated.<o:p></o:p></p>
<p class=3D"MsoNormal">Thanks<o:p></o:p></p>
<p class=3D"MsoNormal">Oren.<o:p></o:p></p>
<p class=3D"MsoNormal"><o:p>&nbsp;</o:p></p>
<p class=3D"MsoNormal"><o:p>&nbsp;</o:p></p>
<p class=3D"MsoNormal">AxisFault<o:p></o:p></p>
<p class=3D"MsoNormal">faultCode: {http://schemas.xmlsoap.org/soap/envelope=
/}Client<o:p></o:p></p>
<p class=3D"MsoNormal">faultSubcode: <o:p></o:p></p>
<p class=3D"MsoNormal">&nbsp;faultString: The Web application at http://16.=
59.60.113 could not be found. Verify that you have typed the URL correctly.=
 If the URL should be serving existing content, the system administrator ma=
y need to add a new request URL mapping
 to the intended application.<o:p></o:p></p>
<p class=3D"MsoNormal">faultActor: http://16.59.60.113/_vti_bin/MCPermissio=
ns.asmx<o:p></o:p></p>
<p class=3D"MsoNormal">faultNode: <o:p></o:p></p>
<p class=3D"MsoNormal">&nbsp;faultDetail: <o:p></o:p></p>
<p class=3D"MsoNormal">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbs=
p;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; {}Error:&lt;ErrorNumber&gt;1010&lt;/ErrorN=
umber&gt;&lt;ErrorMessage&gt;The Web application at http://16.59.60.113 cou=
ld not be found. Verify that you have typed the URL correctly. If the URL s=
hould be serving existing content, the system administrator
 may need to add a new request URL mapping to the intended application.&lt;=
/ErrorMessage&gt;&lt;ErrorSource&gt;Microsoft.SharePoint&lt;/ErrorSource&gt=
;<o:p></o:p></p>
<p class=3D"MsoNormal"><o:p>&nbsp;</o:p></p>
<p class=3D"MsoNormal"><o:p>&nbsp;</o:p></p>
<p class=3D"MsoNormal"><o:p>&nbsp;</o:p></p>
<p class=3D"MsoNormal"><o:p>&nbsp;</o:p></p>
<p class=3D"MsoNormal"><o:p>&nbsp;</o:p></p>
</div>
</body>
</html>

--_000_1E611569B274304DB0C7D90B3735637C01CADE0FG1W3645americas_--

--_004_1E611569B274304DB0C7D90B3735637C01CADE0FG1W3645americas_--

Mime
View raw message