manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Wilken <wilk...@gmail.com>
Subject Re: Sharepoint connector - authentication failure
Date Wed, 22 Aug 2012 17:50:21 GMT
I'm running trunk of ManifoldCF (r1376152, just updated and built this
morning), using java -jar start.jar in dist/example/.

I had been using "SharePoint 4.0 (2010)" in the drop down, I didn't
realize this required the SP plugin to be installed.  I added some
debugging statements to SPSProxyHelper.java, and it appears to be
failing before trying to access the MCPermissions service.  The
authentication exception gets thrown at line 1487, before anything
related to the plugin is called (if I'm understanding it correctly).

I just tried using SharePoint 2.0 from the drop down, and got the same
401 error.  I'll continue down the debugging paths you've suggested,
thanks!

-mike

On Wed, Aug 22, 2012 at 10:34 AM, Karl Wright <daddywri@gmail.com> wrote:
> Hi Mike,
>
> Which version of ManifoldCF are you using?  Did you select "SharePoint
> 2.0" from the pulldown?  You will need to do this if you do not have
> the SharePoint plugin installed.
>
> For the record, in order to be able to crawl SharePoint 2010, you MUST
> be using trunk (not ManifoldCF 0.6), and you MUST select "SharePoint
> 4.0 (2010)" from the pulldown.  That will also mean you need to build
> and deploy the SharePoint 2010 plug-in on the SharePoint server for
> anything to work at all with SharePoint 2010.  FWIW, all of this will
> be released in about a month when MCF 0.7 goes out the door.
>
> In the interim, you can check to see whether you have true connection
> problems by doing the following:
>
> - Select SharePoint 2.0 from the pulldown
> - Save the connection
> - If you still get the error, then we escalate to the next level of
> debugging, which will include some or all of the following:
>
> (1) See if you can get to the web services from IE.  For example, if
> the site's url is http://xxx.yyy.com, then try to get to
> http://xxx.yyy.com/_vti_bin/Lists.asmx.  If that fails, look into your
> IIS configuration.
> (2) Turn on "wire debugging", as described in the FAQ, and view your
> connection again; it may give additional error details that could be
> helpful.
>
> Karl
>
> On Wed, Aug 22, 2012 at 1:22 PM, Michael Wilken <wilkenm@gmail.com> wrote:
>> I'm running into authentication errors when trying to use ManifoldCF
>> trunk against a Sharepoint2010 site.
>>
>> After creating a repository connection, I get the following message in
>> 'Connection Status':
>>     Crawl user did not authenticate properly, or has insufficient
>> permissions to access http://tunedin.disney.com: (401)Unauthorized
>>
>> The SP site is using NTLM for authentication.  I've verified that the
>> login info is correct: I can access the SP site via a web browser
>> using the credentials, and can make SOAP calls with the credentials
>> using soapUI.
>>
>> I have not installed the MCPermission service, as we don't have to
>> worry about permissions at this time.  Looking at the code, I'd expect
>> to get a different error message if this was causing the problem.
>>
>> Any suggestions for further debugging to see what's going wrong?
>>
>> Thanks,
>> -mike

Mime
View raw message