manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Swapna Vuppala <swapna.kollip...@gmail.com>
Subject Re: Problem crawling windows share
Date Tue, 15 Nov 2011 05:10:53 GMT
Hi Karl,

Thanks for the input. It looks like my problem is related to the second one
that you specified. One of the directories in the path am trying to index
is actually redirecting to a different server. And when I specify this new
server in defining the repository connection, with my credentials, the
connection fails with the message:  "Couldn't connect to server: Logon
failure: unknown user name or bad password"

I'll look into why am not able to connect to this server.

Thanks and Regards,
Swapna.

On Mon, Nov 14, 2011 at 4:56 PM, Karl Wright <daddywri@gmail.com> wrote:

> There's two kinds of problem you might be having.  The first is
> intermittent, and the second is not intermittent but would have
> something to do with specific directories.
>
> Intermittent problems might include a domain controller that is not
> always accessible.  In such cases, the crawl will proceed but will
> tend to fail unpredictably.  On the other hand, if you have a
> directory that is handled by a DFS redirection, it is possible that
> the redirection is indicating a new server (lets call it server3)
> which may not like the precise form of your login credentials.  Can
> you determine which scenario you are seeing?
>
> Karl
>
> On Mon, Nov 14, 2011 at 3:11 AM, Swapna Vuppala
> <swapna.kollipara@gmail.com> wrote:
> > Hi,
> >
> > I have been using windows share repository connection to crawl and get
> data
> > from a particular server (server 1). Its working perfectly fine.
> However, am
> > having trouble when I try with data from another server (server 2).
> >
> > When I define a repository connection of type windows share and specify
> the
> > server name (server 2) with my credentials, the connection status shows
> > "Connection working". But when I run a job to use this repository
> connection
> > and index data from a location on this server 2, I keep getting the
> > exception below:
> >
> > JCIFS: Possibly transient exception detected on attempt 3 while checking
> if
> > file exists: Logon failure: unknown user name or bad password.
> > jcifs.smb.SmbAuthException: Logon failure: unknown user name or bad
> > password.
> >     at jcifs.smb.SmbTransport.checkStatus(SmbTransport.java:544)
> >     at jcifs.smb.SmbTransport.send(SmbTransport.java:661)
> >     at jcifs.smb.SmbSession.sessionSetup(SmbSession.java:390)
> >     at jcifs.smb.SmbSession.send(SmbSession.java:218)
> >     at jcifs.smb.SmbTree.treeConnect(SmbTree.java:176)
> >     at jcifs.smb.SmbFile.doConnect(SmbFile.java:911)
> >     at jcifs.smb.SmbFile.connect(SmbFile.java:954)
> >     at jcifs.smb.SmbFile.connect0(SmbFile.java:880)
> >     at jcifs.smb.SmbFile.queryPath(SmbFile.java:1335)
> >     at jcifs.smb.SmbFile.exists(SmbFile.java:1417)
> >     at
> >
> org.apache.manifoldcf.crawler.connectors.sharedrive.SharedDriveConnector.fileExists(SharedDriveConnector.java:2064)
> >     at
> >
> org.apache.manifoldcf.crawler.connectors.sharedrive.SharedDriveConnector.getDocumentVersions(SharedDriveConnector.java:521)
> >     at
> >
> org.apache.manifoldcf.crawler.system.WorkerThread.run(WorkerThread.java:318)
> >
> > Am able to access this location from windows explorer. What else should
> I be
> > checking or what could be the reasons/factors causing this to fail ?
> >
> > Thanks and Regards,
> > Swapna.
> >
>

Mime
View raw message