manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: Strange class loading issue
Date Tue, 22 Mar 2011 19:33:33 GMT
Hi Fuad,

It's a little unclear what your steps were here.  The following:

<repositoryconnector name="RSS"
  class="org.apache.manifoldcf.crawler.connectors.rss2.RSSConnector2"/>

<repositoryconnector name="RSS2"
  class="org.apache.manifoldcf.crawler.connectors.rss2.RSSConnector2"/>

... should create two entries in the repositoryconnectors table, that
have the same class.  BUT, your repository connections save the class
name, not the repository connector name, so you've really created a
distinction without a difference.  This is not recommended; the class
names should be distinct for different names.

Karl

On Tue, Mar 22, 2011 at 2:11 PM, Fuad Efendi <fuad@efendi.ca> wrote:
> It’s strange; I created copy of RSS connector in a different package:
>
> package org.apache.manifoldcf.crawler.connectors.rss2
>
>
>
>   <repositoryconnector name="RSS"
> class="org.apache.manifoldcf.crawler.connectors.rss2.RSSConnector2"/>
>
>   <repositoryconnector name="RSS2"
> class="org.apache.manifoldcf.crawler.connectors.rss2.RSSConnector2"/>
>
>
>
> I added some log output (to check that I have new RSS2 working)
>
>
>
>
>
> However, old Manifold always loaded old
> org.apache.manifoldcf.crawler.connectors.rss.RSSConnector (from rss package
> instead of rss2)
>
>
>
>
>
> I was forsed to rename class too, into RSSConnector2, and it works now…
>
> org.apache.manifoldcf.crawler.connectors.rss2.RSSConnector2

Mime
View raw message