manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From c.a....@gmx.de
Subject "Connection already in use" when crawling Windows Share repositories
Date Fri, 18 Feb 2011 11:31:47 GMT
I'm running MCF rev. 1071535 with Apache Tomcat 7. Solr and MCF are using HTTPS. When crawling
data from a Windows Share Connection with Active Directory Authority after some time of crawling
my job aborts with the status "Error: Couldn't set up SSL connection to ingestion API: Address
already in use: connect".

In the mcf logfile I get:

[2011-02-18 11:24:33,695]ERROR Exception tossed: Couldn't set up SSL connection to ingestion
API: Address already in use: connect
org.apache.manifoldcf.core.interfaces.ManifoldCFException: Couldn't set up SSL connection
to ingestion API: Address already in use: connect
	at org.apache.manifoldcf.agents.output.solr.HttpPoster.createSocket(HttpPoster.java:736)
	at org.apache.manifoldcf.agents.output.solr.HttpPoster$IngestThread.run(HttpPoster.java:1006)
Caused by: java.net.BindException: Address already in use: connect
	at java.net.PlainSocketImpl.socketConnect(Native Method)
	at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
	at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
	at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
	at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
	at java.net.Socket.connect(Socket.java:529)
	at com.sun.net.ssl.internal.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:550)
	at com.sun.net.ssl.internal.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:353)
	at com.sun.net.ssl.internal.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:71)
	at org.apache.manifoldcf.agents.output.solr.HttpPoster.createSocket(HttpPoster.java:728)
	... 1 more

I use the same LDAP user
- to authenticate at MCF
- login credentials for the Solr Connection
- credentials for authority connection
- and for connecting to our LDAP server itself (in tomcat JNDI Realm config).

It seems to me that the connection to LDAP might be a problem. I tried to configure connection
pooling for tomcat. (I'm afraid I'm not so familiar with that.)
"-Dcom.sun.jndi.ldap.connect.pool=true -Dcom.jndi.ldap.connect.pool.protocol=ssl"

Did I miss sth in the config? Or how do I have to configure MCF?

Thanks in advance.

Carina
-- 
GMX DSL Doppel-Flat ab 19,99 Euro/mtl.! Jetzt mit 
gratis Handy-Flat! http://portal.gmx.net/de/go/dsl

Mime
View raw message