manifoldcf-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jack Krupansky" <jack.krupan...@lucidimagination.com>
Subject Re: Sharepoint Connector
Date Wed, 23 Jun 2010 03:14:46 GMT
In practice, (1) is probably good enough for most applications and the 
default value is probably sufficient as well. Longer term, dynamic discovery 
is a better solution.

I suppose that any Solr config params can change dynamically, but discovery 
once on the initial request may be sufficient. But, I suppose, it is also 
possible that the Solr server could shutdown, restart, and reload between 
two LCF output requests. Maybe a solution would be to have a config version 
number that Solr could return and accept on each request and which would 
cause a failure if the config version number has changed since that config 
version was returned. That could signal an app to re-query Solr to 
re-discover config info. But that sounds a lot more complex than the 
immediate issue warrants. Still, it would address the issue fully.

-- Jack Krupansky

--------------------------------------------------
From: <karl.wright@nokia.com>
Sent: Tuesday, June 22, 2010 10:19 PM
To: <connectors-user@incubator.apache.org>
Subject: RE: Sharepoint Connector

> There are really only three models that could be used for this kind of 
> data.
>
> (1) Inclusion as part of Solr connector configuration information.
> (2) Inclusion as part of Solr connector output specification information 
> (which means it would be set on a per-job basis).
> (3) Dynamic discovery on every request.
>
> I think that (3) is impractical from a performance standpoint, unless 
> Solr's extractingUpdateRequestHandler gives you a predefined way of 
> sending a generic ID field which *it* then maps to the actual id field. 
> (1) would work, but would preclude any kind of dynamic discovery (because 
> you need the configuration information to be set up in order to talk with 
> Solr at all - chicken and egg).  (2) is just plain the wrong place to do 
> this.
>
> So, logically, we either do (1) and do not expect dynamic discovery, or we 
> do (3), and make changes to Solr to support it.
>
> Thoughts?
> Karl
>
> ________________________________________
> From: ext Erik Hatcher [erik.hatcher@gmail.com]
> Sent: Tuesday, June 22, 2010 10:10 PM
> To: connectors-user@incubator.apache.org
> Subject: Re: Sharepoint Connector
>
> Or maybe obtained dynamically from Solr itself :)   At the very least,
> schema.xml is fetchable from Solr - look at Solr's admin UI for the
> link.  But there are possibly other ways to get that value from Solr
> if we needed it.
>
>        Erik
>
> On Jun 22, 2010, at 10:00 PM, Jack Krupansky wrote:
>
>> Oops, yeah. So it probably needs to be a property that can be set in
>> the Solr output connector UI as well.
>>
>> -- Jack Krupansky
>>
>> --------------------------------------------------
>> From: "Erik Hatcher" <erik.hatcher@gmail.com>
>> Sent: Tuesday, June 22, 2010 9:02 PM
>> To: <connectors-user@incubator.apache.org>
>> Subject: Re: Sharepoint Connector
>>
>>> Note that "id" is just an arbitrary field name in Solr, so one
>>> can't guarantee that's the actual field name or if it has been set
>>> to  something else using the uniqueKey setting in schema.xml.
>>>
>>> Erik
>>>
>>> On Jun 22, 2010, at 1:57 PM, <karl.wright@nokia.com> 
>>> <karl.wright@nokia.com
>>> > wrote:
>>>
>>>> There is one way I can think of for this to happen inside LCF,
>>>> and  that is if there is a metadata field called “id” attached to
>>>> the  SharePoint document.  So then you will get two “id” fields.
>>>>
>>>> Not sure what to do about this, though.  All I can think of is to
>>>> suppress all metadata fields called “id” in the solr connector.
>>>>
>>>> Karl
>>>>
>>>>
>>>> From: Wright Karl (Nokia-S/Cambridge)
>>>> Sent: Tuesday, June 22, 2010 1:48 PM
>>>> To: Rohan.GPatil@cognizant.com; connectors-user@incubator.apache.org
>>>> Subject: RE: Sharepoint Connector
>>>>
>>>> Actually, LCF does not have the ability to send two id’s.  So,
>>>> this  is almost certainly a Solr issue.
>>>>
>>>> You can verify this using the steps I outlined earlier.  The id
>>>> that  LCF will be sending is a url, but that url may well have a
>>>> comma in  it.  If it does, it appears that Solr does something
>>>> funky with it  and interprets it as multiple values.
>>>>
>>>> If you can please confirm that LCF’s ingestion into Solr is using
>>>> a  URL with commas, then we can go ahead and figure out if there
>>>> is a  way to address the issue on the solr end.
>>>>
>>>> Thanks,
>>>> Karl
>>>>
>>>> From: Rohan.GPatil@cognizant.com [mailto:Rohan.GPatil@cognizant.com]
>>>> Sent: Tuesday, June 22, 2010 1:03 PM
>>>> To: connectors-user@incubator.apache.org
>>>> Subject: RE: Sharepoint Connector
>>>>
>>>> Hi,
>>>>
>>>> literal.FileSizeDisplay=1928&literal.deny_token_document=Ad%2BAu
>>>> thority
>>>> %2BConnector:DEAD_AUTHORITY&literal.Edit=0&literal.DocIcon=xml&li
>>>> teral.id=http://orgfudmac:2122/Shared%2520Documents/Test/firsttemp
>>>> late
>>>>  .xml
>>>> &literal.LinkFilenameNoMenu=firsttemplate.xml&literal.Created=20
>>>> 10-05-20T15:10:42&literal.allow_token_document=Ad%2BAuthority
>>>> %2BConnecto
>>>> r:S
>>>> -1
>>>> -5-21-1178368992-402679808-390482200-115498&literal.allow_token_doc
>>>> ument=Ad%2BAuthority
>>>> %2BConnector:S-1-5-21-1178368992-402679808-390482200
>>>> -222745&literal.allow_token_document=Ad%2BAuthority
>>>> %2BConnector:S-1-5-21
>>>> -1178368992
>>>> -402679808-390482200-289873&literal.allow_token_document=Ad%2
>>>> BAuthority
>>>> %2BConnector:S-1-5-21-1178368992-402679808-390482200-519550&li
>>>> teral.allow_token_document=Ad%2BAuthority
>>>> %2BConnector:S-1-5-21-117836899
>>>> 2-402679808-390482200-544963&literal.allow_token_document=Ad
>>>> %2BAuthority
>>>> %2BConnector:S
>>>> -1-5-21-374722173-1639260489-1021760189-1020&literal._UIVe
>>>> rsionString
>>>> =1.0&literal.Title=firsttemplate.xml&literal.ID=6&literal.Mod
>>>> ified
>>>> =2010-05-20T15:10:42&fmap.content=text&literal.Author=Mukherjee, +Sh
>>>> ubhdeep+
>>>> (org)&literal.FileLeafRef=firsttemplate.xml&literal.LinkFilename
>>>> =firsttemplate.xml&uprefix=attr_&literal.Editor=Mukherjee,
>>>> +Shubhdeep+ (or
>>>> g)&lowernames=true&literal.ContentType=Document&captureAttr=true
>>>>
>>>>
>>>> as u can see there are 2 ids being sent! i have hilighted themin
>>>> bold. Is this the problem ??
>>>>
>>>> Thanks and Regards
>>>> Rohan
>>>> From: karl.wright@nokia.com [mailto:karl.wright@nokia.com]
>>>> Sent: Tue 6/22/2010 9:48 PM
>>>> To: connectors-user@incubator.apache.org
>>>> Subject: RE: Sharepoint Connector
>>>>
>>>> Actually, it's clear from the trace that Solr is interpreting the
>>>> literal.id url with a comma as being multivalued.  I suppose we
>>>> should check whether LCF is making some kind of an error in the
>>>> original ID, though.  Can you use the Simple Report tool to find
>>>> one  of the ingestion requests for a url that has a comma in it,
>>>> and send  me the corresponding url?  Also, paste that url into a
>>>> browser and  see if you get the document you expect.  If you do,
>>>> then LCF is  doing everything properly. But Solr is making a
>>>> decision about what  sort of thing a field can contain.  Hopefully
>>>> there's a good way to  override it in schema.xml, but if not,
>>>> there needs to be a way.
>>>>
>>>> Karl
>>>>
>>>>
>>>> -----Original Message-----
>>>> From: Wright Karl (Nokia-S/Cambridge)
>>>> Sent: Tuesday, June 22, 2010 12:06 PM
>>>> To: connectors-user@incubator.apache.org
>>>> Subject: RE: Sharepoint Connector
>>>>
>>>> So, Solr is interpreting the "," in some funky way?  That sounds
>>>> like potentially incorrect behavior on the part of Solr.  Can you
>>>> post to the lucene/solr list and ask them if this is intentional
>>>> behavior?
>>>>
>>>> Karl
>>>>
>>>>
>>>> -----Original Message-----
>>>> From: ext Rohan.GPatil@cognizant.com [mailto:Rohan.GPatil@cognizant.com
>>>>  ]
>>>> Sent: Tuesday, June 22, 2010 11:19 AM
>>>> To: connectors-user@incubator.apache.org
>>>> Subject: RE: Sharepoint Connector
>>>>
>>>>
>>>> Hi Karl,
>>>>
>>>>
>>>> Thanks a lot to you :)
>>>>
>>>> But the next error is
>>>>
>>>> SEVERE: org.apache.solr.common.SolrException: Document specifies
>>>> multiple unique ids! Id
>>>>
>>>> Because the id is sent like this
>>>>
>>>> "http://orginfudvmtech0:2122/Shared%20Documents/OOPS.docx, 1"
>>>>
>>>> Thanks & Regards,
>>>> Rohan G Patil
>>>>
>>>> -----Original Message-----
>>>> From: karl.wright@nokia.com [mailto:karl.wright@nokia.com]
>>>> Sent: Tuesday, June 22, 2010 7:19 PM
>>>> To: connectors-user@incubator.apache.org
>>>> Subject: RE: Sharepoint Connector
>>>>
>>>> Hi Rohan,
>>>>
>>>> This is actually great news, in that the directions are useful
>>>> enough
>>>> now so that it is possible to follow them and succeed. ;-)
>>>>
>>>> Anyhow, all you need to do to make this work is to change your Solr
>>>> schema definition file (called schema.xml), to declare the field
>>>> you  are
>>>> using for the author to be multivalued.  There are some examples
>>>> of  this
>>>> usage in the example solr schema.xml file under example/solr/conf.
>>>>
>>>> Thanks,
>>>> Karl
>>>>
>>>> -----Original Message-----
>>>> From: ext Rohan.GPatil@cognizant.com [mailto:Rohan.GPatil@cognizant.com
>>>>  ]
>>>> Sent: Tuesday, June 22, 2010 9:25 AM
>>>> To: connectors-user@incubator.apache.org
>>>> Subject: RE: Sharepoint Connector
>>>>
>>>>
>>>> Hi,
>>>>
>>>> Finally the Sharepoint connection is functional. But I have
>>>> stumbled  on
>>>> to a new problem.
>>>>
>>>> There are multiple values for author field in sharepoint,
>>>> therefore  its
>>>> giving a bad request error. The logs is
>>>>
>>>> Jun 22, 2010 6:37:38 PM org.apache.solr.common.SolrException log
>>>> SEVERE: org.apache.solr.common.SolrException: ERROR:
>>>> [http://ctsinbtpvmtech0:2122/Shared%20Documents/Test/
>>>> firsttemplate.xml]
>>>> multiple values encountered for non multiValued field id:
>>>> [http://ctsinbtpvmtech0:2122/Shared%20Documents/Test/
>>>> firsttemplate.xml,
>>>> 6]
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.update.DocumentBuilder.toDocument(DocumentBuilder.java:2
>>>> 14)
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.update.processor.RunUpdateProcessor.processAdd(RunUpdate
>>>> ProcessorFactory.java:60)
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.handler.extraction.ExtractingDocumentLoader.doAdd(Extrac
>>>> tingDocumentLoader.java:118)
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.handler.extraction.ExtractingDocumentLoader.addDoc(Extra
>>>> ctingDocumentLoader.java:123)
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.handler.extraction.ExtractingDocumentLoader.load(Extract
>>>> ingDocumentLoader.java:192)
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.handler.ContentStreamHandlerBase.handleRequestBody(Conte
>>>> ntStreamHandlerBase.java:54)
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.handler.RequestHandlerBase.handleRequest(RequestHandlerB
>>>> ase.java:131)
>>>>       at
>>>> org.apache.solr.core.RequestHandlers
>>>> $LazyRequestHandlerWrapper.handleReq
>>>> uest(RequestHandlers.java:233)
>>>>       at org.apache.solr.core.SolrCore.execute(SolrCore.java:1316)
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.servlet.SolrDispatchFilter.execute(SolrDispatchFilter.ja
>>>> va:338)
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.j
>>>> ava:241)
>>>>       at
>>>> org
>>>>  .apache
>>>> .catalina.core.ApplicationFilterChain.internalDoFilter(Applica
>>>> tionFilterChain.java:235)
>>>>       at
>>>> org
>>>>  .apache
>>>> .catalina.core.ApplicationFilterChain.doFilter(ApplicationFilt
>>>> erChain.java:206)
>>>>       at
>>>> org
>>>>  .apache
>>>> .catalina.core.StandardWrapperValve.invoke(StandardWrapperValv
>>>> e.java:233)
>>>>       at
>>>> org
>>>>  .apache
>>>> .catalina.core.StandardContextValve.invoke(StandardContextValv
>>>> e.java:191)
>>>>       at
>>>> org
>>>>  .apache
>>>> .catalina.core.StandardHostValve.invoke(StandardHostValve.java
>>>> :128)
>>>>       at
>>>> org
>>>>  .apache
>>>> .catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java
>>>> :102)
>>>>       at
>>>> org
>>>>  .apache
>>>> .catalina.core.StandardEngineValve.invoke(StandardEngineValve.
>>>> java:109)
>>>>       at
>>>> org
>>>>  .apache
>>>> .catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:2
>>>> 93)
>>>>       at
>>>> org
>>>>  .apache
>>>> .coyote.http11.Http11Processor.process(Http11Processor.java:84
>>>> 9)
>>>>       at
>>>> org.apache.coyote.http11.Http11Protocol
>>>> $Http11ConnectionHandler.process(
>>>> Http11Protocol.java:583)
>>>>       at
>>>> org.apache.tomcat.util.net.JIoEndpoint
>>>> $Worker.run(JIoEndpoint.java: 454)
>>>>       at java.lang.Thread.run(Unknown Source)
>>>>
>>>> Jun 22, 2010 6:37:38 PM org.apache.solr.core.SolrCore execute
>>>> INFO: [] webapp=/solr path=/update/extract
>>>> params
>>>> ={literal.FileSizeDisplay=1928&literal.deny_token_document=Ad %2BAu
>>>> thority
>>>> %2BConnector:DEAD_AUTHORITY&literal.Edit=0&literal.DocIcon=xml&li
>>>> teral.id=http://ctsinbtpvmtech0:2122/Shared%2520Documents/Test/
>>>> firsttemp
>>>> late
>>>>  .xml
>>>> &literal.LinkFilenameNoMenu=firsttemplate.xml&literal.Created=20
>>>> 10-05-20T15:10:42&literal.allow_token_document=Ad%2BAuthority
>>>> %2BConnecto
>>>> r:S
>>>> -1
>>>> -5-21-1178368992-402679808-390482200-115498&literal.allow_token_doc
>>>> ument=Ad%2BAuthority
>>>> %2BConnector:S-1-5-21-1178368992-402679808-390482200
>>>> -222745&literal.allow_token_document=Ad%2BAuthority
>>>> %2BConnector:S-1-5-21
>>>> -1178368992
>>>> -402679808-390482200-289873&literal.allow_token_document=Ad%2
>>>> BAuthority
>>>> %2BConnector:S-1-5-21-1178368992-402679808-390482200-519550&li
>>>> teral.allow_token_document=Ad%2BAuthority
>>>> %2BConnector:S-1-5-21-117836899
>>>> 2-402679808-390482200-544963&literal.allow_token_document=Ad
>>>> %2BAuthority
>>>> %2BConnector:S
>>>> -1-5-21-374722173-1639260489-1021760189-1020&literal._UIVe
>>>> rsionString
>>>> =1.0&literal.Title=firsttemplate.xml&literal.ID=6&literal.Mod
>>>> ified
>>>> =2010-05-20T15:10:42&fmap.content=text&literal.Author=Mukherjee, +Sh
>>>> ubhdeep+
>>>> (org)&literal.FileLeafRef=firsttemplate.xml&literal.LinkFilename
>>>> =firsttemplate.xml&uprefix=attr_&literal.Editor=Mukherjee,
>>>> +Shubhdeep+ (or
>>>> g)&lowernames=true&literal.ContentType=Document&captureAttr=true}
>>>> status=400 QTime=550
>>>> Jun 22, 2010 6:37:40 PM
>>>> org.apache.solr.update.processor.LogUpdateProcessor finish
>>>> INFO: {} 0 2006
>>>> Jun 22, 2010 6:37:40 PM org.apache.solr.common.SolrException log
>>>> SEVERE: org.apache.solr.common.SolrException: ERROR:
>>>> [http://ctsinbtpvmtech0:2122/Shared%20Documents/MCMS%20White
>>>> %20Paper.doc
>>>> x] multiple values encountered for non multiValued field author:
>>>> [223423, Mukherjee, Shubhdeep (org)]
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.update.DocumentBuilder.toDocument(DocumentBuilder.java:2
>>>> 14)
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.update.processor.RunUpdateProcessor.processAdd(RunUpdate
>>>> ProcessorFactory.java:60)
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.handler.extraction.ExtractingDocumentLoader.doAdd(Extrac
>>>> tingDocumentLoader.java:118)
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.handler.extraction.ExtractingDocumentLoader.addDoc(Extra
>>>> ctingDocumentLoader.java:123)
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.handler.extraction.ExtractingDocumentLoader.load(Extract
>>>> ingDocumentLoader.java:192)
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.handler.ContentStreamHandlerBase.handleRequestBody(Conte
>>>> ntStreamHandlerBase.java:54)
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.handler.RequestHandlerBase.handleRequest(RequestHandlerB
>>>> ase.java:131)
>>>>       at
>>>> org.apache.solr.core.RequestHandlers
>>>> $LazyRequestHandlerWrapper.handleReq
>>>> uest(RequestHandlers.java:233)
>>>>       at org.apache.solr.core.SolrCore.execute(SolrCore.java:1316)
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.servlet.SolrDispatchFilter.execute(SolrDispatchFilter.ja
>>>> va:338)
>>>>       at
>>>> org
>>>>  .apache
>>>> .solr.servlet.SolrDispatchFilter.doFilter(SolrDispatchFilter.j
>>>> ava:241)
>>>>       at
>>>> org
>>>>  .apache
>>>> .catalina.core.ApplicationFilterChain.internalDoFilter(Applica
>>>> tionFilterChain.java:235)
>>>>       at
>>>> org
>>>>  .apache
>>>> .catalina.core.ApplicationFilterChain.doFilter(ApplicationFilt
>>>> erChain.java:206)
>>>>       at
>>>> org
>>>>  .apache
>>>> .catalina.core.StandardWrapperValve.invoke(StandardWrapperValv
>>>> e.java:233)
>>>>       at
>>>> org
>>>>  .apache
>>>> .catalina.core.StandardContextValve.invoke(StandardContextValv
>>>> e.java:191)
>>>>       at
>>>> org
>>>>  .apache
>>>> .catalina.core.StandardHostValve.invoke(StandardHostValve.java
>>>> :128)
>>>>       at
>>>> org
>>>>  .apache
>>>> .catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java
>>>> :102)
>>>>       at
>>>> org
>>>>  .apache
>>>> .catalina.core.StandardEngineValve.invoke(StandardEngineValve.
>>>> java:109)
>>>>       at
>>>> org
>>>>  .apache
>>>> .catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:2
>>>> 93)
>>>>       at
>>>> org
>>>>  .apache
>>>> .coyote.http11.Http11Processor.process(Http11Processor.java:84
>>>> 9)
>>>>       at
>>>> org.apache.coyote.http11.Http11Protocol
>>>> $Http11ConnectionHandler.process(
>>>> Http11Protocol.java:583)
>>>>       at
>>>> org.apache.tomcat.util.net.JIoEndpoint
>>>> $Worker.run(JIoEndpoint.java: 454)
>>>>       at java.lang.Thread.run(Unknown Source)
>>>>
>>>>
>>>> Please point me in the right direction.
>>>>
>>>> Thanks & Regards,
>>>> Rohan G Patil
>>>>
>>>> -----Original Message-----
>>>> From: karl.wright@nokia.com [mailto:karl.wright@nokia.com]
>>>> Sent: Monday, June 21, 2010 9:05 PM
>>>> To: connectors-user@incubator.apache.org
>>>> Subject: RE: Sharepoint Connector
>>>>
>>>> Yes.  You are still missing:
>>>>
>>>> Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral,
>>>> PublicKeyToken=71e9bce111e9429c, processorArchitecture=MSIL
>>>>
>>>> That's a file, usually called "SharePoint.dll", which should be
>>>> put in
>>>> the place the error message below tells you.  Alternatively, you can
>>>> simply install SharePoint and it should put the file in the right
>>>> place.
>>>>
>>>> Karl
>>>>
>>>>
>>>> -----Original Message-----
>>>> From: ext Rohan.GPatil@cognizant.com [mailto:Rohan.GPatil@cognizant.com
>>>>  ]
>>>> Sent: Monday, June 21, 2010 11:17 AM
>>>> To: connectors-user@incubator.apache.org
>>>> Subject: RE: Sharepoint Connector
>>>>
>>>>
>>>> Hi,
>>>>
>>>> Well fixed the registry settings and still encounter this,
>>>>
>>>>
>>>> Are some references missing?
>>>>
>>>>
>>>>
>>>> Buildfile: D:\Rohan\LCF\modules\connectors\sharepoint\build.xml
>>>>
>>>> calculate-condition:
>>>>
>>>> precompile-check:
>>>>
>>>> build-webservice:
>>>>    [exec] Microsoft (R) Build Engine Version 2.0.50727.4927
>>>>    [exec] [Microsoft .NET Framework, Version 2.0.50727.4927]
>>>>    [exec] Copyright (C) Microsoft Corporation 2005. All rights
>>>> reserved.
>>>>    [exec]
>>>>    [exec] Could Not Find
>>>> D:\Rohan\LCF\modules\connectors\sharepoint\webservice
>>>> \bin\*.dll
>>>>    [exec] The system cannot find the file specified.
>>>>    [exec] Build started 6/21/2010 8:41:09 PM.
>>>>    [exec] __________________________________________________
>>>>    [exec] Project
>>>> "D:\Rohan\LCF\modules\connectors\sharepoint\webservice\MCPer
>>>> missionsService.csproj" (default targets):
>>>>    [exec]
>>>>    [exec] Target ResolveAssemblyReferences:
>>>>    [exec]     Primary reference "Microsoft.SharePoint,
>>>> Version=12.0.0.0, Cultu
>>>> re=neutral, PublicKeyToken=71e9bce111e9429c,
>>>> processorArchitecture=MSIL".
>>>>    [exec]
>>>> c:\windows\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.t
>>>> argets : warning MSB3245: Could not resolve this reference. Could
>>>> not
>>>> locate the
>>>> assembly "Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral,
>>>> PublicKeyTok
>>>> en=71e9bce111e9429c, processorArchitecture=MSIL". Check to make
>>>> sure  the
>>>> assembl
>>>> y exists on disk. If this reference is required by your code, you
>>>> may
>>>> get compil
>>>> ation errors.
>>>>    [exec]             For SearchPath "{TargetFrameworkDirectory}".
>>>>    [exec]             Considered
>>>> "C:\Windows\Microsoft.NET\Framework\v2.0.5072
>>>> 7\Microsoft.SharePoint.exe", but it didn't exist.
>>>>    [exec]             Considered
>>>> "C:\Windows\Microsoft.NET\Framework\v2.0.5072
>>>> 7\Microsoft.SharePoint.dll", but it didn't exist.
>>>>    [exec]             For SearchPath "{AssemblyFolders}".
>>>>    [exec]             Considered "C:\Program Files\Reference
>>>> Assemblies\Micros
>>>> oft\Framework\v3.5\Microsoft.SharePoint.exe", but it didn't exist.
>>>>    [exec]             Considered "C:\Program Files\Reference
>>>> Assemblies\Micros
>>>> oft\Framework\v3.5\Microsoft.SharePoint.dll", but it didn't exist.
>>>>    [exec]             For SearchPath "{GAC}".
>>>>    [exec]             Considered "Microsoft.SharePoint,
>>>> Version=12.0.0.0, Cult
>>>> ure=neutral, PublicKeyToken=71e9bce111e9429c,
>>>> processorArchitecture=MSIL", which
>>>> was not found in the GAC.
>>>>    [exec]             For SearchPath "{RawFileName}".
>>>>    [exec]             Considered treating "Microsoft.SharePoint,
>>>> Version=12.0.
>>>> 0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c,
>>>> processorArchitecture=MSI
>>>> L" as a file name, but it didn't exist.
>>>>    [exec]             For SearchPath "bin\".
>>>>    [exec]             Considered "bin\Microsoft.SharePoint.exe", but
>>>> it didn't
>>>> exist.
>>>>    [exec]             Considered "bin\Microsoft.SharePoint.dll", but
>>>> it didn't
>>>> exist.
>>>>    [exec] Done building target "ResolveAssemblyReferences" in
>>>> project
>>>> "MCPermi
>>>> ssionsService.csproj".
>>>>    [exec] Target CoreCompile:
>>>>    [exec]     C:\Windows\Microsoft.NET\Framework\v2.0.50727\Csc.exe
>>>> /noconfig
>>>> /nowarn:1701,1702 /errorreport:prompt /warn:4 /define:DEBUG;TRACE
>>>> /reference:C:\
>>>> Windows\Microsoft.NET\Framework\v2.0.50727\System.Configuration.dll
>>>> /reference:C
>>>> :\Windows\Microsoft.NET\Framework\v2.0.50727\System.Data.dll
>>>> /reference:C:\Windo
>>>> ws\Microsoft.NET\Framework\v2.0.50727\System.dll
>>>> /reference:C:\Windows\Microsoft
>>>> .NET\Framework\v2.0.50727\System.Drawing.dll
>>>> /reference:C:\Windows\Microsoft.NET
>>>> \Framework\v2.0.50727\System.EnterpriseServices.dll
>>>> /reference:C:\Windows\Micros
>>>> oft.NET\Framework\v2.0.50727\System.Web.dll
>>>> /reference:C:\Windows\Microsoft.NET\
>>>> Framework\v2.0.50727\System.Web.Mobile.dll
>>>> /reference:C:\Windows\Microsoft.NET\F
>>>> ramework\v2.0.50727\System.Web.Services.dll
>>>> /reference:C:\Windows\Microsoft.NET\
>>>> Framework\v2.0.50727\System.Xml.dll /debug+ /debug:full
>>>> /keyfile:MetaCarta.snk /
>>>> optimize- /out:obj\Debug\MetaCarta.SharePoint.dll /target:library
>>>> MCPermissions.
>>>> cs Properties\AssemblyInfo.cs Properties\Settings.Designer.cs "Web
>>>> References\SP
>>>> PermissionsService\Reference.cs"
>>>>    [exec]     MCPermissions.cs(28,17): error CS0234: The type or
>>>> namespace nam
>>>> e 'SharePoint' does not exist in the namespace 'Microsoft' (are you
>>>> missing an a
>>>> ssembly reference?)
>>>>    [exec]     MCPermissions.cs(137,63): error CS0246: The type or
>>>> namespace na
>>>> me 'SPPrincipal' could not be found (are you missing a using
>>>> directive
>>>> or an ass
>>>> embly reference?)
>>>>    [exec]     MCPermissions.cs(137,83): error CS0246: The type or
>>>> namespace na
>>>> me 'SPRoleDefinition' could not be found (are you missing a using
>>>> directive or a
>>>> n assembly reference?)
>>>>    [exec] Done building target "CoreCompile" in project
>>>> "MCPermissionsService.
>>>> csproj" -- FAILED.
>>>>    [exec]
>>>>    [exec] Done building project "MCPermissionsService.csproj" --
>>>> FAILED.
>>>>    [exec]
>>>>    [exec] Build FAILED.
>>>>    [exec]
>>>> c:\windows\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targe
>>>> ts : warning MSB3245: Could not resolve this reference. Could not
>>>> locate
>>>> the ass
>>>> embly "Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral,
>>>> PublicKeyToken=7
>>>> 1e9bce111e9429c, processorArchitecture=MSIL". Check to make sure the
>>>> assembly ex
>>>> ists on disk. If this reference is required by your code, you may
>>>> get
>>>> compilatio
>>>> n errors.
>>>>    [exec] MCPermissions.cs(28,17): error CS0234: The type or
>>>> namespace
>>>> name 'S
>>>> harePoint' does not exist in the namespace 'Microsoft' (are you
>>>> missing
>>>> an assem
>>>> bly reference?)
>>>>    [exec] MCPermissions.cs(137,63): error CS0246: The type or
>>>> namespace name '
>>>> SPPrincipal' could not be found (are you missing a using
>>>> directive  or an
>>>> assembl
>>>> y reference?)
>>>>    [exec] MCPermissions.cs(137,83): error CS0246: The type or
>>>> namespace name '
>>>> SPRoleDefinition' could not be found (are you missing a using
>>>> directive
>>>> or an as
>>>> sembly reference?)
>>>>    [exec]     1 Warning(s)
>>>>    [exec]     3 Error(s)
>>>>    [exec]
>>>>    [exec] Time Elapsed 00:00:00.43
>>>>    [exec] Cabinet Maker - Lossless Data Compression Tool
>>>>    [exec]
>>>>    [exec] Parsing directives
>>>>    [exec] Parsing directives (MCPermissionsService.ddf: 1
>>>> lines)MCPermissionsS
>>>> ervice.ddf(26): ERROR: Could not find file: bin
>>>> \MetaCarta.SharePoint.dll
>>>>    [exec] ERROR: MakeCAB aborted: 1 errors encountered
>>>>    [exec] Result: 1
>>>>
>>>> BUILD SUCCESSFUL
>>>> Total time: 1 second
>>>>
>>>>
>>>>
>>>> Thanks & Regards,
>>>> Rohan G Patil
>>>> Cognizant  Programmer Analyst Trainee,Bangalore || Mob # +91
>>>> 9535577001
>>>> Rohan.GPatil@cognizant.com
>>>>
>>>>
>>>> -----Original Message-----
>>>> From: G Patil, Rohan (Cognizant)
>>>> Sent: Monday, June 21, 2010 8:25 PM
>>>> To: 'connectors-user@incubator.apache.org'
>>>> Subject: RE: Sharepoint Connector
>>>>
>>>> Hi,
>>>>
>>>> Encountered this
>>>>
>>>>
>>>>
>>>> Buildfile: D:\Rohan\LCF\modules\connectors\sharepoint\build.xml
>>>>
>>>> calculate-condition:
>>>>
>>>> precompile-check:
>>>>
>>>> build-webservice:
>>>>    [copy] Copying 1 file to
>>>> D:\Rohan\LCF\modules\connectors\sharepoint\webserv
>>>> ice\References\SPPermissionsService
>>>>    [exec] The system cannot find the file specified.
>>>>    [exec] The system cannot find the file specified.
>>>>    [exec] Microsoft (R) Build Engine Version 2.0.50727.4927
>>>>    [exec] [Microsoft .NET Framework, Version 2.0.50727.4927]
>>>>    [exec] Copyright (C) Microsoft Corporation 2005. All rights
>>>> reserved.
>>>>    [exec]
>>>>    [exec] Build started 6/21/2010 8:06:03 PM.
>>>>    [exec] __________________________________________________
>>>>    [exec] Project
>>>> "D:\Rohan\LCF\modules\connectors\sharepoint\webservice\MCPer
>>>> missionsService.csproj" (default targets):
>>>>    [exec]
>>>>    [exec] Target GetFrameworkPaths:
>>>>    [exec]     Could not locate the .NET Framework SDK.  The task is
>>>> looking fo
>>>> r the path to the .NET Framework SDK at the location specified in
>>>> the
>>>> SDKInstall
>>>> Rootv2.0 value of the registry key
>>>> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFra
>>>> mework.  You may be able to solve the problem by doing one of the
>>>> following:  1.
>>>> ) Install the .NET Framework SDK.  2.) Manually set the above
>>>> registry
>>>> key to th
>>>> e correct location.
>>>>    [exec] Target PrepareForBuild:
>>>>    [exec]     Creating directory "bin\".
>>>>    [exec]     Creating directory "obj\Debug\".
>>>>    [exec] Target ResolveAssemblyReferences:
>>>>    [exec]     Primary reference "Microsoft.SharePoint,
>>>> Version=12.0.0.0, Cultu
>>>> re=neutral, PublicKeyToken=71e9bce111e9429c,
>>>> processorArchitecture=MSIL".
>>>>    [exec]
>>>> c:\windows\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.t
>>>> argets : warning MSB3245: Could not resolve this reference. Could
>>>> not
>>>> locate the
>>>> assembly "Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral,
>>>> PublicKeyTok
>>>> en=71e9bce111e9429c, processorArchitecture=MSIL". Check to make
>>>> sure  the
>>>> assembl
>>>> y exists on disk. If this reference is required by your code, you
>>>> may
>>>> get compil
>>>> ation errors.
>>>>    [exec]             For SearchPath "{TargetFrameworkDirectory}".
>>>>    [exec]             Considered
>>>> "C:\Windows\Microsoft.NET\Framework\v2.0.5072
>>>> 7\Microsoft.SharePoint.exe", but it didn't exist.
>>>>    [exec]             Considered
>>>> "C:\Windows\Microsoft.NET\Framework\v2.0.5072
>>>> 7\Microsoft.SharePoint.dll", but it didn't exist.
>>>>    [exec]             For SearchPath "{AssemblyFolders}".
>>>>    [exec]             Considered "C:\Program Files\Reference
>>>> Assemblies\Micros
>>>> oft\Framework\v3.5\Microsoft.SharePoint.exe", but it didn't exist.
>>>>    [exec]             Considered "C:\Program Files\Reference
>>>> Assemblies\Micros
>>>> oft\Framework\v3.5\Microsoft.SharePoint.dll", but it didn't exist.
>>>>    [exec]             For SearchPath "{GAC}".
>>>>    [exec]             Considered "Microsoft.SharePoint,
>>>> Version=12.0.0.0, Cult
>>>> ure=neutral, PublicKeyToken=71e9bce111e9429c,
>>>> processorArchitecture=MSIL", which
>>>> was not found in the GAC.
>>>>    [exec]             For SearchPath "{RawFileName}".
>>>>    [exec]             Considered treating "Microsoft.SharePoint,
>>>> Version=12.0.
>>>> 0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c,
>>>> processorArchitecture=MSI
>>>> L" as a file name, but it didn't exist.
>>>>    [exec]             For SearchPath "bin\".
>>>>    [exec]             Considered "bin\Microsoft.SharePoint.exe", but
>>>> it didn't
>>>> exist.
>>>>    [exec]             Considered "bin\Microsoft.SharePoint.dll", but
>>>> it didn't
>>>> exist.
>>>>    [exec] Done building target "ResolveAssemblyReferences" in
>>>> project
>>>> "MCPermi
>>>> ssionsService.csproj".
>>>>    [exec] Target CoreCompile:
>>>>    [exec]     C:\Windows\Microsoft.NET\Framework\v2.0.50727\Csc.exe
>>>> /noconfig
>>>> /nowarn:1701,1702 /errorreport:prompt /warn:4 /define:DEBUG;TRACE
>>>> /reference:C:\
>>>> Windows\Microsoft.NET\Framework\v2.0.50727\System.Configuration.dll
>>>> /reference:C
>>>> :\Windows\Microsoft.NET\Framework\v2.0.50727\System.Data.dll
>>>> /reference:C:\Windo
>>>> ws\Microsoft.NET\Framework\v2.0.50727\System.dll
>>>> /reference:C:\Windows\Microsoft
>>>> .NET\Framework\v2.0.50727\System.Drawing.dll
>>>> /reference:C:\Windows\Microsoft.NET
>>>> \Framework\v2.0.50727\System.EnterpriseServices.dll
>>>> /reference:C:\Windows\Micros
>>>> oft.NET\Framework\v2.0.50727\System.Web.dll
>>>> /reference:C:\Windows\Microsoft.NET\
>>>> Framework\v2.0.50727\System.Web.Mobile.dll
>>>> /reference:C:\Windows\Microsoft.NET\F
>>>> ramework\v2.0.50727\System.Web.Services.dll
>>>> /reference:C:\Windows\Microsoft.NET\
>>>> Framework\v2.0.50727\System.Xml.dll /debug+ /debug:full
>>>> /keyfile:MetaCarta.snk /
>>>> optimize- /out:obj\Debug\MetaCarta.SharePoint.dll /target:library
>>>> MCPermissions.
>>>> cs Properties\AssemblyInfo.cs Properties\Settings.Designer.cs "Web
>>>> References\SP
>>>> PermissionsService\Reference.cs"
>>>>    [exec]     MCPermissions.cs(28,17): error CS0234: The type or
>>>> namespace nam
>>>> e 'SharePoint' does not exist in the namespace 'Microsoft' (are you
>>>> missing an a
>>>> ssembly reference?)
>>>>    [exec]     MCPermissions.cs(137,63): error CS0246: The type or
>>>> namespace na
>>>> me 'SPPrincipal' could not be found (are you missing a using
>>>> directive
>>>> or an ass
>>>> embly reference?)
>>>>    [exec]     MCPermissions.cs(137,83): error CS0246: The type or
>>>> namespace na
>>>> me 'SPRoleDefinition' could not be found (are you missing a using
>>>> directive or a
>>>> n assembly reference?)
>>>>    [exec] Done building target "CoreCompile" in project
>>>> "MCPermissionsService.
>>>> csproj" -- FAILED.
>>>>    [exec]
>>>>    [exec] Done building project "MCPermissionsService.csproj" --
>>>> FAILED.
>>>>    [exec]
>>>>    [exec] Build FAILED.
>>>>    [exec]
>>>> c:\windows\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targe
>>>> ts : warning MSB3245: Could not resolve this reference. Could not
>>>> locate
>>>> the ass
>>>> embly "Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral,
>>>> PublicKeyToken=7
>>>> 1e9bce111e9429c, processorArchitecture=MSIL". Check to make sure the
>>>> assembly ex
>>>> ists on disk. If this reference is required by your code, you may
>>>> get
>>>> compilatio
>>>> n errors.
>>>>    [exec] MCPermissions.cs(28,17): error CS0234: The type or
>>>> namespace
>>>> name 'S
>>>> harePoint' does not exist in the namespace 'Microsoft' (are you
>>>> missing
>>>> an assem
>>>> bly reference?)
>>>>    [exec] MCPermissions.cs(137,63): error CS0246: The type or
>>>> namespace name '
>>>> SPPrincipal' could not be found (are you missing a using
>>>> directive  or an
>>>> assembl
>>>> y reference?)
>>>>    [exec] MCPermissions.cs(137,83): error CS0246: The type or
>>>> namespace name '
>>>> SPRoleDefinition' could not be found (are you missing a using
>>>> directive
>>>> or an as
>>>> sembly reference?)
>>>>    [exec]     1 Warning(s)
>>>>    [exec]     3 Error(s)
>>>>    [exec]
>>>>    [exec] Time Elapsed 00:00:01.89
>>>>    [exec] Cabinet Maker - Lossless Data Compression Tool
>>>>    [exec]
>>>>    [exec] Parsing directives
>>>>    [exec] Parsing directives (MCPermissionsService.ddf: 1
>>>> lines)MCPermissionsS
>>>> ervice.ddf(26): ERROR: Could not find file: bin
>>>> \MetaCarta.SharePoint.dll
>>>>    [exec] ERROR: MakeCAB aborted: 1 errors encountered
>>>>    [exec] Result: 1
>>>>
>>>> BUILD SUCCESSFUL
>>>> Total time: 3 seconds
>>>>
>>>>
>>>> I have the latest .Net Framework installed. And the Registry also is
>>>> reflecting the proper Path to the .Net Framework path.
>>>>
>>>> Is visual Studio absolutely necessary ?
>>>>
>>>>
>>>> Thanks & Regards,
>>>> Rohan G Patil
>>>> Cognizant  Programmer Analyst Trainee,Bangalore || Mob # +91
>>>> 9535577001
>>>> Rohan.GPatil@cognizant.com
>>>>
>>>>
>>>>
>>>>
>>>> -----Original Message-----
>>>> From: karl.wright@nokia.com [mailto:karl.wright@nokia.com]
>>>> Sent: Monday, June 21, 2010 7:58 PM
>>>> To: connectors-user@incubator.apache.org
>>>> Subject: RE: Sharepoint Connector
>>>>
>>>> That's because you need to follow the instructions to build it.
>>>> Karl
>>>>
>>>> -----Original Message-----
>>>> From: ext Rohan.GPatil@cognizant.com [mailto:Rohan.GPatil@cognizant.com
>>>>  ]
>>>> Sent: Monday, June 21, 2010 9:22 AM
>>>> To: connectors-user@incubator.apache.org
>>>> Subject: RE: Sharepoint Connector
>>>>
>>>>
>>>> Hi,
>>>>
>>>> But there seems to be one more problem the file
>>>> "MetaCarta.SharePoint.MCPermissionsService.wsp" is not available.
>>>> Which
>>>> is needed to install the webservice.
>>>>
>>>> Thanks & Regards,
>>>> Rohan G Patil
>>>> Cognizant  Programmer Analyst Trainee,Bangalore || Mob # +91
>>>> 9535577001
>>>> Rohan.GPatil@cognizant.com
>>>>
>>>>
>>>> -----Original Message-----
>>>> From: karl.wright@nokia.com [mailto:karl.wright@nokia.com]
>>>> Sent: Monday, June 21, 2010 3:34 PM
>>>> To: connectors-user@incubator.apache.org
>>>> Subject: RE: Sharepoint Connector
>>>>
>>>> (1) Please read the deployment directions.  You must install the
>>>> MCPermissions service on the SharePoint server, if it is
>>>> SharePoint  3.0
>>>> or higher and you need security.  (If you don't need security, just
>>>> select SharePoint 2.0).
>>>> (2) Authentication errors are difficult to diagnose, but I would
>>>> certainly fix problem (1) before assuming there's a problem.
>>>>
>>>> Karl
>>>>
>>>> ________________________________________
>>>> From: ext Rohan.GPatil@cognizant.com [Rohan.GPatil@cognizant.com]
>>>> Sent: Monday, June 21, 2010 2:19 AM
>>>> To: connectors-user@incubator.apache.org
>>>> Cc: Wright Karl (Nokia-S/Cambridge)
>>>> Subject: Sharepoint Connector
>>>>
>>>> Hi! (especially Karl!)
>>>>
>>>> I have two doubts about the Sharepoint Connector.
>>>>
>>>> 1) There is a wsdl called MCPermissions in the wsdls directory of
>>>> Sharepoint Connector.
>>>>
>>>> Should I delete that, Or should I leave it as it is with the
>>>> other  wsdls
>>>> which we put there prior to building LCF and due to that 302 error
>>>> is
>>>> displayed i.e. on hitting this
>>>> "http://corp.organisation.com/sites/somewhere/_vti_bin/MCPermissions.asm
>>>> x" link in the browser, its being redirected to file not found error
>>>> page.
>>>>
>>>>
>>>> 2) And using the credentials, I can access the wsdls from the
>>>> browser
>>>> i.e. Only by GET method.
>>>>
>>>> But the POST is throwing Authentication errors.
>>>>
>>>> Which type of credentials should I use to connect to Sharepoint.
>>>>
>>>>
>>>>
>>>> Thanks & Regards,
>>>> Rohan G Patil
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> This e-mail and any files transmitted with it are for the sole use
>>>> of
>>>> the intended recipient(s) and may contain confidential and
>>>> privileged
>>>> information.
>>>> If you are not the intended recipient, please contact the sender by
>>>> reply e-mail and destroy all copies of the original message.
>>>> Any unauthorized review, use, disclosure, dissemination, forwarding,
>>>> printing or copying of this email or any action taken in reliance on
>>>> this
>>>> e-mail is strictly prohibited and may be unlawful.
>>>>
>>>>
>>>>
>>>> This e-mail and any files transmitted with it are for the sole use
>>>> of
>>>> the intended recipient(s) and may contain confidential and
>>>> privileged
>>>> information.
>>>> If you are not the intended recipient, please contact the sender by
>>>> reply e-mail and destroy all copies of the original message.
>>>> Any unauthorized review, use, disclosure, dissemination, forwarding,
>>>> printing or copying of this email or any action taken in reliance on
>>>> this
>>>> e-mail is strictly prohibited and may be unlawful.
>>>>
>>>>
>>>>
>>>> This e-mail and any files transmitted with it are for the sole use
>>>> of
>>>> the intended recipient(s) and may contain confidential and
>>>> privileged
>>>> information.
>>>> If you are not the intended recipient, please contact the sender by
>>>> reply e-mail and destroy all copies of the original message.
>>>> Any unauthorized review, use, disclosure, dissemination, forwarding,
>>>> printing or copying of this email or any action taken in reliance on
>>>> this
>>>> e-mail is strictly prohibited and may be unlawful.
>>>>
>>>>
>>>>
>>>> This e-mail and any files transmitted with it are for the sole use
>>>> of
>>>> the intended recipient(s) and may contain confidential and
>>>> privileged
>>>> information.
>>>> If you are not the intended recipient, please contact the sender by
>>>> reply e-mail and destroy all copies of the original message.
>>>> Any unauthorized review, use, disclosure, dissemination, forwarding,
>>>> printing or copying of this email or any action taken in reliance on
>>>> this
>>>> e-mail is strictly prohibited and may be unlawful.
>>>>
>>>>
>>>>
>>>> This e-mail and any files transmitted with it are for the sole use
>>>> of
>>>> the intended recipient(s) and may contain confidential and
>>>> privileged
>>>> information.
>>>> If you are not the intended recipient, please contact the sender by
>>>> reply e-mail and destroy all copies of the original message.
>>>> Any unauthorized review, use, disclosure, dissemination, forwarding,
>>>> printing or copying of this email or any action taken in reliance
>>>> on this
>>>> e-mail is strictly prohibited and may be unlawful.
>>>>
> 

Mime
View raw message