manifoldcf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rafa Haro <rh...@apache.org>
Subject Re: Axis question
Date Fri, 25 Jan 2019 14:08:22 GMT
I used a wsdl2java script that comes as an utility of the apache cxf
release, but basically is making use
of org.apache.cxf.tools.wsdlto.WSDLToJava class. You can find here an usage
example with ant: http://cxf.apache.org/docs/wsdl-to-java.html

On Fri, Jan 25, 2019 at 2:59 PM Karl Wright <daddywri@gmail.com> wrote:

> I was using ancient Axis 1.4 and none of them were working.  You can
> exercise this with "ant classcreate-wsdls" in the csws directory.
>
> If you can give instructions for invoking CXF, maybe we can do that
> instead.  What's the main class, and what jars do we need to include?
>
> Karl
>
>
> On Fri, Jan 25, 2019 at 7:28 AM Rafa Haro <rharo@apache.org> wrote:
>
>> Yes, I did. I have only tested Authentication service with Apache CXF and
>> it was apparently working fine. Which ones were failing for you?
>>
>> On Fri, Jan 25, 2019 at 12:38 PM Karl Wright <daddywri@gmail.com> wrote:
>>
>>> Were you able to look at this yesterday at all?
>>> Karl
>>>
>>> On Thu, Jan 24, 2019 at 6:34 AM Karl Wright <daddywri@gmail.com> wrote:
>>>
>>>> They're all checked in.
>>>>
>>>> See
>>>> https://svn.apache.org/repos/asf/manifoldcf/branches/CONNECTORS-1566/connectors/csws/wsdls
>>>>
>>>> Karl
>>>>
>>>>
>>>> On Thu, Jan 24, 2019 at 6:24 AM Rafa Haro <rharo@apache.org> wrote:
>>>>
>>>>> Karl, can you share the WSDL, I can try to take a look later today
>>>>>
>>>>> On Thu, Jan 24, 2019 at 12:13 PM Karl Wright <daddywri@gmail.com>
>>>>> wrote:
>>>>>
>>>>> > I'm redeveloping the Livelink connector because the API code has
been
>>>>> > discontinued and the only API is now web services based.  The WSDLs
>>>>> and
>>>>> > XSDs have been exported and I'm trying to use the Axis tool
>>>>> WSDL2Java to
>>>>> > convert to Java code.  Unfortunately, I haven't been able to make
>>>>> this work
>>>>> > -- even though the WSDLs references have been made local and the
>>>>> XSDs also
>>>>> > seem to be getting parsed, it complains about missing definitions,
>>>>> even
>>>>> > though those definitions are clearly present in the XSD files.
>>>>> >
>>>>> > Has anyone had enough experience with this tool, and web services
in
>>>>> > general, to figure out what's wrong?  I've tried turning on as
>>>>> verbose a
>>>>> > debugging level for WSDL2Java as I can and it's no help at all.
 I
>>>>> suspect
>>>>> > namespace issues but I can't figure out what they are.
>>>>> >
>>>>> > Thanks in advance,
>>>>> > Karl
>>>>> >
>>>>>
>>>>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message