manifoldcf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: ManifoldCF and PostgradeSQL Version Compatability
Date Wed, 05 Dec 2018 11:55:35 GMT
We know that the 9.x series works with ManifoldCF fine.
If you go with the 10.x or 11.x series, you will need to get a different
postgresql driver but I doubt there is anything that would make this not
work.  But you would need to verify that.

Karl


On Wed, Dec 5, 2018 at 6:46 AM Singh,Jasvinder <Jasvinder.Singh@gartner.com>
wrote:

> Karl - My Question was regarding which version of postgresql is compatible
> with ManifoldCF as per postgresql site they have versioning till 11.1
>
> https://www.postgresql.org/support/versioning/
> PostgreSQL 11.1, 10.6, 9.6.11, 9.5.15, 9.4.20, and 9.3.25 Released!
>
> So my question is from the site which version of postgresql to download so
> that it can be compatible with  Postgresql driver 42.1.3 as you mentioned
> below
>
>
>
>
> -----Original Message-----
> From: Karl Wright [mailto:daddywri@gmail.com]
> Sent: Wednesday, December 05, 2018 4:43 PM
> To: dev
> Subject: Re: ManifoldCF and PostgradeSQL Version Compatability
>
> Hi Jasvinder,
>
> The Postgresql driver we currently download for testing and when customers
> build ManifoldCF themselves is:
>
>     <property name="postgresql.version" value="42.1.3"/>
>
>
> Karl
>
>
> On Wed, Dec 5, 2018 at 4:43 AM jasvinder.singh@gartner.com <
> jasvinder.singh@gartner.com> wrote:
>
> > As per Documentation in it states that
> >
> > The PostgreSQL JDBC driver included with ManifoldCF is known to work with
> > version 9.1, so that version is the currently recommended one.
> >
> > But as per
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.postgresql.org_download_&d=DwIBaQ&c=qRq7a-87GiVVW7v8KD1gdQ&r=O4FdpznhI-aW2GjsYnqls4K1A4w_taTiyoHoGzRLt4o&m=JlT2BPjDwyBACj4tLKM-exSW76gvASv-70C5cpO5ZwU&s=QLQ-FPqx0eIjPyFS_qj9fGv6aCkXLExOIiRF0M8VZ90&e=
> site version 9.1 seems
> > not downloadable
> > as its falls under unsupported version - Can you suggest what version you
> > recommend
> > today - i have to use PostgreSQL for Simplified multi-process model using
> > ZooKeeper-based synchronization.
> >
> > Also please confirm I have to update configurations in
> > properties-global.xml file and not properties.xml
> > file in D:\manifoldcftunk\dist\multiprocess-zk-example-proprietary
> > As per example in applciation for Single Process it uses properties.xml
> > to override values
> > but no where in documentation i see where to update the values for
> > Simplified multi-process model using ZooKeeper-based synchronization.
> > Looking at  properties-global.xml  file it seems it has below config so I
> > am assuming it needs to be udpated
> >
> > <property name="org.apache.manifoldcf.databaseimplementationclass"
> > value="org.apache.manifoldcf.core.database.DBInterfaceHSQLDB"/>
> >
> > Thanks in advance for help
> >
>
> ________________________________
>
> CEB is now Gartner. Learn more.<
> https://www.gartner.com/technology/about/ceb-acquisition.jsp>
> CEB India Private Ltd. Registration No: U741040HR2004PTC035324. Registered
> office: 6th Floor, Tower-B, Building No.10, DLF Cyber City, Gurgaon 122002,
> Haryana India If you are not the intended recipient or have received this
> message in error, please notify the sender and permanently delete this
> message and any attachments.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message