manifoldcf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Piergiorgio Lucidi (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (CONNECTORS-1548) CMIS output connector test fails with versioning state error
Date Thu, 25 Oct 2018 19:00:00 GMT

     [ https://issues.apache.org/jira/browse/CONNECTORS-1548?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Piergiorgio Lucidi resolved CONNECTORS-1548.
--------------------------------------------
    Resolution: Fixed

Solved in r1844857.

In one of the latest commits the CMIS Output Connector was changed in terms of managing
the versioning state policy. Now I changed it to VersioningState.NONE.

The current OpenCMIS server supports only the VersionState.NONE for the default cmis:document
type definition. Inside the current connector class I saw that with the latest updates it
was changed from VersioningState.NONE to VersioningState.MAJOR.

Probably during the last contribution from [~douglascrp] he changed it for using it with Alfresco
Community. The default value supported by OpenCMIS server is VersioningState.NONE that is
the same default for Alfresco Enterprise edition.

Here we should manage the versioning state policy using a specific field inside the connector
configuration, this because each vendor is implementing in different ways their own versioning
policy. The side effect of this is that we found in the market some platforms that is using
VersioningState.MAJOR or VersioningState.NONE as their own default.

I'll create a new issue as an improvement o add this new "Versioning State Policy" field for
choosing from a select list the related binding value in the CMIS standard.

> CMIS output connector test fails with versioning state error
> ------------------------------------------------------------
>
>                 Key: CONNECTORS-1548
>                 URL: https://issues.apache.org/jira/browse/CONNECTORS-1548
>             Project: ManifoldCF
>          Issue Type: Bug
>          Components: CMIS Output Connector
>            Reporter: Karl Wright
>            Assignee: Piergiorgio Lucidi
>            Priority: Major
>             Fix For: ManifoldCF 2.12
>
>
> While working on the upgrade to Tika 1.19.1, I ran into CMIS output connector test failures.
 Specifically, here's the trace:
> {code}
>     [junit] org.apache.manifoldcf.core.interfaces.ManifoldCFException: The versioning
state flag is imcompatible to the type definition.
>     [junit]     at org.apache.manifoldcf.agents.output.cmisoutput.CmisOutputConnector.addOrReplaceDocumentWithException(CmisOutputConnector.java:994)
> {code}
> Nested exception is:
> {code}
>     [junit] Caused by: org.apache.chemistry.opencmis.commons.exceptions.CmisConstraintException:
The versioning state flag is imcompatible to the type definition.
>     [junit]     at org.apache.chemistry.opencmis.client.bindings.spi.atompub.AbstractAtomPubService.convertStatusCode(AbstractAtomPubService.java:514)
>     [junit]     at org.apache.chemistry.opencmis.client.bindings.spi.atompub.AbstractAtomPubService.post(AbstractAtomPubService.java:717)
>     [junit]     at org.apache.chemistry.opencmis.client.bindings.spi.atompub.ObjectServiceImpl.createDocument(ObjectServiceImpl.java:122)
>     [junit]     at org.apache.chemistry.opencmis.client.runtime.SessionImpl.createDocument(SessionImpl.java:1158)
> {code}
> This may (or may not) be related to the Tika code now using a different implementation
of jaxb.  I've moved all of jaxb and its dependent classes into connector-common-lib accordingly,
and have no specific inclusions of jaxb in any connector class that would need it to be in
connector-lib.
> It has been committed to trunk; r1844137.  Please verify (or disprove) that the problem
is the new jaxb implementation.  If it is we'll need to figure out why CMIS cares which implementation
is used.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message