manifoldcf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Wright (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CONNECTORS-1454) ElasticSearch 5.5 plugin needed
Date Tue, 14 Aug 2018 10:18:00 GMT

    [ https://issues.apache.org/jira/browse/CONNECTORS-1454?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16579601#comment-16579601
] 

Karl Wright commented on CONNECTORS-1454:
-----------------------------------------

Hi [~kvrobert],

Unfortunately the APIs in ElasticSearch change so rapidly we've been unable to keep up with
them.  The last formal ES version we released a plugin for was ES 1.5, three years ago.

A plugin is a fairly simple thing to develop but requires the ability to "wrap" queries that
ES constructs with our own boolean query logic.  How you do that has changed like dreams from
one minute to the next.  I created a project, found here:

https://svn.apache.org/repos/asf/manifoldcf/integration/elasticsearch-5.5/trunk

... to work on this, but ran into problems on the port:

{code}
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:2.3.2:compile
(default-compile) on project elasticsearch-5.5-plugin-mcf: Compilation failure: Compilation
failure:
[ERROR] \wip\mcf-integration\elasticsearch-5.5\trunk\src\main\java\org\apache\manifoldcf\elasticsearch\MCFAuthorizerPlugin.java:[50,23]
error: cannot find symbol
[ERROR] \wip\mcf-integration\elasticsearch-5.5\trunk\src\main\java\org\apache\manifoldcf\elasticsearch\MCFAuthorizerRestSearchAction.java:[97,25]
error: cannot find symbol
[ERROR] \wip\mcf-integration\elasticsearch-5.5\trunk\src\main\java\org\apache\manifoldcf\elasticsearch\MCFAuthorizerRestSearchAction.java:[98,25]
error: cannot find symbol
[ERROR] \wip\mcf-integration\elasticsearch-5.5\trunk\src\main\java\org\apache\manifoldcf\elasticsearch\MCFAuthorizerRestSearchAction.java:[99,54]
error: incompatible types: String cannot be converted to SearchSourceBuilder
[ERROR] \wip\mcf-integration\elasticsearch-5.5\trunk\src\main\java\org\apache\manifoldcf\elasticsearch\MCFAuthorizerRestSearchAction.java:[107,54]
error: incompatible types: String cannot be converted to SearchSourceBuilder
[ERROR] \wip\mcf-integration\elasticsearch-5.5\trunk\src\main\java\org\apache\manifoldcf\elasticsearch\MCFAuthorizerRestSearchAction.java:[132,22]
error: method parseSearchRequest in class RestSearchAction cannot be applied to given types;
[ERROR] \wip\mcf-integration\elasticsearch-5.5\trunk\src\main\java\org\apache\manifoldcf\elasticsearch\MCFAuthorizerRestSearchAction.java:[246,27]
error: cannot find symbol
[ERROR] \wip\mcf-integration\elasticsearch-5.5\trunk\src\main\java\org\apache\manifoldcf\elasticsearch\MCFAuthorizerRestSearchAction.java:[255,31]
error: cannot find symbol
[ERROR] \wip\mcf-integration\elasticsearch-5.5\trunk\src\main\java\org\apache\manifoldcf\elasticsearch\MCFAuthorizerRestSearchAction.java:[344,65]
error: incompatible types: String[] cannot be converted to List<String>
[ERROR] \wip\mcf-integration\elasticsearch-5.5\trunk\src\main\java\org\apache\manifoldcf\elasticsearch\MCFAuthorizerRestSearchAction.java:[356,166]
error: method field in class SuggestionBuilder<T> cannot be applied to given types;
[ERROR] \wip\mcf-integration\elasticsearch-5.5\trunk\src\main\java\org\apache\manifoldcf\elasticsearch\MCFAuthorizerRestSearchAction.java:[356,226]
error: incompatible types: String cannot be converted to SuggestMode
[ERROR] \wip\mcf-integration\elasticsearch-5.5\trunk\src\main\java\org\apache\manifoldcf\elasticsearch\MCFAuthorizerPlugin.java:[50,14]
error: onModule(RestModule) in MCFAuthorizerPlugin cannot override onModule(DiscoveryModule)
in Plugin
{code}

If you know anything about ES please feel free to help us with this.  Thanks!


> ElasticSearch 5.5 plugin needed
> -------------------------------
>
>                 Key: CONNECTORS-1454
>                 URL: https://issues.apache.org/jira/browse/CONNECTORS-1454
>             Project: ManifoldCF
>          Issue Type: New Feature
>    Affects Versions: ManifoldCF 2.8
>            Reporter: Karl Wright
>            Assignee: Karl Wright
>            Priority: Major
>
> We need an ES 5.5 plugin.  The API has changed entirely since 2.0.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message