manifoldcf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Furkan KAMACI (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CONNECTORS-1316) Tika 1.13 is now out, so we need to upgrade Tika yet again
Date Mon, 15 Aug 2016 14:10:22 GMT

    [ https://issues.apache.org/jira/browse/CONNECTORS-1316?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15421008#comment-15421008
] 

Furkan KAMACI commented on CONNECTORS-1316:
-------------------------------------------

[~kwright@metacarta.com] Here is the dependency tree of tika-parsers:

{code}
[INFO] \- org.apache.tika:tika-parsers:jar:1.13:compile
[INFO]    +- org.apache.tika:tika-core:jar:1.13:compile
[INFO]    +- org.gagravarr:vorbis-java-tika:jar:0.8:compile
[INFO]    +- com.healthmarketscience.jackcess:jackcess:jar:2.1.3:compile
[INFO]    |  +- commons-lang:commons-lang:jar:2.6:compile
[INFO]    |  \- commons-logging:commons-logging:jar:1.1.3:compile
[INFO]    +- com.healthmarketscience.jackcess:jackcess-encrypt:jar:2.1.1:compile
[INFO]    +- net.sourceforge.jmatio:jmatio:jar:1.0:compile
[INFO]    +- org.apache.james:apache-mime4j-core:jar:0.7.2:compile
[INFO]    +- org.apache.james:apache-mime4j-dom:jar:0.7.2:compile
[INFO]    +- org.apache.commons:commons-compress:jar:1.11:compile
[INFO]    +- org.tukaani:xz:jar:1.5:compile
[INFO]    +- commons-codec:commons-codec:jar:1.10:compile
[INFO]    +- org.apache.pdfbox:pdfbox:jar:2.0.1:compile
[INFO]    |  \- org.apache.pdfbox:fontbox:jar:2.0.1:compile
[INFO]    +- org.apache.pdfbox:pdfbox-tools:jar:2.0.1:compile
[INFO]    |  \- org.apache.pdfbox:pdfbox-debugger:jar:2.0.1:compile
[INFO]    +- org.apache.pdfbox:jempbox:jar:1.8.12:compile
[INFO]    +- org.bouncycastle:bcmail-jdk15on:jar:1.54:compile
[INFO]    |  \- org.bouncycastle:bcpkix-jdk15on:jar:1.54:compile
[INFO]    +- org.bouncycastle:bcprov-jdk15on:jar:1.54:compile
[INFO]    +- org.apache.poi:poi:jar:3.15-beta1:compile
[INFO]    +- org.apache.poi:poi-scratchpad:jar:3.15-beta1:compile
[INFO]    +- org.apache.poi:poi-ooxml:jar:3.15-beta1:compile
[INFO]    |  +- org.apache.poi:poi-ooxml-schemas:jar:3.15-beta1:compile
[INFO]    |  |  \- org.apache.xmlbeans:xmlbeans:jar:2.6.0:compile
[INFO]    |  \- com.github.virtuald:curvesapi:jar:1.03:compile
[INFO]    +- org.ccil.cowan.tagsoup:tagsoup:jar:1.2.1:compile
[INFO]    +- org.ow2.asm:asm:jar:5.0.4:compile
[INFO]    +- com.googlecode.mp4parser:isoparser:jar:1.1.18:compile
[INFO]    +- com.drewnoakes:metadata-extractor:jar:2.8.1:compile
[INFO]    |  \- com.adobe.xmp:xmpcore:jar:5.1.2:compile
[INFO]    +- de.l3s.boilerpipe:boilerpipe:jar:1.1.0:compile
[INFO]    +- com.rometools:rome:jar:1.5.1:compile
[INFO]    |  +- com.rometools:rome-utils:jar:1.5.1:compile
[INFO]    |  \- org.slf4j:slf4j-api:jar:1.7.7:compile
[INFO]    +- org.gagravarr:vorbis-java-core:jar:0.8:compile
[INFO]    +- com.googlecode.juniversalchardet:juniversalchardet:jar:1.0.3:compile
[INFO]    +- org.codelibs:jhighlight:jar:1.0.2:compile
[INFO]    +- com.pff:java-libpst:jar:0.8.1:compile
[INFO]    +- com.github.junrar:junrar:jar:0.7:compile
[INFO]    |  +- commons-logging:commons-logging-api:jar:1.1:compile
[INFO]    |  \- org.apache.commons:commons-vfs2:jar:2.0:compile
[INFO]    |     +- org.apache.maven.scm:maven-scm-api:jar:1.4:compile
[INFO]    |     |  \- org.codehaus.plexus:plexus-utils:jar:1.5.6:compile
[INFO]    |     \- org.apache.maven.scm:maven-scm-provider-svnexe:jar:1.4:compile
[INFO]    |        +- org.apache.maven.scm:maven-scm-provider-svn-commons:jar:1.4:compile
[INFO]    |        \- regexp:regexp:jar:1.3:compile
[INFO]    +- org.apache.cxf:cxf-rt-rs-client:jar:3.0.3:compile
[INFO]    |  +- org.apache.cxf:cxf-rt-transports-http:jar:3.0.3:compile
[INFO]    |  +- org.apache.cxf:cxf-core:jar:3.0.3:compile
[INFO]    |  |  +- org.codehaus.woodstox:woodstox-core-asl:jar:4.4.1:compile
[INFO]    |  |  |  \- org.codehaus.woodstox:stax2-api:jar:3.1.4:compile
[INFO]    |  |  \- org.apache.ws.xmlschema:xmlschema-core:jar:2.1.0:compile
[INFO]    |  \- org.apache.cxf:cxf-rt-frontend-jaxrs:jar:3.0.3:compile
[INFO]    |     +- javax.ws.rs:javax.ws.rs-api:jar:2.0.1:compile
[INFO]    |     \- javax.annotation:javax.annotation-api:jar:1.2:compile
[INFO]    +- org.apache.opennlp:opennlp-tools:jar:1.5.3:compile
[INFO]    |  +- org.apache.opennlp:opennlp-maxent:jar:3.0.3:compile
[INFO]    |  \- net.sf.jwordnet:jwnl:jar:1.3.3:compile
[INFO]    +- commons-io:commons-io:jar:2.4:compile
[INFO]    +- org.apache.commons:commons-exec:jar:1.3:compile
[INFO]    +- com.googlecode.json-simple:json-simple:jar:1.1.1:compile
[INFO]    +- org.json:json:jar:20140107:compile
[INFO]    +- com.google.code.gson:gson:jar:2.2.4:compile
[INFO]    +- edu.ucar:netcdf4:jar:4.5.5:compile
[INFO]    |  +- net.jcip:jcip-annotations:jar:1.0:compile
[INFO]    |  \- net.java.dev.jna:jna:jar:4.1.0:compile
[INFO]    +- edu.ucar:grib:jar:4.5.5:compile
[INFO]    |  +- com.google.protobuf:protobuf-java:jar:2.5.0:compile
[INFO]    |  +- org.jdom:jdom2:jar:2.0.4:compile
[INFO]    |  +- org.jsoup:jsoup:jar:1.7.2:compile
[INFO]    |  +- edu.ucar:jj2000:jar:5.2:compile
[INFO]    |  \- org.itadaki:bzip2:jar:0.9.1:compile
[INFO]    +- edu.ucar:cdm:jar:4.5.5:compile
[INFO]    |  +- edu.ucar:udunits:jar:4.5.5:compile
[INFO]    |  +- org.apache.httpcomponents:httpcore:jar:4.2.5:compile
[INFO]    |  +- joda-time:joda-time:jar:2.2:compile
[INFO]    |  +- org.quartz-scheduler:quartz:jar:2.2.0:compile
[INFO]    |  |  \- c3p0:c3p0:jar:0.9.1.1:compile
[INFO]    |  +- net.sf.ehcache:ehcache-core:jar:2.6.2:compile
[INFO]    |  +- com.google.guava:guava:jar:17.0:compile
[INFO]    |  \- com.beust:jcommander:jar:1.35:compile
[INFO]    +- edu.ucar:httpservices:jar:4.5.5:compile
[INFO]    |  +- org.apache.httpcomponents:httpclient:jar:4.2.6:compile
[INFO]    |  \- org.apache.httpcomponents:httpmime:jar:4.2.6:compile
[INFO]    +- org.apache.commons:commons-csv:jar:1.0:compile
[INFO]    +- org.apache.sis.core:sis-utility:jar:0.6:compile
[INFO]    +- org.apache.sis.storage:sis-netcdf:jar:0.6:compile
[INFO]    |  +- org.apache.sis.storage:sis-storage:jar:0.6:compile
[INFO]    |  \- org.apache.sis.core:sis-referencing:jar:0.6:compile
[INFO]    +- org.apache.sis.core:sis-metadata:jar:0.6:compile
[INFO]    +- org.opengis:geoapi:jar:3.0.0:compile
[INFO]    |  \- javax.measure:jsr-275:jar:0.9.3:compile
[INFO]    \- com.fasterxml.jackson.core:jackson-core:jar:2.7.1:compile
{code}

You can see that curves-api comes within:

{code}
[INFO]    +- org.apache.poi:poi-ooxml:jar:3.15-beta1:compile
[INFO]    |  +- org.apache.poi:poi-ooxml-schemas:jar:3.15-beta1:compile
[INFO]    |  |  \- org.apache.xmlbeans:xmlbeans:jar:2.6.0:compile
[INFO]    |  \- com.github.virtuald:curvesapi:jar:1.03:compile
{code}

So, it is not directly placed as a separate jar under lib folder. However its been used and
listed at META-INF/DEPENDENCIES at tika-parsers. If you want, I can remove the license definitions
for such kind of jars which are not directly placed under lib folder?

> Tika 1.13 is now out, so we need to upgrade Tika yet again
> ----------------------------------------------------------
>
>                 Key: CONNECTORS-1316
>                 URL: https://issues.apache.org/jira/browse/CONNECTORS-1316
>             Project: ManifoldCF
>          Issue Type: Improvement
>          Components: Tika extractor
>    Affects Versions: ManifoldCF 2.4
>            Reporter: Karl Wright
>            Assignee: Karl Wright
>             Fix For: ManifoldCF 2.6
>
>         Attachments: CONNECTORS-1316.patch
>
>
> Tika 1.13 is now out, so we need to upgrade Tika yet again.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message