manifoldcf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Karl Wright <daddy...@gmail.com>
Subject Re: rat-sources not working?
Date Wed, 27 Apr 2016 18:07:10 GMT
Hmm, it doesn't complain for me either:

Buildfile: C:\wip\mcf\trunk\build.xml
Trying to override old definition of task javac

-taskdef:

rat-sources:
[rat:report]
[rat:report] *****************************************************
[rat:report] Summary
[rat:report] -------
[rat:report] Generated at: 2016-04-27T14:04:29-04:00
[rat:report] Notes: 6
[rat:report] Binaries: 672
[rat:report] Archives: 0
[rat:report] Standards: 877
[rat:report]
[rat:report] Apache Licensed: 876
[rat:report] Generated Documents: 0
[rat:report]
[rat:report] JavaDocs are generated and so license header is optional
[rat:report] Generated files do not required license headers
[rat:report]
[rat:report] 0 Unknown Licenses
[rat:report]


But it looks like somebody power-disabled it in build.xml:

        <fileset dir="connectors/">
          <exclude name="**/*"/>

Spelunking now...

Karl


On Wed, Apr 27, 2016 at 1:21 PM, Ahmet Arslan <iorixxx@yahoo.com.invalid>
wrote:

> Hi,
>
> I accidentally notice that SearchBloxConfig.java lacks Apache licene
> header.
> I go back and run 'ant rat-sources'. However it does not complain about
> SearchBloxConfig but prints a lot of *.js and *.css for me.
>
> I remember rat sources reported missing header before for me. Did it stop
> working?
> I use macos by the way.
>
> Thanks,
> Ahmet
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message