manifoldcf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aeham Abushwashi (JIRA)" <j...@apache.org>
Subject [jira] [Created] (CONNECTORS-1240) Building earlier branches fails
Date Tue, 15 Sep 2015 13:17:45 GMT
Aeham Abushwashi created CONNECTORS-1240:
--------------------------------------------

             Summary: Building earlier branches fails
                 Key: CONNECTORS-1240
                 URL: https://issues.apache.org/jira/browse/CONNECTORS-1240
             Project: ManifoldCF
          Issue Type: Bug
          Components: Build
    Affects Versions: ManifoldCF 1.8
            Reporter: Aeham Abushwashi


Some binary dependencies, specifically elasticseach plugin 2.1 and solr plugin 2.1, appear
to have been removed from the manifold download site. This causes a build of an earlier version
of manifold, e.g. 1.8, to fail as ant is unable to download those artifacts.

If reinstating the deleted files is out of the question, I could workaround the problem easily
enough by editing the build script to download the latest versions of each plugin, assuming
these are backwards compatible (?). In which case, could someone please confirm that the attached
patch is acceptable? Please note that my deployment of manifold doesn't interact with Elasticsearch
or Solr (not directly or knowingly anyway).

Thanks,
Aeham



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message