manifoldcf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Wright (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CONNECTORS-1201) Difficulty setting up file-based synchronization
Date Thu, 21 May 2015 00:33:59 GMT

    [ https://issues.apache.org/jira/browse/CONNECTORS-1201?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14553423#comment-14553423
] 

Karl Wright commented on CONNECTORS-1201:
-----------------------------------------

Ok, I see you added MCF version and OS info into the ticket.

If you really must use file-based synchronization (which is now officially deprecated), I
would check the following:

(1) Try running the jetty-based multiprocess-file-example on your Centos system, with HSQLDB.
 Make sure you start all processes as the same user.  Does this work for you?
(2) If (1) works, then as a next step, try running the UI component ONLY under tomcat.  Make
sure that tomcat also runs as the same user as your other processes.  Does this work for you?
(3) If it does work, change whatever else you need to change, one thing at a time.
(4) ALWAYS be sure to shut down MCF processes using soft-shutdown procedures, NEVER "kill
-9".  If you have to do kill -9, then do a lock clean procedure, as described earlier.


I'd consider strongly using Zookeeper, since it has far fewer restrictions and far better
recovery ability.




> Difficulty setting up file-based synchronization
> ------------------------------------------------
>
>                 Key: CONNECTORS-1201
>                 URL: https://issues.apache.org/jira/browse/CONNECTORS-1201
>             Project: ManifoldCF
>          Issue Type: Bug
>          Components: Active Directory authority
>    Affects Versions: ManifoldCF 1.9
>         Environment: CentOS 6 64bit 
> 8 x Intel(R) Xeon(R) CPU X7460 @ 2.66GHz
> 8Gb RAM
>            Reporter: Dmitry Bardin
>
> Hi!
> I tried to create/edit existing auth connection with active directory type but after
typing all parameters began long running request which never finished. Maybe exist a workaround?
To be honest, I meet this situation not only with auth connections. Also repo connections.
This are unpredictable long running requests



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message