manifoldcf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Wright (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CONNECTORS-947) ElasticSearch connector tests fail to compile when ant test is run without make-deps
Date Thu, 29 May 2014 01:32:02 GMT

    [ https://issues.apache.org/jira/browse/CONNECTORS-947?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14011941#comment-14011941
] 

Karl Wright commented on CONNECTORS-947:
----------------------------------------

r1598192 (release branch)

> ElasticSearch connector tests fail to compile when ant test is run without make-deps
> ------------------------------------------------------------------------------------
>
>                 Key: CONNECTORS-947
>                 URL: https://issues.apache.org/jira/browse/CONNECTORS-947
>             Project: ManifoldCF
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: ManifoldCF 1.6
>            Reporter: Karl Wright
>            Assignee: Karl Wright
>            Priority: Blocker
>             Fix For: ManifoldCF 1.6.1, ManifoldCF 1.7
>
>
> On a fresh checkout, run "ant make-core-deps test".  The build fails on the Elastic Search
connector, as follows:
> {code}
> BUILD FAILED
> C:\wip\mcf\release-1.6-branch\build.xml:265: The following error occurred while executing
this line:
> C:\wip\mcf\release-1.6-branch\build.xml:239: The following error occurred while executing
this line:
> C:\wip\mcf\release-1.6-branch\dist\connector-build.xml:533: C:\wip\mcf\release-1.6-branch\connectors\elasticsearch\test-materials-proprietary\elasticsearch-1.0.1
does not exist.
> {code}
> The conditional compilation of tests seems to not be working right in connector-build.xml.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message