manifoldcf-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ahmet Arslan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CONNECTORS-935) ant build files mention 1.6 as source and target
Date Sat, 03 May 2014 12:47:14 GMT

    [ https://issues.apache.org/jira/browse/CONNECTORS-935?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13988668#comment-13988668
] 

Ahmet Arslan commented on CONNECTORS-935:
-----------------------------------------

Thanks for the explanations. 

bq. I never did understand the java 6 warning; it seems like there is some feature (bootstrap??)
which we were not specifying properly. I did not expect the warnings to go away if java 7
was specified.

As I understand, these warnings happen when we specify older java version (without bootstrap
parameter set) than the installed one. For example I have java7 installed. But in build.xml
we are saying source="1.6" and target="1.6" without bootstrap parameter set.

bq. but we have no java 7 source constructs (yet) anywhere in our code base

We have CONNECTORS-931 . I expect addition of StandardCharsets would break compilation.

> ant build files mention 1.6 as source and target
> ------------------------------------------------
>
>                 Key: CONNECTORS-935
>                 URL: https://issues.apache.org/jira/browse/CONNECTORS-935
>             Project: ManifoldCF
>          Issue Type: Task
>          Components: Build
>    Affects Versions: ManifoldCF 1.6
>         Environment: java version "1.7.0_55"
> Java(TM) SE Runtime Environment (build 1.7.0_55-b13)
> Java HotSpot(TM) 64-Bit Server VM (build 24.55-b03, mixed mode)
> Mac OS X Version 10.7.5
>            Reporter: Ahmet Arslan
>            Priority: Minor
>             Fix For: ManifoldCF 1.7
>
>         Attachments: CONNECTORS-935.patch
>
>
> I was getting following annoying warning {noformat}warning: [options] bootstrap class
path not set in conjunction with -source 1.6 {noformat} Further investigation revealed that
some ant build.xml files mentions.
> {code:xml}
> <javac  target="1.6" source="1.6" />
> {code}
> We are on java7. Lets get rid of this warning message.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message