manifoldcf-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kwri...@apache.org
Subject svn commit: r1807130 - in /manifoldcf/integration/elasticsearch-5.5/trunk: CHANGES.txt DEPENDENCIES.txt NOTICE.txt README.txt pom.xml
Date Sun, 03 Sep 2017 09:06:57 GMT
Author: kwright
Date: Sun Sep  3 09:06:57 2017
New Revision: 1807130

URL: http://svn.apache.org/viewvc?rev=1807130&view=rev
Log:
Update package names etc.

Modified:
    manifoldcf/integration/elasticsearch-5.5/trunk/CHANGES.txt
    manifoldcf/integration/elasticsearch-5.5/trunk/DEPENDENCIES.txt
    manifoldcf/integration/elasticsearch-5.5/trunk/NOTICE.txt
    manifoldcf/integration/elasticsearch-5.5/trunk/README.txt
    manifoldcf/integration/elasticsearch-5.5/trunk/pom.xml

Modified: manifoldcf/integration/elasticsearch-5.5/trunk/CHANGES.txt
URL: http://svn.apache.org/viewvc/manifoldcf/integration/elasticsearch-5.5/trunk/CHANGES.txt?rev=1807130&r1=1807129&r2=1807130&view=diff
==============================================================================
--- manifoldcf/integration/elasticsearch-5.5/trunk/CHANGES.txt (original)
+++ manifoldcf/integration/elasticsearch-5.5/trunk/CHANGES.txt Sun Sep  3 09:06:57 2017
@@ -1,4 +1,4 @@
-Apache ManifoldCF Plugin for Elastic Search change Log
+Apache ManifoldCF Plugin for Elastic Search 5.5 change Log
 $Id$
 
 ======================= 2.1-SNAPSHOT =====================

Modified: manifoldcf/integration/elasticsearch-5.5/trunk/DEPENDENCIES.txt
URL: http://svn.apache.org/viewvc/manifoldcf/integration/elasticsearch-5.5/trunk/DEPENDENCIES.txt?rev=1807130&r1=1807129&r2=1807130&view=diff
==============================================================================
--- manifoldcf/integration/elasticsearch-5.5/trunk/DEPENDENCIES.txt (original)
+++ manifoldcf/integration/elasticsearch-5.5/trunk/DEPENDENCIES.txt Sun Sep  3 09:06:57 2017
@@ -1,6 +1,6 @@
-Apache ManifoldCF Plugin for Elastic Search requires
---------------------------------------------------
-* JRE 1.7 or above
+Apache ManifoldCF Plugin for Elastic Search 5.5 requires
+------------------------------------------------------
+* JRE 1.8 or above
 * mvn 2.2 or higher
 
 For building Apache ManifoldCF Plugin for Elastic Search:

Modified: manifoldcf/integration/elasticsearch-5.5/trunk/NOTICE.txt
URL: http://svn.apache.org/viewvc/manifoldcf/integration/elasticsearch-5.5/trunk/NOTICE.txt?rev=1807130&r1=1807129&r2=1807130&view=diff
==============================================================================
--- manifoldcf/integration/elasticsearch-5.5/trunk/NOTICE.txt (original)
+++ manifoldcf/integration/elasticsearch-5.5/trunk/NOTICE.txt Sun Sep  3 09:06:57 2017
@@ -1,4 +1,4 @@
-Apache ManifoldCF Plugin for Elastic Search
+Apache ManifoldCF Plugin for Elastic Search 5.5
 Copyright 2010-2017 The Apache Software Foundation
 
 This product includes software developed by

Modified: manifoldcf/integration/elasticsearch-5.5/trunk/README.txt
URL: http://svn.apache.org/viewvc/manifoldcf/integration/elasticsearch-5.5/trunk/README.txt?rev=1807130&r1=1807129&r2=1807130&view=diff
==============================================================================
--- manifoldcf/integration/elasticsearch-5.5/trunk/README.txt (original)
+++ manifoldcf/integration/elasticsearch-5.5/trunk/README.txt Sun Sep  3 09:06:57 2017
@@ -17,16 +17,16 @@ Compatibility
 ------------
 
 This version of this component is fully functional with Apache ManifoldCF 1.6 and
-above and with Elasticsearch 2.x.
+above and with Elasticsearch 5.5.
 
 Instructions for Building Apache ManifoldCF Plugin for Elastic Search from Source
 -----------------------------------------------------------------------------
 
-1. Download the Java SE 7 JDK (Java Development Kit), or greater, from
+1. Download the Java SE 8 JDK (Java Development Kit), or greater, from
    http://www.oracle.com/technetwork/java/index.html.
    You will need the JDK installed, and the %JAVA_HOME%\bin directory included
    on your command path.  To test this, issue a "java -version" command from your
-   shell and verify that the Java version is 1.7 or greater.
+   shell and verify that the Java version is 1.8 or greater.
 
 2. Download and install Maven 2.2.1 or later.  Maven installation and configuration
    instructions can be found here:
@@ -42,7 +42,7 @@ mvn clean install
 
 The JAR packages can be found in the target folder:
 
-target/elasticsearch-2.0-plugin-mcf-<VERSION>-jar-with-dependencies.jar
+target/elasticsearch-5.5-plugin-mcf-<VERSION>-jar-with-dependencies.jar
 
 ... where <VERSION> is the release version
 
@@ -141,7 +141,7 @@ public class SearchService {
 Licensing
 ---------
 
-Apache ManifoldCF Plugin for Elastic Search 2.0 is licensed under the
+Apache ManifoldCF Plugin for Elastic Search 5.5 is licensed under the
 Apache License 2.0. See the files called LICENSE.txt and NOTICE.txt
 for more information.
 

Modified: manifoldcf/integration/elasticsearch-5.5/trunk/pom.xml
URL: http://svn.apache.org/viewvc/manifoldcf/integration/elasticsearch-5.5/trunk/pom.xml?rev=1807130&r1=1807129&r2=1807130&view=diff
==============================================================================
--- manifoldcf/integration/elasticsearch-5.5/trunk/pom.xml (original)
+++ manifoldcf/integration/elasticsearch-5.5/trunk/pom.xml Sun Sep  3 09:06:57 2017
@@ -30,11 +30,11 @@
   <groupId>org.apache.manifoldcf.elasticsearch</groupId>
 
   <name>ManifoldCF ElasticSearch Plugin</name>
-  <artifactId>elasticsearch-2.0-plugin-mcf</artifactId>
+  <artifactId>elasticsearch-5.5-plugin-mcf</artifactId>
   <version>2.1-SNAPSHOT</version>
   <packaging>jar</packaging>
-  <description>ManifoldCF Plugin for ElasticSearch 2.0</description>
-  <inceptionYear>2016</inceptionYear>
+  <description>ManifoldCF Plugin for ElasticSearch 5.5</description>
+  <inceptionYear>2017</inceptionYear>
 
   <organization>
     <name>The Apache Software Foundation</name>
@@ -43,7 +43,7 @@
 
   <!-- Move these to the parent pom, when I create a parent pom -->
   <properties>
-    <elasticsearch.version>2.0.2</elasticsearch.version>
+    <elasticsearch.version>5.5.2</elasticsearch.version>
     <junit.version>4.8.2</junit.version>
     <log4j.version>1.2.16</log4j.version>
     <httpcomponent.version>4.4.1</httpcomponent.version>



Mime
View raw message