mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jyotiranjan panda <tell2jy...@gmail.com>
Subject compatibility of hadoop and mahout version
Date Mon, 27 Oct 2014 05:34:07 GMT
Hi,
I have just started mahout learning last week.
I am facing lots of problem in executing sample examples in mahout, before
I ask those errors, I want to confirm about the version compatibility of
demons.

I am using Apache Hadoop-2.3.0 with Mahout-distrubution-0.9 in ubuntu14.04
32 bit Laptop.
while running Mahout on command I don’t get any errors and it gives me all
the valid program names as output.But while executing a clustering example
it gives error as below.

---------------------------------------------------------------------------
hduser@localhostjp:/usr/local/hadoop$ hadoop jar mahouttest.jar
Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/mahout/math/Vector
    at java.lang.Class.forName0(Native Method)
    at java.lang.Class.forName(Class.java:270)
    at org.apache.hadoop.util.RunJar.main(RunJar.java:205)
Caused by: java.lang.ClassNotFoundException: org.apache.mahout.math.Vector
    at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
    ... 3 more
-----------------------------------------------------------------------------------------------------------

Regards
JyotiRanjan Panda

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message