mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tom LAMPERT <t.lamp...@laboquantup.eu>
Subject RE: lucene2seq and empty fields
Date Mon, 01 Sep 2014 16:48:30 GMT
An update of my progress...

I have worked around the problem of not being able to specify multiple fields in the mahout
trunk version: I needed to encompass multiple fields with quotation marks for the command
to work (specifically under windows). And this now partly solves my first problem in that
the trunk version does not complain about empty fields. Nevertheless, I cannot resolve the
issue for Mahout 0.9. Possibly this is a bug for which there isn't a workaround and the only
solution is to wait for Mahout 1.0?


________________________________________
From: Tom LAMPERT
Sent: 30 August 2014 17:43
To: user@mahout.apache.org
Subject: RE: lucene2seq and empty fields

I have this problem using 0.9 (using the Hortonworks Sandbox v2.1).

I have also tried using the trunk version under windows but that gives me the following (different)
error when using multiple fields (using the same command format as 0.9):

    Unexpected YYYY while processing Job-Specific Options:

The command format that I've used (for both versions) is:

    mahout lucene2seq -i /inputdir -o /outputdir -id idfield -f XXXX,YYYY -q tableName:table1

to reiterate, this command works on version 0.9 using the same data (although it falls over
if YYYY is empty in some documents).

________________________________________
From: Suneel Marthi <suneel.marthi@gmail.com>
Sent: 30 August 2014 00:05
To: user@mahout.apache.org
Subject: Re: lucene2seq and empty fields

Which Mahout version?


On Sat, Aug 30, 2014 at 12:32 AM, Tom LAMPERT <t.lampert@laboquantup.eu>
wrote:

> Hi all,
>
>
> I have running into a problem with lucene2seq and I'm wondering whether
> any of you can help me. I have a Solr index in which the documents contain
> several fields and some of these fields are empty in some of the documents.
> The problem that I am encountering is that lucene2seq gives the error:
>
>
> Error: java.lang.IllegalArgumentException: Field 'XXXXXXX' does not exist
> in the index?
>
>
> when an empty field is encountered. I have verified that the field exists
> by querying the Solr (but as I have said, it is empty). Can anyone help
> with this?
>
>
> Thanks,
>
>
> Tom
>
Mime
View raw message