mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Diego Ceccarelli <diego.ceccare...@gmail.com>
Subject Re: Using Mahout with Hadoop 0.23
Date Mon, 29 Oct 2012 19:06:41 GMT
Hi Sean,
I took a look to the profiles and in core there is this 'hadoop-0.23' but if I
try to compile:

mvn -P hadoop-0.23 install -DskipTests

Maven returns with this weird error:

[ERROR] Failed to execute goal on project mahout-core: Could not
resolve dependencies for project
org.apache.mahout:mahout-core:jar:0.8-SNAPSHOT: The following
artifacts could not be resolved:
org.apache.hadoop:hadoop-common:jar:1.0.4,
org.apache.hadoop:hadoop-mapreduce-client-common:jar:1.0.4,
org.apache.hadoop:hadoop-mapreduce-client-core:jar:1.0.4: Failure to
find org.apache.hadoop:hadoop-common:jar:1.0.4 in
http://repo1.maven.org/maven2 was cached in the local repository,
resolution will not be reattempted until the update interval of
central has elapsed or updates are forced -> [Help 1]

(seems that it is looking for the wrong version of hadoop..)
I also tried to replace the property hadoop.version in the main pom,
but it seems that there is not
hadoop 0.23* in maven central, and I'm not able to find a the a jar to
install it in my local repo :((
At the end I tried with 0.20.2, and I was able to compile but I got
the same previous error
when I launched mahout :P



On Mon, Oct 29, 2012 at 7:14 PM, Sean Owen <srowen@gmail.com> wrote:
> I don't think anyone has tried 0.23 in force because it (and the 2.0
> branch) are still alpha. But I don't know a strong reason it wouldn't work
> other than you have to compile against 0.23 not the current supported
> version (1.0.4). And I think someone even added a Maven profile to select
> the 0.23 version as the dependency. It is not just a matter of changing the
> version in pom.xml since the artifacts split and changed names. Dig around
> in pom.xml  to see what I mean.
> On Oct 29, 2012 6:07 PM, "Diego Ceccarelli" <diego.ceccarelli@gmail.com>
> wrote:
>
>> Dear all,
>>
>> I'm trying to run mahout on a cluster with hadoop 0.23
>> I set all the environment variables but when I run the job
>> i got this error:
>>
>> Exception in thread "main" java.lang.NoSuchMethodError:
>> org.apache.hadoop.util.ProgramDriver.driver([Ljava/lang/String;)V
>>         at
>> org.apache.mahout.driver.MahoutDriver.main(MahoutDriver.java:195)
>>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>>         at
>> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>>         at
>> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>>         at java.lang.reflect.Method.invoke(Method.java:597)
>>         at org.apache.hadoop.util.RunJar.main(RunJar.java:208)
>>
>> I tried both mahout 0.0.7 and 0.0.8-SNAPSHOT, with the same result
>> It is normal that MAHOUT-JOB takes mahout-examples-0.8-SNAPSHOT-job.jar?
>>
>> Thanks,
>> Diego
>>



-- 
Computers are useless. They can only give you answers.
(Pablo Picasso)
_______________
Diego Ceccarelli
High Performance Computing Laboratory
Information Science and Technologies Institute (ISTI)
Italian National Research Council (CNR)
Via Moruzzi, 1
56124 - Pisa - Italy

Phone: +39 050 315 3055
Fax: +39 050 315 2040
________________________________________

Mime
View raw message