mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Owen <sro...@gmail.com>
Subject Re: compiling Mahout in Intellij IDE
Date Wed, 06 Jun 2012 10:16:54 GMT
The error from Maven indicates your installation is messed up.

No you do not need to install Hadoop. But Mahout needs Hadoop to
compile. Maven takes care of that for you, and it just works.

It sounds like you have a Maven problem locally.

On Wed, Jun 6, 2012 at 11:14 AM, Yaprak Ayazoglu
<yaprak.ayazoglu@gmail.com> wrote:
> Hi Filippo,
>
> I tried to look at the version of the maven as below, but it gives some
> error
> that I do not understand. Does it mean that it cannot find the path of
> maven?
>
> ya@yaprak:~$ mvn -v
> Error: Could not find or load main class org.codehaus.classworlds.Launcher
>
> Hi Sean,
>
> Do I need to install hadoop yet? Or, when I checkout the mahout project it
> will
> download the required jar files for me?
>
> By the way, I attached the topmost .pom file.
>
>
> On Wed, Jun 6, 2012 at 1:01 PM, Filippo Diotalevi <filippo@ntoklo.com>
> wrote:
>>
>> Hi,
>> have you tried
>> "mvn clean install"
>> ?
>>
>> Which version of Maven are you running?
>>
>> --
>> Filippo Diotalevi
>>
>>
>> On Wednesday, 6 June 2012 at 10:58, Yaprak Ayazoglu wrote:
>>
>> > Hi,
>> >
>> > I'm a newbie for Mahout project. I'm trying to "compile" the Mahout
>> > project.
>> > However, I'm facing some problems at maven dependencies.
>> >
>> > Let me tell the procedure that I follow when I'm downloading Mahout
>> > project:
>> >
>> > I check out the Mahout project from git hub. Intellij successfully
>> > clones
>> > the
>> > Mahout project from github.
>> >
>> > However, in pom.xml it gives errors in the lines below:
>> > ...
>> > <groupId>org.apache.hadoop</groupId>
>> > <artifactId>hadoop-common</artifactId>
>> > <version>${hadoop.version}</version>
>> > ...
>> > <dependency>
>> > <groupId>org.apache.hadoop</groupId>
>> > <artifactId>hadoop-mapreduce-client-core</artifactId>
>> > <version>${hadoop.version}</version>
>> > </dependency>
>> > <dependency>
>> > <groupId>org.apache.hadoop</groupId>
>> > <artifactId>hadoop-mapreduce-client-common</artifactId>
>> > <version>${hadoop.version}</version>
>> > </dependency>
>> > ...
>> > <skipTests>${skipTests}</skipTests>
>> > ...
>> > etc.
>> >
>> > In the hadoop case, I know that I somehow have to install hadoop
>> > project.
>> > But I dont
>> > know why I have to install it?
>> >
>> > Is there a simple way to compile Mahout? Is there a good documentation
>> > at
>> > web?
>> >
>> > Thanks.
>> > --
>> > Yaprak
>> >
>> >
>>
>>
>
>
>
> --
> Yaprak
>

Mime
View raw message