mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Brickley <dan...@danbri.org>
Subject Re: Problems running examples
Date Fri, 02 Sep 2011 09:05:40 GMT
Hi Jeff,

On 31 August 2011 22:32, Jeff Eastman <jeastman@narus.com> wrote:
> No I never did. I got distracted doing something else and did not debug further. If you
are still seeing this on trunk then we should (re)open a JIRA.

I spent a bit more time on this, and the problem (at least for me)
seems to me to be HADOOP_CONF_DIR. The bin/mahout script is appending
it to classpath, and when it points to a legitimate Hadoop conf/
directory, something in mahout notices and switches to clustered
behaviour.

Could you take a look at
https://issues.apache.org/jira/browse/MAHOUT-800 (and suggested
patch). Does this relate to your problems?

Dan

> Jeff
>
> -----Original Message-----
> From: danbri2011@danbri.org [mailto:danbri2011@danbri.org] On Behalf Of Dan Brickley
> Sent: Wednesday, August 31, 2011 12:16 PM
> To: Jeff Eastman
> Cc: user@mahout.apache.org
> Subject: Re: Problems running examples
>
> On 10 June 2011 18:34, Jeff Eastman <jeastman@narus.com> wrote:
>> I'm still trying to figure out why reuters-0.5 does not work on either of my clusters.
The scripts themselves have no diff and the environment variables are set as in trunk except
for MAHOUT_HOME. The synthetic control and 20 newsgroups examples run on both clusters without
problems (well, 20 newsgroups has a Version Mismatch error on CDH3, but that is another story).
But when I run reuters on 0.5 I see "MAHOUT_LOCAL is set, running locally" followed by file
IO exceptions in MahoutDriver that are cluster dependent. When I run it on trunk, I don't
see this and it works just fine.
>
> Did you get to the bottom of this? I'm running a freshly built trunk,
> compiled today with a new ~/.m2 (and I reinstalled my hadoop just in
> case). Initially I was expecting the build-reuters.sh demos to run on
> hadoop, but I googled errors and found my way to this thread as you've
> the same errors, which suggests they'll only work locally. FWIW re
> clustered mode, I have a hadoop pseudo-cluster running on my laptop
> alongside mahout, and have pig and other things talking to it fine.
>
> I have btw had build-reuters.sh run kmeans on another -real- cluster
> quite happily (and have just done that again, to make sure). Not sure
> what's wrong with the Mac one, nor why
> the same run of the script on my laptop tells me both "no HADOOP_HOME
> set, running locally" and also "Call to localhost/127.0.0.1:9000
> failed on local exception: java.io.EOFException".  From re-reading
> this thread I seem to be following in your footsteps...
>
> Thanks for any pointers / update,
>
> cheers,
>
> Dan
>

Mime
View raw message