mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken Krugler <kkrugler_li...@transpac.com>
Subject Re: Hadoop version compatibility.
Date Fri, 01 Jul 2011 16:31:46 GMT

On Jul 1, 2011, at 8:51am, Ted Dunning wrote:

> You have to watch out, however, because Hadoop wire format changes pretty
> often.

Exactly.

E.g. stock Hadoop 0.20.2 installed on a machine has problems talking to the JobTracker on
a cluster running CDH3 u0, even though CHD3 is 0.20.2 + patches.

-- Ken

> 
> On Fri, Jul 1, 2011 at 7:21 AM, Xiaobo Gu <guxiaobo1982@gmail.com> wrote:
> 
>> I mean mahout using the higher version of Hadoop libraries connecting
>> to a lower version of Hadoop cluster.
>> 
>> On Fri, Jul 1, 2011 at 8:42 PM, Sean Owen <srowen@gmail.com> wrote:
>>> Yes, it's still compatible.
>>> 
>>> On Fri, Jul 1, 2011 at 1:35 PM, Xiaobo Gu <guxiaobo1982@gmail.com>
>> wrote:
>>>> Hi,
>>>> 
>>>> Since the trunk of Mahout has moved to Hadoop 0.20.203, can we still
>>>> let Mahout connect to a lower version of Hadoop backend, such as
>>>> 0.20.2?
>>>> 
>>>> Regards,
>>>> 
>>>> Xiaobo Gu
>>>> 
>>> 
>> 

--------------------------
Ken Krugler
+1 530-210-6378
http://bixolabs.com
custom data mining solutions







Mime
View raw message