mahout-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Weishung Chung <weish...@gmail.com>
Subject Re: cardinality vs size
Date Sat, 12 Feb 2011 01:34:20 GMT
sounds good to me :)

On Fri, Feb 11, 2011 at 6:46 PM, Sebastian Schelter <ssc@apache.org> wrote:

> Any objections to that? I'd go for a quick refactoring without a jira if no
> one objects.
>
> --sebastian
>
>
> On 11.02.2011 22:36, Ted Dunning wrote:
>
>> +10!!
>>
>> On Fri, Feb 11, 2011 at 10:13 AM, Sebastian Schelter <ssc@apache.org
>> <mailto:ssc@apache.org>> wrote:
>>
>>    Maybe we should rename them to something like dimension and
>>    initialCapacity then?
>>
>>    --sebastian
>>
>>
>>    On 11.02.2011 18:49, Weishung Chung wrote:
>>
>>        Thanks a lot for the explanation. This really helps me out :)
>>
>>        On Fri, Feb 11, 2011 at 11:38 AM, Ted
>>        Dunning<ted.dunning@gmail.com <mailto:ted.dunning@gmail.com>>
>>
>>          wrote:
>>
>>            Argh!
>>
>>            This is a really confusing API.
>>
>>            Cardinality is the dimension of the vector.
>>
>>            Size is the number of storage elements that you want to have
>>            in the vector
>>            initially, much in the style of ArrayList where you specify
>>            how many
>>            elements to pre-allocate.
>>
>>            On Fri, Feb 11, 2011 at 8:33 AM, Weishung
>>            Chung<weishung@gmail.com <mailto:weishung@gmail.com>>
>>
>>            wrote:
>>
>>                Is cardinality the original size of the vector including
>>                zeros and size
>>
>>            is
>>
>>                the number of nonzeros in the vector?
>>                I am referring to
>>
>>                  public RandomAccessSparseVector(int cardinality, int
>> size)
>>
>>                Thank you :)
>>
>>
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message